none
Error: Internet Explorer cannot download ...ed.ReportViewerWebControl.axd from site

    Question

  • I have created a local report and used ReportViewer Web control. The Export to Excel and PDF functionality is working fine on developer machine. But I am getting the above error in test environment. I have installed .Net 2.0 and ran Reportviewer.exe on test machine.

    Any one can know the solution for this?

     

    Thanks,

    Jitendra

    Friday, January 05, 2007 11:56 AM

All replies

  • I know this is a pretty old post, but seeing as it never got answered and doing other web searches I havent seen an answer I thought Id put my 2cents in..

     

    I recently experienced the exact same error message in my app. My issue, which may not be the same as yours, was a SSL problem.

     

    My production environment for the report is SSL protected, so the issue is a browser cache issue. As I understand it, SSL docuemtns generally wont cache. Since SSL wont cache the secured document there is nothing to reference, resulting in the error message.

     

    Solution:

     

    From Internet Explorer, go to: tools/internet options/advanced/got to the security section/uncheck “do not save encrypted pages”

     

    This solved the issue for me. If you are not in an SSL environment, then i guess this probable wont work for you!!

     

    • Proposed as answer by Andrew Wolfe Monday, June 20, 2011 10:37 AM
    Wednesday, May 07, 2008 5:17 PM
  •  This worked for me as well thanks for your post!
    Wednesday, August 06, 2008 6:17 PM
  • Thats weird... I'm having this problem too, and my "do not save encrypted pages" option was already unchecked... I tried checking it, and that obviously didn't help. Clearing temp internet files didn't help either.
    Wednesday, October 08, 2008 9:32 PM
  • Hi All,

    This problem gave me such big headache for 2 days. Finally I resolved it.

    This is the issue with setting http header as "pragma: no-cache". This can be either in the IIS being set under http-header> custom header, or might be setting inside code. I was setting that inside code. Fiddler (www.fiddler.com) tool helped me in finding whether my page was sending http header with no-cache. The I commented the code and compiled my application. The problem was gone.

    You can find more in http://support.microsoft.com/default.aspx?scid=kb;en-us;316431.

    Thanks
    Gita
    • Proposed as answer by Gitarani Friday, December 19, 2008 8:26 PM
    Friday, December 19, 2008 8:25 PM
  • Thank you, thank you, thank you.
    Tuesday, April 21, 2009 2:02 PM
  • Thanks lot Gitarani...
    it is all "pragma: no-cache" issue..

    after removing "pragma: no-cache" it worked..

    Regards
    Siva
    Monday, June 22, 2009 5:00 PM
  • That did it for me--THANKS!
    Trilon, Inc.
    Friday, April 09, 2010 8:04 PM
  • Thanks.

    This worked for me too.. :)


    Regards, Anurag
    Monday, May 31, 2010 9:13 AM
  • Thanks A lot this worked for me as well

    Thursday, July 15, 2010 9:18 PM
  • Hi

    My application runs in an SSL environment. My "do not save encrypted pages" option is unchecked. I couldn't find any of the following in my conf files as well:

    Pragma: no-cache
    Cache-control: no-cache,max-age=0,must-revalidate
    Can you please help me understand whether this header will be present in the httpd.conf of in some other conf file. Also mine is a html-perl setup with the help of mod-perl. I am trying to figure out a way in which I can add custom headers for my app in order to avoid error appearing in GUI for cross site scripting while using IE8. Can anyone please advice?

     

    Monday, February 14, 2011 3:20 PM
  • Thanks Isaac, I was having the same issue 3 years on.  This tick box solved it and at the same time, resolved my other issue.  In SharePoint, Actions/Export to Spreadsheet, would only let me save the IQY file that I'd then have to browse for and reopen.  I now have the option to Open directly from Internet Explorer without the messing around.
    Monday, June 20, 2011 10:40 AM
  • Solution:

     

    From Internet Explorer, go to: tools/internet options/advanced/got to the security section/uncheck “do not save encrypted pages”

     

    This solved the issue for me. If you are not in an SSL environment, then i guess this probable wont work for you!!

     

     

    Isaac Vallee, Thanks!

    Igor


    Thursday, November 10, 2011 9:16 AM
  • This is mega late but I just encountered this issue with a client and I appreciate the link and your explanation.   Helped immensely...thanks!
    Monday, January 30, 2012 4:54 PM