locked
Connect ot Database from Server Explorer error

    Question

  • When I select Tools -> Connect to Datavase... (or press toolbar button in Server Explorer) in VS 2008 TS I receive error message:

    An unexpected error occurred in the .NET framework data provider for Microsoft SQL Server Compact 3.5
    . Please contact the provider vendor to resolve this problem.


    I dont't use Microsoft SQL Server Compact 3.5 and only want to create connection to my SQL 2005. I have tried reinstall VS 2008, install and unistall Microsoft SQL Server Compact 3.5, but error still here.

    Do you have any ideas how to fix this?

    Saturday, February 23, 2008 2:16 PM

Answers

  • I had the exact same problem and yes reinstall of VS 2008 don't help. What I end up doing is go to the register

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\9.0\DataProviders

     

    and delete the one says .NET framework data provider for Microsoft SQL Server Compact 3.5

     

    I am sure this is not the best solution as I can not connect to a database file using instance but it should be fine if you just want to connect to a SQL server

     

    Tuesday, February 26, 2008 10:34 PM

All replies

  • Hello,

     

      Could you please try the following steps to see if it works?

     

       Tools -- Import and Export Setting -- Reset all Settings.

     

       Thanks.

    Monday, February 25, 2008 12:17 PM
  • Thank you for advice but unfortunatly it does not help.
    Monday, February 25, 2008 1:35 PM
  • I had the exact same problem and yes reinstall of VS 2008 don't help. What I end up doing is go to the register

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\9.0\DataProviders

     

    and delete the one says .NET framework data provider for Microsoft SQL Server Compact 3.5

     

    I am sure this is not the best solution as I can not connect to a database file using instance but it should be fine if you just want to connect to a SQL server

     

    Tuesday, February 26, 2008 10:34 PM
  • Thank you. It works!
    Wednesday, February 27, 2008 6:25 AM
  • Hi friends.

    I had the exact same problem... I have unistaled/instaled VS 2008, I folowed the tip of Hua Chen -->  Tools -- Import and Export Setting -- Reset all Settings, and I did what xlj said, all of this didn't help.

    What can I do?

    Regards.
    Friday, May 15, 2009 1:48 PM
  • Hey guys... I got a way for this problem:

    run vs2008 with the command:

    Devenv.exe /ResetSkipPkgs




    Regards.
    Friday, May 15, 2009 7:55 PM
  • Devenv.exe /ResetSkipPkgs command solved the problem, thanks
    Thursday, August 20, 2009 5:12 PM
  • Well,  it worked......find more info here...

    http://msdn.microsoft.com/en-us/library/ms241276(VS.80).aspx


    .NET *.*, C#, ASP.NET (Designing application using .NET *.* )
    Thursday, April 01, 2010 3:38 PM
  • I tried all above options but none is working.. I have executed vs with /ResetSkipPkgs also i have reset all settings.

    But still same problem.

     

    • Proposed as answer by krymz12 Wednesday, June 23, 2010 5:42 PM
    Thursday, April 15, 2010 7:16 AM
  • Hi there!I've also bumped  with the same problem as yours mine is  An unexpected error occurred in the .NET framework data provider for Mysql. Please contact the provider vendor to resolve this problem.

    I've tried allot of way trying to fix this error:

    1. Tools -- Import and Export Setting -- Reset all Settings.(NOT WORKING)

    2.devenv.exe/resetskippkgs(Still wont work)

    3.blah3x,,,,search2x

    so i decided to come up with my own solution eventhough i'm not really good at configuring things...

    its a little bit risky so i recommend you to backup your files first^_^

    1.start>run>regedit

    2.HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\VISUALSTUDIO\9.0\DATAPROVIDERS

    3.inside dataproviders you can see all the .net framework for diff db.The main folders would look like this:(example only:{7F041D59-D76A-44ed-9AA2-FBF6B0548B80)

    4.In your case look for {7C602B5B-ACCB-4acd-9DC0-CA66388C1533}

    5.Backup your registry by right clicking the folder>export>name of reg>save

    6.FOR FINALE delete the {7C602B5B-ACCB-4acd-9DC0-CA66388C1533}: right click>delete

    7.After that the error is gone, i have already access  the "Connect to Database" in TOOLS.

    I hope a helped in solving this error.^_^

    But i still don t know  the consequences of what i have done;P

    ---Let me know if theres a problem OK...^_^
    • Proposed as answer by krymz12 Wednesday, June 23, 2010 5:44 PM
    Wednesday, June 23, 2010 5:43 PM
  • I got the same issue after installing a trail for VS2010.  The answer from krymz12 was dead on.  Thanks.
    Thursday, August 05, 2010 6:24 PM
  • sure thing:)glad i helped you u
    Saturday, January 29, 2011 10:18 PM
  • Just wanted to add one thing:

    I am running VS2010 on a Win2008R2 server (64 bit) and experienced the same issue. Note that on a 64 bit machine the above mentioned key does not exist. The key on 64bit machines will be:

    HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\VisualStudio\<version>\DataProviders\{7C602B5B-ACCB-4acd-9DC0-CA66388C1533}

    where <version> is either 9.0 or 10.0 depending on whether you have VS2008 or VS2010 (or both - choose the one experiencing the issue). Deleting this key cured a host of errors that popped up when attempting to do anything related to connecting to a data source, e.g. add a source, perform a schema comparison. This is despite the fact that the appropriate provider was presumably installed correctly.

    • Proposed as answer by AntiAliasing Tuesday, March 27, 2012 8:42 PM
    Thursday, April 14, 2011 10:08 PM
  • hi thanks for the soln it work in vs2010.
    Regrads jAI
    Friday, August 19, 2011 11:19 AM
  • Hi,

    I have been fighting the same issue for three days now and gone through all the sam solutions noted above and NONE worked... I even when as far as searching my Registry for ALL instalces of MySQL and deleting then... still got the error....

    BUT persistance and stubbornness prevailed!>>>

    Deleting the Registry setting noted above by JReeder did the job.

    A BIG Thanks to all here...

     

    (Oh I'm running VS2010 SP1, .NET 4, C# & VB, SQL Express R2)


    SquireDude
    • Proposed as answer by SquireDude Monday, August 29, 2011 4:04 PM
    • Edited by SquireDude Monday, August 29, 2011 4:06 PM Addes environment
    Monday, August 29, 2011 4:04 PM
  • thanks i used and works.

     

     

    Wednesday, November 02, 2011 10:48 PM
  • Thanks this helped me.

     

    In case of SQL server compact 4.0 delete the below key

    OS: Win7 64 bit

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\10.0\DataProviders\{0CFB2EEB-3E0E-4909-99B7-8AE9E1C3E871}]

    Thursday, January 12, 2012 8:48 PM
  • Venkatesh Rajkumar Thank you sooo much I've been struggling with trying to fix my VS2010 for DAYS now. First I couldn't open stylesheets, I reinstalled 3 times, uninstalled MVC installed web development sp1 and finally got stylesheets back but broke database access. I've been looking for a fix for a long time now.
    Sunday, June 03, 2012 2:58 AM
  • Thanks this helped me.

     

    In case of SQL server compact 4.0 delete the below key

    OS: Win7 64 bit

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\10.0\DataProviders\{0CFB2EEB-3E0E-4909-99B7-8AE9E1C3E871}]

    Helps me too, Thanks!!
    Thursday, July 05, 2012 12:32 PM
  • Hey guys,

         I'm not sure deleting the HKEY from the registry is really what you want to do here.  I suggest going to the add and remove programs and removing the Visual Studio 2010 Tools for SQL Server compact 4.0. (If it's installed) 

    Then your going to want to install the Microsoft SQL Server compact 4.0 (There really is a difference)

    An easy way of doing this is by opening your search from the start menu and typing Web Platform Installer.

    When this application starts just search for "Microsoft SQL Server Compact 4.0.

    Then all you have to do is push the add button. 

    It really only takes about 2 min to complete and you should be on your way. 

    Hope this helps.

    Monday, July 09, 2012 2:44 PM
  • editing the registry seems risky, but it surely works!

    just be aware of the version you are using then remove from the data providers folder the faulty one.

    thanks for everyone's help!

    Monday, August 13, 2012 6:09 PM
  • i deleted the key 

    HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0_Config\DataProviders\{}

    and it worked fine

    Tuesday, November 13, 2012 12:57 PM
  • I had a similar problem with VS 2010 - Trying to use database schema compare.

    Deleting the registry entry as mentioned by xlj did the trick - Although the one I needed to delete was in \VisualStudio\10.0\DataProviders (as I was using VS 2010)

    Thanks xlj!

    Tuesday, December 18, 2012 10:02 AM