none
Problem getting Small Basic to run, can anyone help?

    Question

  • Hi all,

    I followed the instructions to the letter for installing .NET3.5 & Small Basic...

    but when I run Small Basic the computer starts running it ok for a few seconds then freezes totally requiring a reboot.

    My OS is XP and my settings are for the UK, I checked to make sure version 0.2 had the ability to run ok with my set up.

    Anybody have any idea as to why?

    If you need more info then ask and I'll do my best to provide.

    Thanks, Rousel.
    Tuesday, January 13, 2009 8:09 AM

Answers

  • I have had to remove the .net 3.0 & 3.5 installation completely from my computer & from my Windows Update list also, it wasn't just Small Basic not working after all.

    The installation interfered with all my other software & games preventing them from running properly or not at all.

    So it is not a problem with Small Basic after all but with .net.

    This does means I can never use Small Basic unfortunately, thanks to everyone who tried to help me out.

    Take care.

    Rousel.
    Saturday, January 31, 2009 4:15 AM

All replies

  • What local language version are you trying to use? 
    Tuesday, January 13, 2009 2:51 PM
  • Dink, it's set to En-GB.

    Could that be the prob?

    I thought that it would have been ok because it shows on the 'Small Basic Blog' about the 0.2 release that there's 'Support for non-US regional OS settings'.

    Rousel.
    Tuesday, January 13, 2009 3:17 PM
  • I don't think the symptoms resemble a Regional Settings issue.  Rousel, does this happen to only Small Basic or do other apps run into similar issues?
    Wednesday, January 14, 2009 5:10 AM
    Moderator
  • Virus?
    Wednesday, January 14, 2009 1:33 PM
  • Hi Vijaye,

    it only happens with small basic, nothings else (so far).

    I've un-installed both .net 3.0 & 3.5 as well as small basic, I think it may have been something with the .net install, according to the Event Viewer there was a problem during the 3.0 & 3.5 install, I can't tell exactly what it was but up untill I did the uninstall of both there was contanst system errors, nothing critical but they're in the log.

    All is ok with the system now since the uninstall, although I saw there was also a problem with the 'Application Manager Service' too there hasn't been anything in the last 24 hours and I've installed a couple of programs during that time.

    As I mentioned above I think it's .net that's done it, I've still got .net 1 to 2 and I'll try again at installing .net 3 & 3.5 plus small basic.

    When I was uninstalling yesterday I found 'Visual Studio 6.0 Enterprise Edition' (which I uninstalled) on my computer, I didn't install it, I think it was my nephew - I had mentioned to him I was looking in to Small Basic as well as other types of Basic and I think he's stuck it on in an effort to help me. I'm new to Windows & computing but even though I'm old'ish I'm a quick learner LOL. I gave him a ticking off today for doing it.

    Luckily I backed up my computer a few days ago and restored it today so everything is back the way it was before I looked in to getting Basic. Good thing that, systems working fine now.

    Anyway I'm rambling a bit, back to the point.

    I'll install .net again & small basic and let you know how I get on, like I said I think the problem was with the .net installs, if there's a prob during the install again I may have to give up, which is sad. :(

    If small basic does what it did before I'll try another program that uses .net 3.0 or 3.5 to see if it also causes the freeze then I'll definitely know it's .net & not Small basic. ;)

    Thanks Vijaye for the responce, I'll keep you posted. ;)

    Andras (sorry I don't know how to make an 'a' with the little slash above it), it's not a virus, first thing I did when I got my comp just before christmas was buy Nod & a firewall to be extra secure. The idea of worms & virii scared me enough to fork out a small fortune LOL. My comp does a full scan every day & updates whenever it can, I've been told it's doing it too often but better to be safe than sorry.

    Anyway I'm rambling again, I'll let you know how it goes, probably be tomorrow as it's been a long day for me and I'm a bit nervous about doing it, scared in case it damages some hardware or something, funny thing though when it freezes the mouse still moves but everything else (even the task manager) stops dead.

    Ooops rambling again LOL.

    Ciao for now & thanks for your time & help.

    Rousel.
    Wednesday, January 14, 2009 6:39 PM
  • Vijaye,

        sorry it took so long to get back but I'd taken ill and only got back yesterday.

    I had tried what I said and it still locked up. :(

    Today I got .net3.5 through Windows Update & tried 0.2 Small basic again but it did the same thing. :(

    I dont know what's causing it or how to fix it.

     

    Rousel.

    Tuesday, January 27, 2009 9:47 PM
  • I have had to remove the .net 3.0 & 3.5 installation completely from my computer & from my Windows Update list also, it wasn't just Small Basic not working after all.

    The installation interfered with all my other software & games preventing them from running properly or not at all.

    So it is not a problem with Small Basic after all but with .net.

    This does means I can never use Small Basic unfortunately, thanks to everyone who tried to help me out.

    Take care.

    Rousel.
    Saturday, January 31, 2009 4:15 AM