locked
SourceSafe has detected that a previous operation against the "VSS database name" database was unexpectedly terminated.

    Question

  • Full message:

    SourceSafe has detected that a previous operation against the "VSS database name" database was unexpectedly terminated. To recover from this failure, please ask your SourceSafe administrator to run the Analyze utility.

    This message appears on opening in Visual Studio 2005 Team System Developer edition, a project, which had previously been closed without any issues.

    On clicking OK everything seems fine.

    Any ideas?

     

    Thursday, January 11, 2007 1:28 PM

Answers

  • This just means that someone's client died before shutting down properly.  It may have crashed, been killed by the user, been shut down by an administrator patching the OS, etc.  Like the message says, you should run Analyze as a precaution, but chances are nothing bad happened to the database.
    Thursday, January 11, 2007 7:10 PM

All replies

  • This just means that someone's client died before shutting down properly.  It may have crashed, been killed by the user, been shut down by an administrator patching the OS, etc.  Like the message says, you should run Analyze as a precaution, but chances are nothing bad happened to the database.
    Thursday, January 11, 2007 7:10 PM
  • In our case, this dialog appears once in a while often during our automated build process which of course hangs until somebody clicks the OK button. Our build process first sets up an emtpy directory, gets the latest version from SourceSafe into that directory, opens a solution from that directory tree to runs a Visual Studio macro on it to add log statement to CSharp source files (devenv <solution>.sln /command <macro>), and finally starts Visual Studio again to build the solution (devenv <solution>.sln /build Release). The problem doesn't seem to happen during the build of the solution, only when the solution is open to run the macro on it.

    I could no find a way to stop the dialog from displaying. Running an analyze before each build is a little bit heavy handed. I could not find a way to disconnect the solution from the command line either. We are using Visual Studio 2005 and Visual SourceSafe 2005.

    Any other idea?

    Thanks.

    Georges

    Tuesday, May 27, 2008 7:23 PM
  • I have the same issue with the automated build/test scripts. I even tried removing the SourceCodeControl section from the
    solution file before kicking off the build. However, that does not seem to help. I am not sure where else the assoication with
    source code control is stored.
    Haripriyan
    Wednesday, December 30, 2009 4:11 PM
  • Here's how I solved this issue:

    1. Make sure to delete all 'obj' and 'bin' folders after you've cleaned your solution from Visual Studio.  Do not trust Visual Studio to successfully clean your solution.  I found one file locked in use and had to reboot.

    2. Delete the '_Resharper.xxxxxxxxx' folder that appears under your project (if you are using ReSharper) to clean out any cached symbols.

    3. Within Visual Studio 2008, select 'Tools...Options...' from the menu bar.  Then Uncheck the following options (if checked):

       -- Enable .NET Framework source stepping

       -- Enable source server support

    4. Open your Solution, save, close, then re-open the Solution to ensure it is saving properly.

    5. Now build the entire Solution.

    6. Attempt to Debug your application.


    I can't explain whether one or all of these steps fixed the problem, but doing them *did* work after hours of troubleshooting.  Hopefully this will save the next person from the same headaches.  (Note: This had nothing to do with the Analyze tool on the Visual Source Safe Server.)

    Dan

     

    • Edited by justdan23 Thursday, September 08, 2011 10:53 PM I found the solution after a few hours of troubleshooting
    • Proposed as answer by justdan23 Thursday, September 08, 2011 10:54 PM
    Thursday, September 08, 2011 10:20 PM