none
Difference page numbres between print and print preview

    Question

  • Hi ,

    I Have report with the following specification

    1- Report Property :

          Paper size: Landscape width 14 and Height 8.5

         Margins left:0.25 , right:0.25 , top 0.25 and botton 0

    2- On the Report Body, size is set:

        width: 13.5 (14 -0.25 - 0.25) I decreased the left and top margines from the page size

        heigth: 8.25 hight I decreased the top and botton margines from the page size

    Problem:when the report is renedered, it shows me 5 pages (In print preview) while when I print the same page using the print button it has 6 pages.

    I read a lot about this issue and how the HTML rendering is different. Als0 there were some suggestions but none of them works.

    I do not use export to Pdf or Word so I am not worried about them. I just want to be able to print what I see on the page and the reason is I  may want to just print one specific page and in this way it is not possible.

    Is there a setting on report, if I want to have the same user experience from the report preview and print button.

    Any help or idea would be much appreciated.

    Thanks,

    Maryam

    Friday, September 27, 2013 8:17 PM

All replies

  • hi

    did you  cheek printer config.

    Saturday, September 28, 2013 7:30 PM
  • Thanks Saman for your reply.I believe this is not related to printer config as actual print button works correctly.

    This is the print preview which does work right and just show 5 pages instead of 6.

    I also checked with anther report it shows 2 pages in print preview while when I print,it prints 4 pages. The number of pages are correct when they are printed while the number of pages are not right in print preview.

    It seems that Microsoft done it on purpose to improve user experience and have users less clicking on next page in print previw.

    But this is not our users want. They want to be able to print specific page.

    I believe there should be some setting to be able to have the same page numbers in print preview and actual print . But I am not sure what it is.

    I would appreciate any advice.

    Thanks,





    Monday, September 30, 2013 6:02 PM
  • Hi Maryam,

    Sorry for the delay.

    Print preview is a feature that allows a user to view what a printed version of the document would look like on the screen before printing a hard copy which is anything that has been printed on paper. In this case, the page numbers should the same on print and print preview. I have tested it on my local environment, we cannot reproduce this issue. It's hard to say the root reason for this strange behavior. In your scenario, we can try to specify the same size to BodySize and InteractiveSize and check whether this issue is persists or not. Besides, you can export this report to PDF and then print it to check whether print and print preview show the same page numbers.

    Regards,
    Charlie Liao

    If you have any feedback on our support, please click here.


    Charlie Liao
    TechNet Community Support


    Thursday, October 03, 2013 7:02 AM
  • Hi Charlie,

    Thank you so much for returning back to me and for your suggestion.

    Actually I had not set up Interactive page size but I did per your advice but still having issue.

    here is what I did:

    Page Size: 14*8.5

    Left Margin: 0.25  - Right Margin: 0.25 - Left Margin: 0.25 

    Body = 13.5in(14-0.25-0.25), 8.25in(8.5-0.25)

    InteractiveSize = 13.5in(14-0.25-0.25), 8.25in(8.5-0.25)  as you suggested

    But still number of my pages are different between the print and print preview.

    If I exported the report to PDF it has exact number of pages as print.

    But I want to have the same page numbers also in print preview.

    Logically setting interactive page size should serve the purpose but it seems not.

    I read in some other blogs that we have to set Can Grow to false too.

    As a result I set the Can Grow of my fields to false and there you go. I got the correct page numbers!

    But I do not want to set the Can Grow property of fields to false to have correct page numbers.

    Is there any way to be able to do so?

    Any advice would be much appreciated!

    Thanks,

    Maryam


    Thursday, October 03, 2013 5:07 PM