none
Last page of rdlc report is blank

    Question

  • Hello.

    I have an rdlc report with a strange behaviour. Everytime it prints an extra blank page with only the header and footer, no data at all. I've been pulling my hair with this since i cannot find anything wrong in terms of paper size and body, footer and header sizes. If it was that problem it would print a blank page after each normal page, i believe. For one page it prints two and for ten pages it prints eleven...

    Can someone please give some help?

    Thanks in advance.

    Octavio

    • Moved by Mark Liu-lxf Monday, October 24, 2011 7:49 AM report controls (From:Visual Basic General)
    Thursday, October 20, 2011 4:53 PM

All replies

  • Hello.

     

    Just to add a few more information, this is getting more and more weird. If the report has up to six records, there is no extra page. However, with seven or more records the extra page is printed...what can this be?...

     

     

    Friday, October 21, 2011 1:46 PM
  • Hi oteixeira1962,


    Welcome to the MSDN forum.


    This queue is about Visual Basic. I’m afraid that the topic about rdlc report is off topic here. For better support, I will move this thread to Visual Studio Report Controls forum. Sorry for any inconvenience.


    Mark lxf [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, October 24, 2011 7:47 AM
  • Hi oteixeira1962,

    We found a similar problem that we initially thought was the height parameters being incorrect for the report page settings.  After hours of calculations we finally realised that the width of our sub report was creeping over the margins and creating an extra page.  Once the width of our sub report was locked down it behaved correctly.

    Worth a try,

    Mike

     

    Monday, October 24, 2011 9:36 AM
  • I was running out of time so i had to rebuild the report from scratch. Now the problem has gone. My report has no sub report so i believe that, in this case, the cause does not come from there.

    Thanks to everybody who tried to help.

    Octavio

    Monday, October 24, 2011 1:12 PM
  • Set the page-property ConsumeContainerWhitespace=true

    Monday, May 28, 2012 12:26 PM