none
Content database site collections

    Question

  • Hi Friends,

    I took the backup of the "Content database" from sql server.This content database having some site collections. I attached this content database to the other web application.Content database is attached but site collections are not available.I need those site collections.Please can anyone help me anything is going wrong.

    Thanks,

    Tiru


    tirupal


    • Edited by tirupal Thursday, July 18, 2013 5:56 PM
    Thursday, July 18, 2013 5:56 PM

Answers

  • Yes, the sites within the databases will have the same GUIDs, so they won't be visible.  You'll need to export them and import them into the target location.

    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Friday, July 19, 2013 5:57 AM

All replies

  • You either want to restore that database to a different farm, or instead individually export (Export-SPWeb) the sites, and import them into the destination location.

    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, July 18, 2013 6:16 PM
  • HI,

    Are you restoring within the same farm? If yes then please do not go ahead with this since it will cause issues because of same guids.

    If it is from different farm then make sure that you have created the correct managed paths for the sites.

    I hope this will help you out. 


    Thanks, Rahul Rashu

    Thursday, July 18, 2013 6:33 PM
  • Use powershell to attach the databases and use the switches -AssignNewDatabaseId and -ClearChangeLog to be safe. Also as mentioned above make sure you have the correct managed paths.

    That should make sure you don't have any conflicts, assuming you never created the same sites and webs on the other webapp.

    I have usually not had a problem moving content dbs between webapps on the same farm that way.

    Thursday, July 18, 2013 8:00 PM
  • That will assign a new database ID, yes, but the site collections will have identical GUIDs.

    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, July 18, 2013 8:01 PM
  • Ah, I assumed he was moving the content database, not copying it and attaching it.

    Thursday, July 18, 2013 9:48 PM
  • Hi Christopher,

    I am attaching the backup content database with in the same farm but different web application.You are saying something like;if we attach the content database  with in the same farm the site collections are not visible because of the same Guid is it? 

    Thanks,

    Tiru


    tirupal


    • Edited by tirupal Friday, July 19, 2013 5:55 AM wrong
    Friday, July 19, 2013 5:54 AM
  • Yes, the sites within the databases will have the same GUIDs, so they won't be visible.  You'll need to export them and import them into the target location.

    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Friday, July 19, 2013 5:57 AM