none
Problème d'authentification

    Question

  • Bonjour,

    J'ai problème de persitence d'authentification avec SharePoint.
    Le symptôme est le suivant: au bout d'un certains nombre d'oppération effectuer dans WSS 3.0 avec ie7 ie7 redemande au user de s'authentifier. Ce dernier rentre à nouveau ses login et password et il finit par tombé sur un 404 unauthorized. Au final le user doit relancer ie7 pour avoir de nouveau accès à SharePoint...jusqu'a la prochaine fois.

    J'ai passé de SPSadm ce dernier ne relève aucune érreur de configuration?

    Avez vous une idée ?

    Merci d'avance
    Wednesday, August 08, 2007 1:16 PM

All replies

  • Il n'y a un bug que parfois si on change d'utilisateurs connectés en utilisant l'option qui se trouve en haut à droite ( se connecter en tant qu'un utilisateur différent).

    JE crois que c'est un bug ...

    Mais si vous ne changez pas d'utilisateur normalement celà ne devrait pas arriver

     

    Friday, August 10, 2007 3:01 PM
  • Bonsoir

     

    Essayez de jouer avec la configuration de l'authentification formulaire et surtout le timeout (en minute, ici j'ai mis pour 31j) :

     

    Code Snippet

        <authentication mode="Forms">
          <forms loginUrl="/_layouts/login.aspx" path="/" name="AuthentCookie" timeout="44640"  />
        </authentication>

     

     

    J'espère que ça règlera votre problème (attention à IE7 et Vista, il y a un mode protégé qui pourrait vous causer qqs soucis, cf http://technet2.microsoft.com/Office/en-us/library/d3e0e0fc-77b6-4109-87d6-53ad088db01d1033.mspx?mfr=true)

    Friday, August 10, 2007 7:15 PM
  • Merci pour la réponse.
    Cependant, à quel endroit suis-je sensé mettre ce code ?
    Monday, August 13, 2007 9:12 AM
  • Par ailleurs, à chaque fois que ce produit ce problème le message suivant apparait dans le system event viewer:
    Les paramètres d'autorisation spécifiques à l'application n'accordent pas d'autorisation Locale Activation pour l'application serveur COM avec le CLSID
    {61738644-F196-11D0-9953-00C04FD919C1}
     au SID AUTORITE NT\SERVICE RÉSEAU de l'utilisateur (S-1-5-20). Cette autorisation de sécurité peut être modifiée à l'aide de l'outil d'administration Services de composants.

    Après quelques recherches j'ai trouvé ceci:

    ISSUE: Errors in the application event log.

    ERROR:

    ProblemDescription:    Event Type:    Error

    Event Source:        DCOM

    Event Category:        None

    Event ID:        10016

    Date:     <somedate>

    Time:        <sometime>

    User:        <domain\username>

    Computer:        <computername>

    Description:

    The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID

    {61738644-F196-11D0-9953-00C04FD919C1}

    to the user <domain\username> SID (X-X-X-XX-XXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXXX). This security permission can be modified using the Component Services administrative tool.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

     

    RESOLUTION:

    • Navigate to Start->Control Panel->Administrative Tools->Component Services
    • Under Console Root, navigate to Component Services->Computers->My Computer->DCOM Config.
    • Right click IIS WAMREG Admin service and select properties
    • In the Property pane, switch to the Security tab.
    • Click Edit on the Launch and Activation Permissions section and you should see that only administrators and service have rights here. Add your service account in here as well to match the admin rights and those errors should go away.
    J'ai rajouté les utilisateurs du domaine.
    Mais le problème persiste.

    Puis sur le blog de gat j'ai trouvé ces deux liens:

    et pour l'instant cela semble fonctionner.

    ....

     

    Et puis non finalement ça ne résout pas le problème.

    Ce comportement de WSS est devenu tellement intempestif que j'ai du réinstaller le serveur....

    Sur cette nouvelle installation tout ce passe pour le mieux

     

     

    Merci quand même à gat






    Monday, August 13, 2007 10:25 AM