none
Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed...

    Question

  • Greetings,

     

    Does anyone know the likely cause of this error or how to go about investigating it?

     

    Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed. Disconnect all previous connections to the server or shared resource and try again.

     

    We have a receive location that is is mapped to a file share on another server.  We have used the "Authentication" tab on the "File Transport Properties" window to supply the logon credentials of a system administrator on the server hosting the file share.  There is no obvious cause for the credentials to be logged in to this server twice.

     

    Thanks,

    BCB

     

     

     

     

     

     

     

     

    Tuesday, July 31, 2007 2:42 PM

Answers

  • Does the same user or anybody maped that shared folder into their machine for z:, x:, y:, etc... drive.

    Could you please check that?

    Thanks,

    Saravana Kumar

    Tuesday, July 31, 2007 6:43 PM

All replies

  • Does the same user or anybody maped that shared folder into their machine for z:, x:, y:, etc... drive.

    Could you please check that?

    Thanks,

    Saravana Kumar

    Tuesday, July 31, 2007 6:43 PM
  • I do have the same problem. The share folder current have two users mapped. Will that be the issue?

    Thanks in advance.

    Cheers

    Horace Ho

    Sunday, November 04, 2007 3:43 PM
  • Hi try this Kb from Microsoft

     

    http://support.microsoft.com/kb/938120

     

    Friday, July 04, 2008 1:41 PM
  • By chance are you sending data to this server using a send port as well?  I have seen this before where someone was delivering files to the server using two sets of credentials:

    1. Providing credentials in the authentication tab within the send port
    2. Not providing credentials and therefor relying on the credentials of the Host Instance that is hosting that Send Handler.

    The problem was fairly intermittant, but if you tried to send both files around the same time you would receive the same error that you are describing.

     

    Friday, July 04, 2008 7:01 PM
    Answerer
  • Hi
    This link to Microsoft support worked fine for me. I had the problem in Symantec BE 12.5, followed the instructions changed to IP address.
    Saturday, October 03, 2009 7:26 AM
  • The network folder specified is currently mapped using a different
    user name and password. To connect using a different user name and
    password, first disconnect any existing mappings to this network
    share.

    To do this

    net use * /delete

    Press 'Y' on keyboard
    • Proposed as answer by Jinish KG Friday, November 13, 2009 9:03 AM
    Friday, November 13, 2009 9:03 AM
  • Hi all,

    The "net use * /delete" command didn't do it for me. Deleting all the shares from "My Network Places" didn't work as well.

    What worked for me is stopping "Server" and "Workstation" services, as well as the depending services Windows had to stop along with those two.
    I suppose that the File sharing service was transparently making connections to some network resource, or that some other network service was accessing my machine, and that was disabling the hostname change.

    Hope this helps.


    Regards,

    Vladimir
    • Proposed as answer by machinori Tuesday, January 12, 2010 12:59 PM
    Tuesday, January 12, 2010 12:54 PM
  • Hello!

    If you use net use * /delete you will delete the partitions and you will have to recreate them.

    A better solution is to use the IP address of the remote server when you try to connect to the network share or the full domain name : by example if you have some mapping to \\server\shared folder ,  you can try to do the new mapping to \\server.domain\shared folder or \\192.168.0.1\shared folder(where 192.168.0.1 is the ip of the server) .

    Have a nice day,



    • Proposed as answer by Freqy Wednesday, June 20, 2012 5:44 AM
    Thursday, February 18, 2010 10:04 AM
  • just using the IP address instead of the hostname worked for me.

    Thanks

    Alex

     

    • Proposed as answer by Kevin vk Friday, September 24, 2010 8:44 PM
    Saturday, September 04, 2010 1:56 PM
  • I was having the same issue using Windows XP Pro connecting to a Windows 2003 Server.  I went to the command prompt and entered the command "net use" to view my connections.  I noticed a mapping to the server with no drive connection.  I used the "net use <mapping> /d" command.  Once again I performed a net use command and the mapping was gone.  I then retried the connection and it connected successfully.

    I would try this before using the net use * /d command and disconnecting all of your connections.

    I verified this serveral times in my environment and it worked each time.  I also then try the IP mapping to the server, which naturally was successful.  Using the IP mapping seems to prevent the problem appearing, but for my co-workers who seem to forget the IP address to the server, they are now using the net use /d disconnect command I provided above.  It seems to be easier for them to use this command then to remember the IP address (go figure).

    I hope this helps

    • Proposed as answer by Kevin vk Friday, September 24, 2010 8:59 PM
    Friday, September 24, 2010 8:53 PM
  • I don’t get it? Using net use * /d does not fix the issue with the disconnecting? I can just as easy go to my computer right click on the shared drive and click on disconnect and Recreate the map and wait to do it again? How does that fix the drive from disconnecting again ? You’re telling me that all of you are running around remapping drives every time a user gets disconnected? I am testing the map to IP now but I don’t have time to run around remapping everyone’s network drives all the time! How about we find out what is causing the drives to get disconnected in the first place and fix it!

    Wednesday, October 13, 2010 3:06 PM
  • THANK YOU, my thoughts exactly!!
    Monday, November 01, 2010 12:34 PM
  • ---

    Using the net use command lists all shared resources for which there is a connection, and the state of the connection. It's not possible to have a connection to the same resource, and authenticate using two different sets of credentials.

    Using the  net use * /delete will remove all references to shared resources, and force reauthentication for each resource as they are accessed. It's probably more appropriate to just delete the resource for which the credential conflict has occurred. For example, if the "Multiple connections to a server or shared resource... " message appears when attempting to access \\ServerName\ShareName , then run the net use command, and determine whether there's already a connection to \\ServerName . If so, then delete it: for example net use \\ServerName\c$ /delete . Use the same name as exists in the output of the net use command.

    The simplest way to 'reset' a connection is just to delete the resource that's in conflict.

    The reason that using an IP address works is that it just sets up a new connection. So if attempting to access \\ServerName\ShareName causes the "multiple connections " error, and the IP address of ServerName is 192.161.0.1, then accessing the resource via \\192.161.0.1\ShareName will simply open a new shared resource. Try it, then re-run the net use command to verify this.

     

     


    Christopher Scholten 龘龗蘇            ➔ If this posting was helpful, please mark it as such (at top) ✔
    • Proposed as answer by Connextek Friday, January 07, 2011 2:17 PM
    Thursday, November 18, 2010 1:05 AM
  • Hi !

    I had the excat same problem with the error message below, only 3 map drives that wont connect in my login script.

    Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed. Disconnect all previous connections to the server or shared resource and try again.

    Heres my login script before it works, also sorry its in french.

    @ECHO OFF

    NET USE * /DELETE /Y
    NET USE I: \\serveur\REDACTEURS-CONSULTANTS
    NET USE J: \\serveur\PUBLIC
    NET USE T: \\serveur\LOGICIELS
    NET USE M: \\serveur\MARKETING
    NET USE P: \\serveur\ADMINISTRATION 1
    NET USE R: \\serveur\ADMINISTRATION 2
    NET USE H: \\serveur\CLIENTS
    NET USE N: \\serveur\COMPTABILITE
    NET USE X: \\serveur\taxprep

    I know everything looks normal above but here what i have found after adding these ''  '' on the map drive that dont work and uses a special format. 

    NET USE I: ''\\serveur\REDACTEURS-CONSULTANTS''
    NET USE P: ''\\serveur\ADMINISTRATION 1''
    NET USE R: ''\\serveur\ADMINISTRATION 2''

    Now its working like a charm and the error is gone and finally everyone seems happy at the office lol.

    I guess when you use special caracters in your loging script like spaces or - or whatever signs you might have to put these '' ''.

    Btw i dont know why this fix my problem, before the loging script was working, by curiosity i played with it and REMOVED the '' '' for these 3 shares cause i had never seen it before. Its since i was getting the error.  After i put '' '' on those 3 shares everything worked again.

    Weird.

    If anyone can tell me why it would be appreciated.

     

    Friday, January 07, 2011 2:33 PM
  • there is space between ADMINISTRATION and 1. If you don't provide double quotes, net use will try to map to \\serveur\ADMINISTRATION instead of "\\serveur\ADMINISTRATION 1".

    hence double quotes are required if space is between folder name.

    Friday, February 25, 2011 5:16 PM
  • I am having same problem, but it does not fixes by any given solution.

     

    Please provide solution.

     

    Thanks,

    Gopal R.

    Friday, May 20, 2011 2:58 PM
  • It shows me there are no entries in this list.

     

    Problem continues.....

     

    Friday, May 20, 2011 2:58 PM
  • Post your logon script.
    Wednesday, May 25, 2011 8:49 PM
  • worked perfect... thanks
    Tuesday, November 08, 2011 5:19 PM
  • Using the IP of the remote server instead of Server hostname worked for me.

    Thank you for the solution.

    Tuesday, March 13, 2012 3:10 AM
  • Hi,

    This problems occurs whenever unfortunately similer names for multiple computers in a domain or similer named computers are sharing a sheared locations, multiple computers can exists in a domain but it creates problem while sharing a sheared locations so you have to replace <compterName> with <IP address of specific computer> it will resolve your connection isssue.

    for eg. suppose your computer name is ABC and IP address is 192.168.1.7

    then sending URL or Receiving URL must be:- \\192.168.1.7\shredfolder

    Mark this if helps..

    Thanks

    \Harmeet


    Harmeet Singh Virk



    Wednesday, March 14, 2012 6:14 AM
  • thanks, this helped!
    Monday, May 28, 2012 10:55 PM
  • I have had the same problem.  I have A Western Digital MyBook network HD on my network.  I have a partition set up with it's own User name and password.  I have the properties set to not reconnect at login, thinking this would help.  Sometimes I can map the partion and log in and other times I get the "Multiple Connections to a shared resource or shared resource... is not allowed" message.  I have tried Net Use when I get the error message- it doesn't show any mapped resources yet I still can't log in.  The only way around this has been to shut down the HD, reboot my computer and after reboot restart the HD and log in. 

    Any help to solve this would be appreciated.

    Monday, June 04, 2012 4:12 PM
  • I was having the same issue. I restarted the NETLOGIN SERVICES on the server and the workststion and it worked afterwards.

    I think this is tied into the NET sessions but I  really don't think all the "fancy footwork" is necessary for this one.

    >service.msc >rester netlogon service >at worst restart workstation(but that means many dependencies will go down too).


    Tuesday, June 05, 2012 10:34 AM
  • A better solution is to use the IP address of the remote server when you try to connect to the network share or the full domain name.

    Props for the solution, worked perfectly. This really demonstrates the utter futility of Windows' "security measures" like this one. What this does is get in the way of heaps of legitimate use cases, but then its easily worked around in a programmatic way.


    Working in C++ reminds me that some things are almost as illogical as Microsoft

    Wednesday, June 20, 2012 5:47 AM
  • I have been searching the internet for hours now, but I cannot find an instruction to list shares and usernames used for it. I deleted the shares over and over, but there must be some extra hidden connection.

    Moreover if I connect F: with userX it is succesfull. If I then connect M: with userX I get the annoying multiple user message. I used this:

     -net use F: \\server\photo /USER:userX pwdonthavetoknow /PERSISTENT:YES
     -net use M: \\server\music /USER:userX  pwdonthavetoknow /PERSISTENT:YES

    Possible trouble-issues:
    -added UNCFATPHInstaller.msi to windows search to search the netwerk drives. Seems this one is trying to connect with logon crudentials

    -being connected via a webinterface to the same server? Don't think so...using Opera.

    Tuesday, July 10, 2012 6:51 PM
  • Using the full UNC path name resolved this issue for me when mapping multiple drive letters to the same drive:

    sharename.domainname.net


    • Edited by Cody Carver Thursday, August 30, 2012 8:18 PM
    Thursday, August 30, 2012 8:17 PM
  • Thanks! This worked for me (renaming a windows 2003 R2 server on a domain). Apparently the mapped drives were causing the problem (never had that happen before, but whatever).
    Friday, September 28, 2012 8:18 PM
  • Hi,

    I tried with \\ip adress\  <--it shows multiple connections ....error.......if u try with \\destination server name\  <---this will  work.

    B/R

    IT-KID-BD

    Tuesday, November 20, 2012 5:14 AM
  • Neither net use * /delete nor restarting the NetLogon service worked for me.  What did work was restarting the DNS Client service.  Hope that is helpful.

    Jerry Mena

    • Proposed as answer by bharatsahani Friday, May 10, 2013 2:11 PM
    Sunday, December 02, 2012 11:58 PM
  • Thanks! worked for me.

    MCITP: Business Intelligence Developer 2008, MCITP: Database Developer 2008, MCITP: Database Administrator 2008, MCPD: Enterprise Application Developer 3.5, MCTS: SharePoint 2010, Configuration Charter Member, MCTS: .NET Framework 3.5, Windows Workflow Foundation Applications, MCTS: Microsoft Windows Vista: Configuration, Microsoft® Certified Trainer 2010

    Wednesday, December 12, 2012 4:34 AM
  • Monday, May 13, 2013 12:39 PM
  • This worked perfectly in my system. Thanks for the solution!
    Sunday, July 28, 2013 4:22 PM
  • My case was failure in connecting to a shared printer. I used the command " NET USE \\server-name * " It prompted me for the passsword, and then it said the password was expired. We changed the user's password in the server and voila, no more problem.

    Tuesday, December 03, 2013 11:38 AM
  • It worked for me.

    Thanks for the solutions

    M.

    Wednesday, December 04, 2013 11:31 AM