none
cannot configure "TCP connect transport" settings in the Remote Registry Editor

    Question

  • Hello,

    I can't connect to my device with the Remote Registry Editor (running a custom WinCE 5.0 image without ActiveSync) because I can't change settings of the connection. When I select "TCP Connect Transport" in the "Windows CE Connectivity Manager Configuration" -> Properties and click "Configure", nothing happens. I can reproduce this with standard WinCE 5.0 SDKs too (Smartphone 2003).

    I'm using VS2005 SP1

    Wednesday, January 31, 2007 12:53 PM

All replies

  • Since you are trying to connect to a device which doesnt have ActiveSync, you need to do manual bootstrap.

     - Copy the conmanclient2.exe, cmaccept.exe from <sysdrive>:\Program Files\Common Files\Microsoft Shared\CoreCon\1.0\Target\wce400\<Arch> directory to the device.

     - Do ipconfig in device and notedown the ip address of it.

     - Run conmanclient2.exe and cmaccept.exe

     - In desktop, Open VS 2005. Go to Tools - options. Select WinCE 5.0 device. Click the properties button.

    Select the transport as TCP

    Click configure and give the IP of the device

     - Try connecting to the WinCE device now. Connection should succeed.

     -  This post will give you more details http://blogs.msdn.com/vsdteam/archive/2005/01/05/347332.aspx

    Once connection is succeeded, then you can use your remote tools (including remote registry) to do any operations.

    Wednesday, January 31, 2007 2:44 PM
  • Hello Anand,

    I am able to connect to the device with VS2005 and debug our application. The remote tools still don't work though.

    After establishing the connection with VS2005, I start the remote registry editor and try connecting to the device. I then see the connection window pop up and immediately close without any other messages, and I still cannot see the remote registry.

    I can also connect to the device in the remote registry editor by pressing the "test" button in the connect settings dialog. After this, status is still "not connected", and when I try connecting, I see the message box "%1 is not a valid Win32 application". I think that some files must be transferred to the device first in order to make remote tools work, which doesn't seem to happen automatically.

    Friday, February 23, 2007 3:26 PM
  • Hello,

    I've done some more investigation (trying to make the remote file viewer work) and found that it transfers ccfwcli.exe (file size 19.752 bytes) from <Program Files>\CE Remote Tools\5.01\target\wce500\armV4i to \Windows directory on the device and tries to launch it. This .exe cannot be started though (when I double-click it, I get the message "'ccfwcli' is not a valid Windows CE application"), this is the cause of not working remote tools as I see it. I've checked the dependences from the coredll.dll and they are OK.

    Thursday, March 15, 2007 10:35 AM
  • Has anybody found any more info on this.  As far as I can see this post was not answered and I am having the same problem even after the following the so called solution. 


    *mods* can you unanswer this post please?
    Wednesday, November 14, 2007 4:13 PM
  • I'm having the same problem and would very much appreciate an answer - if it's not too much trouble.

     

    I have connected my pc to the device (Win CE 5.0) with activesync - no problem.  While in the cradle I configured the device for wireless connection.  Tools> Options> Device Tools> Devices> Windows CE 5.0 Device, Properties> TCP Connect Transport, Configure> Select "Use Specific IP Address", and enter the current IP address from the device.  Click on OK several times to back out of the option. 

     

    I still can't connect to the device "cold".  I can put the device in the cradle and connect with activesync and then take the device out of the cradle and it will connect via wireless.  If I warmboot the device I loose whatever it was that made it able to connect and I can no longer establish an 802.11 link. 

     

    It is not good enough to just make a connection and sync with the activesync - I must also open one of the remote applications.  Anyone will do, for example, I open the remote file viewer while the device is in the cradle - works fine - I see the files - close remote file viewer.  Then I take it out of the cradle and open the remote process viewer with the device out of the cradle - I see the processes fine.  At this point I can continue to connect to the device via 802.11 until I do a warmboot.

     

    So is there some file that I need to make persist?  Thanks for any help you can give

     

     

    Monday, November 19, 2007 2:58 PM
  • "It is not good enough to just make a connection and sync with the activesync - I must also open one of the remote applications.  Anyone will do, for example, I open the remote file viewer while the device is in the cradle - works fine - I see the files - close remote file viewer.  Then I take it out of the cradle and open the remote process viewer with the device out of the cradle - I see the processes fine.  At this point I can continue to connect to the device via 802.11 until I do a warmboot."

    Simple question here.  Are you making sure that you are getting a solid 802.11 connection to the proper network upon warmboot?  After I disconnect an Activesync there is definitely an effort by the PDA to establish a wireless connection on mine.

    I know that I am not able to configure ANY of the remote tools by Target->Connectivity Options->select my device->Properties->TCP Connect Transport->Configure  Nothing comes up!!  So you are farther than I am. 

    I am able to run the debugger in TCP/IP over wireless and am able to run the remote tools in activesync.  But not even able to configure the remote tools.  Should I try them by command line...are there switches for these options?

    Thanks
    Monday, November 19, 2007 3:34 PM