none
Sharepoint repeatedly prompting for credentials when opening documents after being signed in.

    Question

  • On our setup of SharePoint, after people log in and are authenticated they get still get prompted every time they open a file or document from the site.  The fix we had for it was to add our SharePoint address to the trusted intranet sites, which only resolved the issue for 20% of the people.  This issue does not happen when accessed through FireFox and is more of an annoyance than anything.  Does anyone have any fixes for IE that would cache the credentials once logged in and not ask for them again until signed out?  O yes, and Remember my password does NOT save it.  Any suggestions would be greatly appreciated.

    Thanks,
    -Hu.
    Thursday, October 22, 2009 8:42 PM

Answers

  • Hi, i stumbled over Problems that are slightly different but i want to tell you the solution.

    Our Problem was that some users were prompted each time they accessed the sharepoint site plus once for each attachment. very disturbing...

    the solution was that this users had a entry in

    control-panel / useraccount (or similar, sorry i have german client) / advanced / manage passwords

     

    just deleted that account and the prompts were gone.

    wish you luck, all the best

    Markus

    Wednesday, April 27, 2011 8:59 AM
  • I am using IE9, Windows 7 and am receiving the 3 prompts for two different websites (within my company's local intranet - SharePoint 2010 and our Knowledge Base). I tried many different solutions noted above but the resolution from Markus Greiner above resolved me issue!

    Problem:

    In Windows 7, when accessing a specific website, Windows is prompting for login creditials, username and password many times.  When the prompt is displayed, you input your username and password and select the check box 'remember password' and click 'Ok', the prompt comes up again, so you enter your information one more time, then the propt comes up again....3 times in total even though the website/domain is added to the Local Internet section and/or Trusted Sites section of your Internet Options > Security tab.

    Solution:
    Go to Start > Control Panel > User Accounts > Manage your creditials

    There is most likely an entry for the website(s) that is/are being accessed when the 3 user creditial promts are received.  Expand the webpage record. Click 'Remove from vault'. When prompted to verify the deletion, click 'Yes'. This should alleviate the issue right away. Go to the website you had issues with before; it will open without any request for your credentials!

    This is a much better solution then not having a password or some of the other solutions above. Hope this helps others as well!

    Thursday, April 12, 2012 11:21 PM

All replies

  • "Automatic logon only in Intranet Zone" (under security settings) is the default setting for User Authentication - Logon in IE 7+. So unless you've customized your IE security settings you should ask users to add the site to the Intranet Zone not the Trusted Sites Zone if you want it to stop asking you for your login an password once you've entered it.

    Thursday, October 22, 2009 8:51 PM
  • This is already checked yet it still prompts, anything else?
    -Hu
    Thursday, October 22, 2009 8:54 PM
  • Trusted Zones works well for XPPro and IE6. When Vista and IE7 came out it was discovered that Trusted Zones no longer had the desired effect and it was necessary to put the SharePoint site in the Intranet security zone in IE.

    Since then with IE8 (and Win7) things are less clear although Intranet zone is the first try.

    So the first thing to do is to ask you to try Intranet zone for those users where it doesn't work.

    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    Friday, October 23, 2009 8:36 AM
  • Seems to NOT be a SP 2010 question ("our people") so I'm moving it to the normal Admin forum.


    Later: Well I would if I could but I have not got Moderator rights here.





    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    Friday, October 23, 2009 9:43 AM
  • Yes, this was the fix I implemented, but like I said it only works for 20% of the people,  is there any other setting you can think of that can cached credintial authentication to carry over to documents being opened?
    -Hu
    Friday, October 23, 2009 3:26 PM
  • had the same issue and its a real pain in the you know what. we have a server that is available internally and externally. internal users we fixed by adding the address to the local intranet server. externally (not on domain) you have to enable persistant cookies on ISA server. if you not using ISA server i dont know how to fix it.
    Friday, October 23, 2009 7:30 PM
  • Have you a Vista or Windows 7 Client? Than it could be the following KB: http://support.microsoft.com/kb/943280/en-us

    Friday, October 23, 2009 10:04 PM
  • This is a new change in security of Vista and Windows 7. To remove the login prompt you need to add a key “AuthForwardServerList” to the windows registry. Read the following guidelines.

    Helped for me
    SharePoint Tips & Tricks Portal | Microsoft MVP | My Blog | My twitter
    Saturday, October 24, 2009 12:27 PM
  • You can add the SharePoint URL to the list of Intranet sites and change the setting in IE Security Settings in IE from "Automatic logon only in Intranet Zone" to "Automatic logon with current username and password" if you want to use the current network login to authenticate.  this will stop the "pop up" windows.  You can also disable the security functionality (as listed below in another post) which also does this but it removed the security feature in IE.  Hope this helps.
    Tuesday, January 11, 2011 3:22 PM
  • Hi, i stumbled over Problems that are slightly different but i want to tell you the solution.

    Our Problem was that some users were prompted each time they accessed the sharepoint site plus once for each attachment. very disturbing...

    the solution was that this users had a entry in

    control-panel / useraccount (or similar, sorry i have german client) / advanced / manage passwords

     

    just deleted that account and the prompts were gone.

    wish you luck, all the best

    Markus

    Wednesday, April 27, 2011 8:59 AM
  • Thank you Markus!  This was exactly our issue.

    Sincerely,

      Phil


    Phil Shisbey
    • Proposed as answer by m78d Thursday, April 12, 2012 11:06 PM
    • Unproposed as answer by Margriet BruggemanMVP Wednesday, May 09, 2012 3:03 PM
    Friday, June 03, 2011 4:33 PM
  • I am using IE9, Windows 7 and am receiving the 3 prompts for two different websites (within my company's local intranet - SharePoint 2010 and our Knowledge Base). I tried many different solutions noted above but the resolution from Markus Greiner above resolved me issue!

    Problem:

    In Windows 7, when accessing a specific website, Windows is prompting for login creditials, username and password many times.  When the prompt is displayed, you input your username and password and select the check box 'remember password' and click 'Ok', the prompt comes up again, so you enter your information one more time, then the propt comes up again....3 times in total even though the website/domain is added to the Local Internet section and/or Trusted Sites section of your Internet Options > Security tab.

    Solution:
    Go to Start > Control Panel > User Accounts > Manage your creditials

    There is most likely an entry for the website(s) that is/are being accessed when the 3 user creditial promts are received.  Expand the webpage record. Click 'Remove from vault'. When prompted to verify the deletion, click 'Yes'. This should alleviate the issue right away. Go to the website you had issues with before; it will open without any request for your credentials!

    This is a much better solution then not having a password or some of the other solutions above. Hope this helps others as well!

    Thursday, April 12, 2012 11:21 PM
  • This is all well and good, however I am getting the issue with an external site http://procurement.sovereign.org.uk/Pages/EACDMC-ITT.aspx?PTI=EACDMC-ITT

    this is so people can look at records and bid for work, they need to open the docs, we have no control of anyones end user device to open them.

    Its a big problem with SharePoint 2010 prompting, the site is using anonymous access and does not have client intergration enabled (a previous microsoft fix).

    Wednesday, May 16, 2012 7:02 PM
  • Hello All,

    I have the same problem but the Prompt happens after the user closes IE. I found that pretty strange.

    I have checked the "user account --> manage credentials" and the vault is empty.

    Does anyone know how to resolve this? Should this question be posted on a new thread?

    Monday, June 18, 2012 5:05 PM