none
ssrs 2008r2 SharePoint integrated error 500 works fine in VS, BIDS and Report Builder

    Question

  • I have a fairly simple SSRS report (just cut and pasted a simple select into Report builder wizard and added a few params, no fancy formatiing, groups, etc.) that does not run when deployed in SharePoint 2010 SSRS.  I get the error below when I click to run after completing the parameters (which are able to get data from the db to populate multi select values fine).  When I run the report, nothing happens I get a little error exclamation point at the bottom and I click on it and get this message:

    ---------------------------------------------------------

    Message: Sys.WebForms.PageRequestManagerServerErrorException: An unknown error occurred while processing the request on the server. 
    The status code returned from the server was: 500
    Line: 5
    Char: 62099
    Code: 0

    -------------------------------------------------------

    That is about all the useful information I have been able to find.  I have tried adding the things mentioned to the web configs for both ReportServer and Report Mgr mentioned here (http://www.sqlservercentral.com/Forums/Topic1245595-150-1.aspx#bm1334791), but no luck.  PLEASE HELP! 



    Tuesday, August 27, 2013 1:43 AM

Answers

  • Hi Jason,

    From past experience we know that this is because of the following patch “MS11-100 .Net Framework Security Update (KB 2656355)”. Applying this update limits the maximum number of form keys, files and JSON members to 1000 in a request. An ASP.NET request that has lots of form keys, files, or JSON payload fails with an exception and returns a 500 HTTP status code. You can look at the following article more information:
    http://support.microsoft.com/kb/2661403

    In your scenario, you had add the setting to your web.config file, but without success, right? Please refer to the steps below to ensure that your setting are correct.

    1. Go to the reporting services installation folder.
    2. Go to the report server folder and make a backup of the file “Web.config”. Once you have the backup, open the original file in notepad and add the following entry under the Configuration section:
          <appSettings>
                      <add key="aspnet:MaxHttpCollectionKeys" value="10000"/>
          </appSettings>
    3. Go to the Report Manager folder and again make a backup of the file “Web.config”. Once you have the backup, open the original file in notepad and add the following entry under the appSettings tag:
      <add key="aspnet:MaxHttpCollectionKeys" value="10000"/>

    Once you do the above steps, you should be able to run the report without any issue.

    If you have any questions, please feel free to ask.

    Regards,
    Charlie Liao

    If you have any feedback on our support, please click here.


    Charlie Liao
    TechNet Community Support

    Wednesday, August 28, 2013 3:29 AM
    Moderator

All replies

  • Still not resolved, but I have found the issue is tied to a multi value parameters, that brings in a lot of records in the list of available values.  This works fine on the report parameters screen which lists all these values, but appears to be an issue on rendering of the report, whether I select one, or all the values....
    Wednesday, August 28, 2013 2:02 AM
  • Hi Jason,

    From past experience we know that this is because of the following patch “MS11-100 .Net Framework Security Update (KB 2656355)”. Applying this update limits the maximum number of form keys, files and JSON members to 1000 in a request. An ASP.NET request that has lots of form keys, files, or JSON payload fails with an exception and returns a 500 HTTP status code. You can look at the following article more information:
    http://support.microsoft.com/kb/2661403

    In your scenario, you had add the setting to your web.config file, but without success, right? Please refer to the steps below to ensure that your setting are correct.

    1. Go to the reporting services installation folder.
    2. Go to the report server folder and make a backup of the file “Web.config”. Once you have the backup, open the original file in notepad and add the following entry under the Configuration section:
          <appSettings>
                      <add key="aspnet:MaxHttpCollectionKeys" value="10000"/>
          </appSettings>
    3. Go to the Report Manager folder and again make a backup of the file “Web.config”. Once you have the backup, open the original file in notepad and add the following entry under the appSettings tag:
      <add key="aspnet:MaxHttpCollectionKeys" value="10000"/>

    Once you do the above steps, you should be able to run the report without any issue.

    If you have any questions, please feel free to ask.

    Regards,
    Charlie Liao

    If you have any feedback on our support, please click here.


    Charlie Liao
    TechNet Community Support

    Wednesday, August 28, 2013 3:29 AM
    Moderator