locked
Using ajax control toolkit v2.0 in visual studio 2008???????

    Question

  • Hi All, 
                 I have Visual Studio Pro 2008 on a to develop websites. I installed the newest toolkit for asp.net 3.5 and it works fine in all web application of framework 3.5 .

                 However, I installed the toolkit for asp.net 2.0 to use on asp.net 2.0 web development, but it doesn't work.

                 I am facing some problem, when I use ajax control tool kit of v3.5 in VS 2008 then it works well, But it gives problem when adding ajax dll of v1.0 & 2.0.

                     I have a.net application on version 2.0 in visual studio 2008. I want to use ajax control library in it. I tried it, adds the controls in toolbox & adds the ajax dll in bin folder of application. When I used controls in ajax library & build the application then got following error message

    The type 'System.Web.UI.ExtenderControl' is defined in an assembly that is not referenced. You must add a reference to assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'

    What is that ?????? What I should have to do????

    Also for I tring it with adding following code to web.config

    <compilation debug="true">
    <assemblies>
    <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
    </assemblies>
    </compilation>

    After that project builds ok. but when run it it opens disassembly & gives error as

    The TargetControlID of ... (control id) is not valid. A control with id ... could not found.

    Also use by adding

     <compilation debug="true">
       <assemblies>
        <add assembly="Microsoft.SqlServer.TxScript, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845DCD8080CC91"/>
        <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
        <add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
        <add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
        <add assembly="System.Web.Extensions.Design, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/></assemblies>
      </compilation>

     

    Then the application run successfully but ajax control will not work.............. Please suggest me how to solve this problem.

     

    Regards,

    Girish

     


    Thursday, July 16, 2009 10:17 AM

All replies

  • Hi All, 
                 I have Visual Studio Pro 2008 on a to develop websites. I installed the newest toolkit for asp.net 3.5 and it works fine in all web application of framework 3.5 .

                 However, I installed the toolkit for asp.net 2.0 to use on asp.net 2.0 web development, but it doesn't work.

                 I am facing some problem, when I use ajax control tool kit of v3.5 in VS 2008 then it works well, But it gives problem when adding ajax dll of v1.0 & 2.0.

                     I have a.net application on version 2.0 in visual studio 2008. I want to use ajax control library in it. I tried it, adds the controls in toolbox & adds the ajax dll in bin folder of application. When I used controls in ajax library & build the application then got following error message

    The type 'System.Web.UI.ExtenderControl' is defined in an assembly that is not referenced. You must add a reference to assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'

    What is that ?????? What I should have to do????

    Also for I tring it with adding following code to web.config

    <compilation debug="true">
    <assemblies>
    <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
    </assemblies>
    </compilation>

    After that project builds ok. but when run it it opens disassembly & gives error as

    The TargetControlID of ... (control id) is not valid. A control with id ... could not found.

    Also use by adding

     <compilation debug="true">
       <assemblies>
        <add assembly="Microsoft.SqlServer.TxScript, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845DCD8080CC91"/>
        <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
        <add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
        <add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
        <add assembly="System.Web.Extensions.Design, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/></assemblies>
      </compilation>

     

    Then the application run successfully but ajax control will not work.............. Please suggest me how to solve this problem.

     

    Regards,

    Girish

     


    Saturday, February 12, 2011 11:21 AM