none
How to hide webpart in SharePoint 2013 publishing home page site.

    Question

  • Hi, 

    I have a publishing site, there i have created a new publishing page and set that page as Set HomePage.  Here i have added content query webpart and customized it to make appear blog site and its appearing. 

    But, after saving the page the appearance of the webpart is little down. Its appearing 2 inches down. The upper part is blank.

    As a workaround i have added one more same content query webpart and saved the page. Now the appearance is perfect at top of the content place holder. 

    Okay, again i edited the page and tried hiding the 2nd CQWP but hiden option in edit webpart is disabled at layout section and in advanced section Alow Hide option is also disabled. 

    Now resolution of my query would be either to make 1st content query webpart at top of content place holder or to hide 2nd CQWP. 

    Please help me to achieve this. 

    Thanks in adv !!

    Cheers

    Saturday, January 25, 2014 7:19 PM

Answers

  • It's hard to pinpoint the cause of the problem given the information in this thread, but I would start troubleshooting by changing the MasterPage back to one of the out-of-the-box ones.

    Dimitri Ayrapetov (MCSE: SharePoint)

    • Marked as answer by Rakesh_SP Wednesday, January 29, 2014 6:01 PM
    Sunday, January 26, 2014 8:08 PM

All replies

  • I'm not sure I follow your problem 100%, are you not able to delete the web part from the page?

    If you have some other constraints and just need to hide the web part, I recently wrote a blog post for changing CSS attributes of a specific Web Part, you can use something like this to set the "display" to be equal to "none".

    http://dimitri.spgurus.com/blogs/2014/01/23/change-css-of-specific-content-query-web-part/


    Dimitri Ayrapetov (MCSE: SharePoint)


    Saturday, January 25, 2014 10:51 PM
  • Hi Dimitri,

    Deleting the webpart means you have only one webpart on the page and its appearing 2 inchs down of content place holder. 

    i have tried deleting/closing the 2nd CQWP, result is same 1st CQWP is appearing at down. So, as a workaround i have added 2nd webpart and i tried hiding it. but Hiden option under edit webpart layout section is disabled. let me show you..

    Content place holder starts from here..

    .

    .

    .

    When i added  webpart its appearing from here.. above empty space and then webpart. 

    Help me either to make appear webpart at top of content place holder or to hide 2nd webpart. 

    Thansk !!


    • Edited by Rakesh_SP Sunday, January 26, 2014 5:06 AM space was not taking
    Sunday, January 26, 2014 5:05 AM
  • In that case you have something that is pushing down your web part, either in HTML or CSS. Do you have custom branding (MasterPage / CSS) applied?

    Dimitri Ayrapetov (MCSE: SharePoint)

    Sunday, January 26, 2014 6:55 PM
  • Yes, i have created a HTML webpage and applied it as master page in SP 2013. Master page appearing perfect. is master page the reason for above issue?
    Sunday, January 26, 2014 7:13 PM
  • It's hard to pinpoint the cause of the problem given the information in this thread, but I would start troubleshooting by changing the MasterPage back to one of the out-of-the-box ones.

    Dimitri Ayrapetov (MCSE: SharePoint)

    • Marked as answer by Rakesh_SP Wednesday, January 29, 2014 6:01 PM
    Sunday, January 26, 2014 8:08 PM
  • Can you try accessing the maintenance page by adding a ?contents=1 at the end of your URL. Here you can reset the second webpart and see if this allows you to hide it.

    Otherwise as Dimitri says, change the master page to an oob one and try to replicate the issue. You may need to rework your custom page. 


    Steven Andrews
    SharePoint Business Analyst: LiveNation Entertainment
    Blog: baron72.wordpress.com
    Twitter: Follow @backpackerd00d
    My Wiki Articles: CodePlex Corner Series
    Please remember to mark your question as "answered" if this solves (or helps) your problem.

    Sunday, January 26, 2014 10:53 PM
    Answerer
  • sorry for delay !!

    yes the problem was with CSS only.. i have fixed CSS code now its appearing perfect. Now the 1st webpart itself appearing at top of content place holder. 

    Thanks for your help !!

    Wednesday, January 29, 2014 6:22 PM