none
URGENT : Sample Proposal Workflow Issue

    Question

  • Hello

    I have this really annoying issue. I have checked all the required settings found as told by similar threads and technet articles. I have created a Sample Proposal Enterprise Project Type and set the Sample Proposal to start on it. When i create the project it works fine and i get the message workflow started from my Queue jobs. But when I click on the Project name in Project Center I get the following error:

    "Unable to open the project. The project has not been properly initialized. This may be caused by the workflow associated with the Enterprise Project Type not starting correctly. Please contact your system administrator". 

    When i check workflow settings under site settings i can see that the workflow is in progress.

    Please help.

    Thanks.

    Tuesday, November 13, 2012 11:18 AM

Answers

  • The workflow history pages tend to show a lot more details:

    - Go to Site Actions, View All Site Content, Site Workflows, Show All Workflows, and in the table below you should see a list of running workflows, and some errors error. If you click on an error, it should give you more information about what went wrong
    - Go to Site Actions, View All Site Content, there is a list called Project Server Workflow History, if you open it and sort it by date descending, you should also see the latest workflow errors.

    Check out http://social.technet.microsoft.com/Forums/en-US/projectserver2010general/thread/eae9c9c4-4c52-4e52-823b-9e66cdf3c3b3 as well.


    www.umt.com | www.umtprojectessentials.com

    • Marked as answer by bami131 Tuesday, November 13, 2012 5:49 PM
    Tuesday, November 13, 2012 5:37 PM
  • Hi all,

    I finaly found  a lasting solution to my issue. All I had to do was restart the  "Microsoft Project Server Queue service." and voila no more silly errors!!! 

    Thanks to writer of this blog. "wss.bowman.biz/Lists/Posts/Post.aspx?ID=49"

    • Marked as answer by bami131 Thursday, November 15, 2012 10:34 AM
    • Unmarked as answer by bami131 Thursday, November 15, 2012 10:34 AM
    • Marked as answer by bami131 Thursday, November 15, 2012 10:34 AM
    Thursday, November 15, 2012 10:34 AM

All replies

  • The workflow history pages tend to show a lot more details:

    - Go to Site Actions, View All Site Content, Site Workflows, Show All Workflows, and in the table below you should see a list of running workflows, and some errors error. If you click on an error, it should give you more information about what went wrong
    - Go to Site Actions, View All Site Content, there is a list called Project Server Workflow History, if you open it and sort it by date descending, you should also see the latest workflow errors.

    Check out http://social.technet.microsoft.com/Forums/en-US/projectserver2010general/thread/eae9c9c4-4c52-4e52-823b-9e66cdf3c3b3 as well.


    www.umt.com | www.umtprojectessentials.com

    • Marked as answer by bami131 Tuesday, November 13, 2012 5:49 PM
    Tuesday, November 13, 2012 5:37 PM
  • oh wow..

    Thanks a lot Catalin. I got more info about the error message. I'm getting a GeneralSecurityAccess Denied. It says the wfproxy does not have permission to complete the requested PSI call: Project Uid = "", ProxyUserAccount = "".

    How do i fix this?


    Tuesday, November 13, 2012 5:52 PM
  • Hi Catalin,

    So i fixed the Access Denied issue and then another one arises. I still get the same error "Unable to open the project. The project has not been properly initialized. This may be caused by the workflow associated with the Enterprise Project Type not starting correctly. Please contact your system administrator" when i click on the project name in project center. This time around when i check the Workflow history list it shows

    "Error :Sample Proposal failed to start"

    "Error: Sample Proposal failed to run"

    Please help!!!

    Wednesday, November 14, 2012 6:41 AM
  • Hi there--

    Did you try to change or restart the workflow?
    http://technet.microsoft.com/en-us/library/gg188108.aspx

    Hope that helps.


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    Wednesday, November 14, 2012 8:28 AM
  • Hi all,

    I finaly found  a lasting solution to my issue. All I had to do was restart the  "Microsoft Project Server Queue service." and voila no more silly errors!!! 

    Thanks to writer of this blog. "wss.bowman.biz/Lists/Posts/Post.aspx?ID=49"

    • Marked as answer by bami131 Thursday, November 15, 2012 10:34 AM
    • Unmarked as answer by bami131 Thursday, November 15, 2012 10:34 AM
    • Marked as answer by bami131 Thursday, November 15, 2012 10:34 AM
    Thursday, November 15, 2012 10:34 AM
  • Project Server Settings - Project Workflow Settings (under Workflow and Project Detail Pages) includes a setting for the Workflow Proxy User. That field has a pretty comprehensive and clear description.

    www.umt.com | www.umtprojectessentials.com

    Monday, November 26, 2012 7:02 PM