none
TFS 2012 Update 3 Issue with PSBridge ISAPI Filter

    Question

  • I have upgraded TFS 2012 Update 1 to TFS 2012 Update 3.  I had a similar issue to what I had with a previous upgrade where the PSBridge ISAPI filter could not be loaded.  To get around this I simply deleted the PSBridge filter from the list.  But I am wondering if this is causing any other issues and what the correct solution is going forward as this seems to come back.

    TFS 2012 Update 3 is installed on a windows server 2008 R2 with Service Pack 1 running IIS 7.

    This is the issue from the event viewer:

    Log Name:      Application
    Source:        Microsoft-Windows-IIS-W3SVC-WP
    Date:          8/16/2013 10:31:29 AM
    Event ID:      2274
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      VBMPRWEB289.CBN.Local
    Description:
    ISAPI Filter 'C:\inetpub\wwwroot\LMS\psiisbridge.dll' could not be loaded due to a configuration problem. The current configuration only supports loading images built for a AMD64 processor architecture. The data field contains the error number. To learn more about this issue, including how to troubleshooting this kind of processor architecture mismatch error, see http://go.microsoft.com/fwlink/?LinkId=29349.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-IIS-W3SVC-WP" Guid="{670080D9-742A-4187-8D16-41143D1290BD}" EventSourceName="W3SVC-WP" />
        <EventID Qualifiers="49152">2274</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2013-08-16T14:31:29.000000000Z" />
        <EventRecordID>137168</EventRecordID>
        <Correlation />
        <Execution ProcessID="0" ThreadID="0" />
        <Channel>Application</Channel>

        <Security />
      </System>
      <EventData>
        <Data Name="IsapiFilter">C:\inetpub\wwwroot\LMS\psiisbridge.dll</Data>
        <Data Name="ProcessorArchitecture">AMD64</Data>
        <Binary>C1000000</Binary>
      </EventData>
    </Event>

    Friday, August 16, 2013 2:49 PM

Answers

  • Hi Mister, 

    Thanks for your reply.

    As far as I know we should configure ISAPI Filters in IIS, but I don’t think TFS Server need this PSBrige filter. To configure ISAPI Filters in IIS 7, please refer to the information in this document: http://technet.microsoft.com/en-us/library/cc733109(v=ws.10).aspx or contact IIS experts for the better response.

    Please run the TFS 2012 Power Tools Best Practice Analyzer to scan the installation of your TFS 2012 Server.


    John Qiao [MSFT]
    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Friday, August 23, 2013 3:00 AM
    Moderator

All replies

  • Hi Mister, 

    Thanks for your post.

    Does there have any issues when you using your TFS 2012 Update 3 server?

    You deleted the PSBridge filter from which list, a TFS list?

    From that event message, I can’t find any information relate to TFS. Maybe you need to contact IIS experts for the better response.


    John Qiao [MSFT]
    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Monday, August 19, 2013 3:35 AM
    Moderator
  • Hi Mister, 

    If misunderstood anything, please describe your question in more detail and we will try to provide the better responses.


    John Qiao [MSFT]
    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Tuesday, August 20, 2013 7:10 AM
    Moderator
  • Sorry, the PSBridge was deleted from the TFS web site's ISAPI filter list.  Before it was deleted no one could connect to the web access site. 

    Wednesday, August 21, 2013 12:10 PM
  • Hi Mister, 

    Thanks for your reply.

    After you deleted the PSBridge, everything in your TFS Web Access working normally now?

    If you occurred any specific issue, please share the detailed issue information here. 


    John Qiao [MSFT]
    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Thursday, August 22, 2013 1:33 AM
    Moderator
  • Everything we are currently using is working as expected.

    My concern is that there is something in the product using that ISAPI Filter (why else would it have been installed with it) and either we are not currently using it or not seeing the errors coming from it.  I know that we are in the process of standing up Microsoft Project Server and are wanting to use the feature to sync up TFS with Project Server.  Is this going to affect that?

    Thursday, August 22, 2013 12:51 PM
  • Hi Mister, 

    Thanks for your reply.

    As far as I know we should configure ISAPI Filters in IIS, but I don’t think TFS Server need this PSBrige filter. To configure ISAPI Filters in IIS 7, please refer to the information in this document: http://technet.microsoft.com/en-us/library/cc733109(v=ws.10).aspx or contact IIS experts for the better response.

    Please run the TFS 2012 Power Tools Best Practice Analyzer to scan the installation of your TFS 2012 Server.


    John Qiao [MSFT]
    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Friday, August 23, 2013 3:00 AM
    Moderator