none
The missing "Add STS Reference" (VS 2008 & WIF)

    Question

  • Having uninstalled the Geneva Framework and installed the newly released Windows Identity Foundation RC (here ), I find the the previous "Modify STS Reference" is still there (just a unfuncional link) but the "Add STS Reference", which is supposed to take the place of "Modify STS Reference", does not show up.

    I spent hours to google for solution, but never succeeded ... Can anyone help? Most appreciation!!
    • Moved by SrikumarV Tuesday, September 28, 2010 11:59 PM Migration (From:Windows Azure AppFabric)
    Tuesday, November 10, 2009 6:42 AM

Answers

  • Hi, guys. I finally solved this problem by multi times of uninstall and reinstall the sdk and runtime.. I remembered that for the last attempt, when I uninstalled the WIF runtime, the system required a reboot. After that, everything's ok : )

    Thanks for your concern. Good luck!
    • Marked as answer by Yi-Lun Luo Tuesday, November 17, 2009 11:55 AM
    Wednesday, November 11, 2009 9:05 AM

All replies

  • Hello, it seems that you have not removed the old Geneva Framework completely. Can you try again? First please close all instances of Visual Studio (I'm guessing you missed this step), and then remove both Geneva Framework SDK and Geneva Framework Runtime. Then install WIF Runtime and then WIF SDK. Now open Visual Studio, and you should be able to see the "Add STS Reference" option.
    Lante, shanaolanxing This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, November 10, 2009 9:32 AM
  • I am having the same issue.  I have searched in installed programs and I do not see anything with the keyword Geneva (although I did have it installed at one time).  I have uninstalled and reinstalled the WIF Runtime and the SDK.  No dice.
    Wednesday, November 11, 2009 8:10 AM
  • Hi, guys. I finally solved this problem by multi times of uninstall and reinstall the sdk and runtime.. I remembered that for the last attempt, when I uninstalled the WIF runtime, the system required a reboot. After that, everything's ok : )

    Thanks for your concern. Good luck!
    • Marked as answer by Yi-Lun Luo Tuesday, November 17, 2009 11:55 AM
    Wednesday, November 11, 2009 9:05 AM
  • Based on that advice I tried the following:
     

    Uninstall the WIF SDK

    Uninstall the WIF Runtime

    reboot

    ReInstall Geneva Framework

    ReInstall Geneva Framework SDK

    reboot

    Uninstall Geneva Framework SDK

    Uninstall Geneva Framework

    reboot

    Install the WIF Runtime

    Install the WIF SDK

    Still no luck.  I am running Windows 7 Ultimate, 64 bit edition, and I have Visual Studio 2010 Beta 2 installed.  I don't know if that helps at all.

    Wednesday, November 11, 2009 3:22 PM
  • I didnt re-install Geneva,,, only did it on WIF...

    And,,, did you reboot urself or did the system raise a reboot notice? When I uninstalled the WIF Runtime in the 'view installed updates', the system raised an alert for reboot.

    My os is Windows 7 pro 86x and the ide is VS2008SP1...

    hope it could be helpful.
    Wednesday, November 11, 2009 3:36 PM
  • We are having problems like this going from the Beta 2 to WIF RC on WIndows 2008.

    We uninstalled the beta components and installed the RC version. In VS 2008 we still see the old Modify STS...instead of ADD STS and when trying the option nothing happens.

    Also, when trying to run Dominiks new STS we are getting errors from ASP.Net suggesting there are some references to the old assemblies somewhere...

    Any more information?
    Thursday, November 19, 2009 8:40 PM
  • I solved the problem by copying Microsoft.IdentityModel.Tools.VS.VSAddin.Addin file form Windows Identity Foundation SDK\v3.5\Visual Studio Extensions folder to Users\All Users\Microsoft\MSEnvShared\Addins\WSESettingsVS3.Addin folder (one of VS's add-in paths).
    I have WS 2008 and VS 2008.
        
    • Proposed as answer by SpatDSG Saturday, February 06, 2010 10:48 PM
    Wednesday, November 25, 2009 4:00 PM
  • In my Visual Studio 2008 (on Windows 2008 R2 x64), the add-in shows up under Tools>Add-in Manager... as loaded but the context menu for any kind of web site or web application project. The project templates are loaded and I am able to create new STS or claim-aware websites, but I am unable to add/modify STS references for existing web projects.

    Reinstalling WIF + WIF SDK does not work.
    Repairing WIF + WIF SDK does not work.
    Running VS 2008 with elevated privileges does not work.

    The server never had any previous version of WIF or the WIF SDK installed. I verified that the Microsoft.IdentityModel.Tools.VS and Microsoft.IdentityModel.Tools.VS.resources assemblies are installed in the GAC.

    What am I missing?
    • Proposed as answer by BrandynPhelps Sunday, December 06, 2009 2:48 AM
    Thursday, December 03, 2009 10:26 PM
  • Actually, I was having this problem as well, and I often found this thread in searches for how to fix it.  On a hunch, I decided to uninstall the beta VS 2010 I had installed on the same machine-- One more reinstall later, and the proper context menu items were added by the plugin!

    • Proposed as answer by EdmundIE Friday, December 11, 2009 3:02 PM
    Sunday, December 06, 2009 2:49 AM
  • The problem seems to be the Add-in Manager cannot process the Microsoft.IdentityModel.Tools.VS.VSAddin probably because it cannot locate Microsoft.IdentityModel.Tools.FedUtil.dll which is in C:\Program Files\Reference Assemblies\Microsoft\Windows Identity Foundation SDK\v3.5.

    You can manually fix this by going to Tools Options, clcik on Add-in/Macros Security and either making sure it is in one of the paths displayed - or by adding a reference to its existing paths.

    However the reason this has occurred is because one of the installs did not complete or is missing, so I would suggest that you try the re-install options mentioned above first.

    Friday, December 11, 2009 3:12 PM
  • Hi,

    I am too facing same issue.

    I am running VS 2008 on Vista SP2.

    I have uninstalled earlier Geneva completely and installed WIF runtime and SDK (uninstalled & installed 2 to 3 times atleast), also rebooted the machine after every step. Still the same issue.

    The required Add In is present correctly in the path that is present in Add Ins Tools -> Option -> Addin/Macros Security dialog.

    Can some body help? I am stuck here and badly need help.

    BTW, the core issue is, I can see Modify STS reference menu and Run Federation Utility Tool menu but both are not working as well as I can't see Add STS reference menu.

    Thanks
    Laxmikant
    • Edited by Laxmikant Thursday, December 31, 2009 9:34 AM additional info
    Thursday, December 31, 2009 9:32 AM
  • Hi

    Me too also stuck at the same point....
    I am not able to see Add STS reference option. Instead of that i can see Modify STS reference & Federation Utility Tool but none of the option is working.
    I have installed WIF Runtime & SDK after removing Geneva runtime & SDK.

    Also i have check all the solutions given here in the blog but none of it working for me.

    Please help me in this.

    Thursday, December 31, 2009 9:50 AM
  • Hi,
    I'm also having trouble with this missing Add STS reference.
    Just to further muddy the waters I created a web site as Admin on my Win2008 R2 server and all worked fine - I was able to Add STS Reference.

    However, when I came to create a second web site (following the MS "ActAs" Step-by-Step guide) I no longer had the Add STS Reference option.  The difference was that the second time I was logged in as a domain user rather than the local Admin.  I did run VS2008 as Administrator but that doesnt seem to be enough.

    I think it's a permissions problem but no idea where...
    Monday, January 04, 2010 5:08 PM
  • Further to my last...
    I should have read the readme.htm for WIF SDK.  In the Runtime and Installation Issues section it says

    "The Visual Studio add-in, which supports integrating FedUtil from the Visual Studio, is installed only for the current user. To install the add-in for any other user, follow the following instructions:

     

    a.    Close any instance of Visual Studio.

    b.    On a command-prompt, execute the following command to copy the add-in file. Note that you need to replace "Visual Studio 2008" if you are using a different version of Visual Studio. Also note that on 64-bit systems, the WIF SDK installs to %ProgramFiles(x86)% rather than %ProgramFiles%.

    (i).         copy "%ProgramFiles%\Windows Identity Foundation SDK\v3.5\Visual Studio Extensions\Microsoft.IdentityModel.Tools.VS.VSAddin.Addin" "%USERPROFILE%/Documents/Visual Studio 2008/Addins/"

    c.    Open an instance of Visual Studio.


    After copying the add-in to my non-Admin user it all worked fine.
    • Proposed as answer by Rob Engberg Monday, February 22, 2010 6:57 PM
    Monday, January 04, 2010 8:30 PM
  • I had to:
    1. Disable UAC
    2. Uninstall WIF SDK & runtime
    3. Manual reboot
    4. Install WIF runtime & SDK
    5. AddIn works
    I have Windows 7 Enterprise x64 & VS 2008 SP1.  The goal of developing with least privilege seems just out of reach.

    --Don
    Wednesday, February 03, 2010 2:55 PM
  • Thanks Paul - this worked great for me!
    boms
    Saturday, February 06, 2010 11:00 PM
  • Yeap uninstalling VS2010 b2 + removing UAC + reinstall WIF runtime & SDK did it for me.
    Jonathon
    Thursday, March 11, 2010 1:15 AM
  • I uninstalled vs 2010 beta, and it worked. Thanks!
    Monday, March 15, 2010 12:21 PM
  • FYI on this issue:

     

    If you are uninstall WIF SDK by clicking the msi file and then selecting remove button, then some custom action inside the installer fails if UAC is turned on even if you are an admin user. This was a bug inside the msi. Due to this bug, the addin file and the visual studio template files do not get removed and properly uninstalled, leaving VS in a bad state. VS should come to a good state again if you install the sdk again.

     

    This does not happen if you uninstall WIF SDK from Add/Remove program even if UAC is on.

     

    Solution:

    1.       Wait for the next official SDK (one for 3.5 and another for 4.0)release, which is coming soon with this bug fixed. OR,

    2.       Manually clean up VS and then reinstall the SDK. To clean up VS,

    a.       Close all VS instances.

    b.      Delete the Microsoft.IdentityModel.Tools.VS.AddIn file from %Documents%\Visual Studio 2010\AddIn folder.

    c.       Delete the template files from %Program Files%\Visual Studio 2010\Common7\IDE\ProjectTemplates\WebSite\CSharp\csClaimsAware*.zip (There should be 4 files)

    d.      Run >%Program Files%\Visual Studio 2010\Common7\IDE\devenv /setup   (This will reset VS addin and templates)

    And if you had a previous version of WIF SDK installed (that also has the above mentioned bug) and now installing the latest SDK gives this issue of still seeing "Modify STS reference", you might want to follow these steps before you install the new version.

    1. Close any instance of VS

    2. Uninstall the previous SDK from Add/Remove program. Make sure there is no Microsoft.IdentityModel.Tools.Addin.addin file under %YourMyDocuments%\Visual Studio 20**\Addin\ folder.

    3. Open VS and then close again. This step is required cause VS internally keeps some cached state that stores the add-in information along with other stuff. Opening VS refreshes these states thus removing old SDK's addin info.

    4. Install the new SDK.

    Hope this helps.

    Sunday, April 11, 2010 1:42 AM
  • Excellent. This works fine after specifying the folder in Tools->Options as mentioned in your mail. Thanks for the suggestion.
    Monday, April 12, 2010 6:24 AM
  • FYI on this issue:

     

    If you are uninstall WIF SDK by clicking the msi file and then selecting remove button, then some custom action inside the installer fails if UAC is turned on even if you are an admin user. This was a bug inside the msi. Due to this bug, the addin file and the visual studio template files do not get removed and properly uninstalled, leaving VS in a bad state. VS should come to a good state again if you install the sdk again.

     

    This does not happen if you uninstall WIF SDK from Add/Remove program even if UAC is on.

     

    Solution:

    1.       Wait for the next official SDK (one for 3.5 and another for 4.0)release, which is coming soon with this bug fixed. OR,

    2.       Manually clean up VS and then reinstall the SDK. To clean up VS,

    a.       Close all VS instances.

    b.      Delete the Microsoft.IdentityModel.Tools.VS.AddIn file from %Documents%\Visual Studio 2010\AddIn folder.

    c.       Delete the template files from %Program Files%\Visual Studio 2010\Common7\IDE\ProjectTemplates\WebSite\CSharp\csClaimsAware*.zip (There should be 4 files)

    d.      Run >%Program Files%\Visual Studio 2010\Common7\IDE\devenv /setup   (This will reset VS addin and templates)

     

    And if you had a previous version of WIF SDK installed (that also has the above mentioned bug) and now installing the latest SDK gives this issue of still seeing "Modify STS reference", you might want to follow these steps before you install the new version.

    1. Close any instance of VS

    2. Uninstall the previous SDK from Add/Remove program. Make sure there is no Microsoft.IdentityModel.Tools.Addin.addin file under %YourMyDocuments%\Visual Studio 20**\Addin\ folder.

    3. Open VS and then close again. This step is required cause VS internally keeps some cached state that stores the add-in information along with other stuff. Opening VS refreshes these states thus removing old SDK's addin info.

    4. Install the new SDK.

     

    Hope this helps.


    Hi,

    I followed the above instruction, but this time to fix a different manifestation of this issue: I have the 'Add STS reference' and 'Update federation metadata' option, but I am missing the option to modify. The resets above do not work to fix this.

    I am domain admin on the machine, UAC was disabled from the beginning of the server/OS preparation. WIF SDK was installed under these credentials.

    Any other alternatives to get my GUI based modification working in VS2008 instead of editing the claims apps files directly?

    Thank!


    Danny Alvares, Technical Solutions Architect IAM
    Sunday, April 25, 2010 8:48 PM
  • As of June 24th 2010 download (The download publish date is 5th May 2010) , it appears you still need to turn off UAC on Win7 (Probably applies to Vista as well) for the WIF SDK install to function correctly, else it throws an error about not having the correct .NET framework version installed.
    Wednesday, June 30, 2010 3:44 AM
  • I've done all of this, (even turning off UAC and repairing VS2010) and the commands still don't show up for me.  It's as if the AddIn simply isn't loading (even though it's checked in the add-in manager).  I've never installed Geneva or prior version, either.

    Saturday, July 03, 2010 1:48 PM
  • I had the same problem (no Add STS Reference...) on Windows 7 - VS2010 Ultimate.

    This solved the problem:

    1. Copy Microsoft.IdentityModel.Tools.FedUtil.dll from C:\Program Files (x86)\Reference Assemblies\Microsoft\Windows Identity Foundation SDK\v4.0 to C:\Program Files (x86)\Windows Identity Foundation SDK\v4.0\Visual Studio Extensions.

    2. Add C:\Program Files (x86)\Windows Identity Foundation SDK\v4.0\Visual Studio Extensions directory  to VS2010 - Tools - Options - Environment - Add-in/Macros Security

    3. Restart VS2010. Add STS Reference now shows up in context menu on web sites and in VS2010 Tools. (together with 'Run Federation Utility tool..)

    Hope this helps :-)

     

    • Proposed as answer by Erik Oppedijk Tuesday, December 28, 2010 2:08 PM
    Wednesday, July 07, 2010 9:13 PM
  • One thing that has not been explained is that it appears to be impossible to get this working with Visual Studio Express.  It appears that many things are not supported with express including add-ins.

    Also, it is possible to do this without the link by using the FedUtil.exe tool.  You just need to find the tool and input the location of web.config for the project you want to use.  It seems that only the web.config is modified during this process.


    Jeff Muir Citrix Labs
    Wednesday, July 14, 2010 11:26 PM
  • I solved this issue:

    I read the  "%ProgramFiles%\Windows Identity Foundation SDK\v4.0\readme.htm and I follow the instruction below

    a.    Close any instance of Visual Studio.

    b.    On a command-prompt, execute the following command to copy the add-in file. Also note that on 64-bit systems, the WIF SDK installs to %ProgramFiles(x86)% rather than %ProgramFiles%.

    copy "%ProgramFiles%\Windows Identity Foundation SDK\v4.0\Visual Studio Extensions\Microsoft.IdentityModel.Tools.VS.VSAddin.Addin" "%USERPROFILE%/Documents/Visual Studio 2010/Addins/"

    c.    Open an instance of Visual Studio.

    I add one more Step:

    d. Go to tools->Options->Add-in/Macros Security and check the path of add-in.

    If you have the path "%USERPROFILE%/Documents/Visual Studio 2010/Addins/"

    Everything will work; if you don’t have that path just add it so your Add-in Manager will be happy. You can also check tools ->add-in manager to see if available add-ins is included the Windows Identity Foundation add-in.

    Close Visual Studio and reopen. And everything must work.

     Ihope things work.

    Galan.

     

     

     

    • Proposed as answer by wadneyare Tuesday, December 28, 2010 3:44 PM
    Friday, October 29, 2010 5:21 AM
  • I was also facing the same problems, couldn't open the VS2010 templates for WIF.

    I only installed the 4.0 SDK. But after I installed alo the 3.5 version, all my problems were solved :-)

    • Proposed as answer by StevenD007 Thursday, February 24, 2011 12:24 PM
    Thursday, February 24, 2011 11:37 AM
  •  VS2010 in Server 2008R2, same issue

    > Uninstalled WIF4.0

    > Rebooted

    >Installed.

    Working fine

    Tuesday, July 19, 2011 11:27 PM
  • Thanks Rob, that did it for me.
    Emmanuel
    Friday, August 26, 2011 3:45 PM
  • Why is this do hard Microsoft?  This bug has been present since 2008?  I've tried everything listed a s a solution - nothing works.  Using VS2010 Ultimate SP1.  Server 2008 R2.  I've tried all version of WIF SDK.  Nothing works.  Add STS never comes up...very frustrating.  Is there a Connect issue on this somewhere? 
    Sunday, February 12, 2012 12:34 AM
  • Finally this fixed my system (VS10 on Win 7). The Add STS now appear under Tools > Add STS Reference.., that's good enough. Thanks.
    Tuesday, May 15, 2012 2:26 PM
  • I have generally found that you can reinstall the identity sdk multiple times and it never gets fixed, so I always try and patch it up manually.  Make sure the SDK addin "Microsoft.IdentityModel.Tools.VS.VSAddin.Addin" is accessible from one of your tools->options->Add-in/Macros Security folders --- Or add a new folder at say "%USERPROFILE%\Documents\Visual Studio 2010\Addins" folder if it and put it there.  Then do a reset - devenv /ResetAddin Microsoft.IdentityModel.Tools.VS.VSAddin.FederationAddin.

    Friday, July 13, 2012 8:27 PM