locked
Autocad 2012 (64 bit) failed to install

    Question

  • Windows ‘8’ Developer Preview “comes with” Microsoft .Net Framework 3.5.1 and Microsoft .Net Framework 4.5. Some of the desktop applications that I use happen to rely on some versions of .Net Framework, including Nero Multimedia Suite 10, Microsoft Mathematics 4.0, AutoCAD 2012, and etc. Microsoft .Net Framework 3.5.1 and some components of Microsoft .Net Framework 4.5 are Windows features which are “off” by default. When I tried to turn “on” the features, Windows ‘8’ Developer Preview actually requires me to connect to Internet to download some components online through Windows Update, which I found puzzling. After I turned “on” Microsoft .Net Framework 3.5.1 and Microsoft .Net Framework 4.5, it appears that Microsoft Mathematics 4.0 and Nero Multimedia 10 can be installed and executed but I failed to install AutoCAD 2012. Does anybody have any clues how to get AutoCAD 2012 installed in Windows ‘8’ Developer Preview?


    Sonic the Hedgehog
    Thursday, September 15, 2011 1:52 PM

Answers

  • Hi jcsonic,

    I've investigated this and Microsoft is aware of the issues with Autocade 2012 and Autocad Lt 2012 and we have passed this feedback onto the right group.

    Thanks again,

    BillFill - MSFT

    Friday, September 16, 2011 1:30 AM
    Owner

All replies

  • Hi jcsonic,

    I've investigated this and Microsoft is aware of the issues with Autocade 2012 and Autocad Lt 2012 and we have passed this feedback onto the right group.

    Thanks again,

    BillFill - MSFT

    Friday, September 16, 2011 1:30 AM
    Owner
  • I eventually figured out the way to install AutoCAD 2012 (64 bit) in Windows “8” Developer Preview. I manually edited the setup.ini file. I speculated that the failed attempt to install Microsoft .Net Framework 4.0 was the reason behind the prevention of the installation of Windows “8” Developer Preview. In “Turn Windows Features on or off”, I manually enable both “Microsoft .Net Framework 3.5.1” and “Microsoft .Net Framework 4.5 Advanced Services”. Windows “8” Developer Preview connected to Internet using “Windows Update” to turn on “Microsoft .Net Framework 3.5.1” and “Microsoft .Net Framework 4.5 Advanced Services”. I suspected while I cannot install Microsoft .Net Framework manually using the installers downloaded from Microsoft web site, “Windows Update” and “Turning on Features” may actually make .Net Framework turned on in Windows “8” Developer Preview. Still, AutoCAD 2012 setup process will try to verify and install Microsoft .Net Framework. Such verification process prevented the AutoCAD 2012 to proceed as it assumed that my PC was not meeting the system requirement. I removed all references to .Net Framework in the setup.ini file of AutoCAD 2012 installation folder. While I did get error messages while installing AutoCAD 2012, the installation process eventually proceeded and finished.

    Here came the real test. Did AutoCAD 2012 actually run after being installed by such a trick? Well, it did. But when I tried to close AutoCAD 2012, I received an error message and a dialogue box requesting permission from me to send error report. This always happened whenever I closed AutoCAD 2012. Despite all the compatibility issues, I am glad that I finally get AutoCAD 2012 running on Windows “8” Developer Preview. Will this compatibility issue be fixed when Windows “8” Beta is released? I honestly do not know. From the functional standpoint, the “workaround” that I mentioned does make AutoCAD 2012 works, that’s if you do not mind to see error message every time you close AutoCAD 2012.


    Sonic the Hedgehog
    • Proposed as answer by nataku Monday, December 26, 2011 1:04 PM
    Thursday, September 22, 2011 11:28 AM
  • can i get a copy of your autocad setup.ini please.  I tried missing with the setup.ini and deleting the ,Net Framework but its not working for me....   my email is chinhvannguyen@sbcglobal.net

     

     

    thx

    • Proposed as answer by Nazifi Friday, October 07, 2011 7:43 PM
    Saturday, September 24, 2011 7:59 AM
  • Assuming that you’ve “turned on” Microsoft .Net Framework 3.5.1 and Microsoft .Net Framework 4.5, my advice will make AutoCAD 2012 work. Even if you’ve modified setup.ini as I suggested, you click “Install” from AutoCAD 2012 setup Window, it’s very like that the AutoCAD 2012 just crash after trying to verify your system. Instead of clicking “install” first, I clicked “Install Tools and Utilities”. Of course, I did not actually install “Tools and Utilities”; when I got to another page prompting me to proceed, I just clicked “Back”. If you’ve modified “setup.ini” correctly, clicking “Install” this time will successfully initiate the setup process. You can then make some choices as usual before the installation of AutoCAD 2012 begins. Speaking of “setup.ini”, I’ve uploaded it to my SkyDrive. Note that I make no guarantee of anything I said here. I merely share my own experience.


    Sonic the Hedgehog
    Saturday, September 24, 2011 9:55 AM
  • Thank you jcsonic. I downloaded setup.ini file from your skydrive. But I couldn't install autocad 2012. it's giving lots of error mesages like "section dotnet xxx missing".  then when the error messages finished I click install button. But when I click install, it's open a window and saying error report e.g. and then install program is closing, How can we solve this problem. Pls help me... 

     

    Thanks..

    Friday, October 07, 2011 6:43 PM
  • im experiencing the same problem! after I click "Install tools and utilities", click back then install did not work for me. I've used the setup.ini from your skydrive and have turned on Microsoft .Net Framework 3.5.1 and Microsoft .Net Framework 4.5. please help me!

    Saturday, October 15, 2011 4:23 AM
  • I was trying to help others who were interested in testing AutoCAD 2012 in Windows “8” Developer Preview. Unfortunately, it appears that the references to “dot net 2.0” and “dot net 4.0” were not completely removed from setup.ini file which I’ve uploaded to Windows Live SkyDrive the first time. I’ve corrected the issues and tested it myself (successfully). After receiving a number of replies through my email, I decided to take a look at the issue. I uninstalled AutoCAD 2012 and reinstalled it by replacing the original setup.ini from the version from my SkyDrive. As expected, the installation was failed. From the log file, I saw that it was still trying to install .net 2.0 and .net 4.0. I realized that the one I’ve uploaded was not changed completely. You may have wondered how the “setup.ini”, which was uploaded to SkyDrive, can be problematic if I managed to install AutoCAD 2012. The truth is that I did not keep the setup.ini file when I successfully edited it initially. When I saw other have responded to the forums, I tried to edit setup.ini again but missed a few lines.

    Again, please reply in this forum if you faced any problems. I hope that I could be any help.


    Sonic the Hedgehog
    Saturday, October 15, 2011 9:07 AM
  • thanks for the re-upload! this time there wasn't any error message. I've follow your steps accordingly, but after clicking install, the autodesk installer error report popped up. I've tried clicking "install tools and utilities", then click back and install. I tried several times to no avail.. might I ask, is there any other steps that I'm missing??

    many thanks for your prompt reply!

    • Proposed as answer by sissyquantum Tuesday, October 18, 2011 9:58 AM
    • Unproposed as answer by sissyquantum Tuesday, October 18, 2011 10:08 AM
    Tuesday, October 18, 2011 9:47 AM
  • May I know how exactly you know the failing of the installation? Error message? Log file? Screenshot? Lack of details will prevent me from knowing what was wrong exactly. All I can say is that I can install it on Windows “8” Developer Preview convolutedly, if not directly. More information will certainly be helpful for us to figure out the problems for you.


    Sonic the Hedgehog
    Tuesday, October 18, 2011 10:00 AM
  • many thanks for the prompt reply! i have uploaded the dmp onto my skydrive! https://skydrive.live.com/#!/?cid=b339b73e4a711fa8&sc=documents&uc=1&id=B339B73E4A711FA8%21272 i'm unsure of what is wrong! could you help me check? what other details do you need?
    Tuesday, October 18, 2011 10:40 AM
  • There are a couple of reasons which can trigger this error message.  Take a look at these forums:

    ·         http://www.tomshardware.com/forum/239451-45-0xc0000005-access-violation

    ·         http://www.updatexp.com/0xC0000005.html

    The bottom line is that you’ve make sure that you have working hardware and proper device drivers being installed. If you are sure that your hardware is not faulty, you may need to install drivers such as (GPU, sound card, etc.) manually. Bear in mind that this Developer Preview does not include many device drivers natively. That means if you have to install them one by one. Furthermore, Windows 7 drivers may work in most cases but no one can guarantee it. I did install Windows 7 drivers on my PC running Windows “8” Developer Preview.


    Sonic the Hedgehog
    Tuesday, October 18, 2011 1:22 PM
  • jcsonic, thanks for your help! i checked the drivers and have updated them! i'm still missing this "SM bus controller" thing. I'll try find it and install afterwards! should i encounter any problems, i'll reply on this post! thanks alot!


    edit: I've just finished installing every driver using the manufacturer's driver update utility. everything is in place but autocad installation doesn't work! i'll try restoring windows developer preview and see if the problem persists..
    Tuesday, October 18, 2011 3:48 PM
  • I've just done a clean installation of windows 8 dev preview, re-downloaded the drivers, did exactly what you mentioned earlier. however, autocad 2012 is not installing! could you tell me in details what i have to do? I'm feeling like im missing a step somewhere..

    Wednesday, October 19, 2011 10:30 AM
  • Original ‘setup.ini’ will make the AutoCAD 2012 setup process checks if your system meets the system requirement. However, the installer for .Net Framework does not work in Windows “8” Developer Preview. AutoCAD 2012 does require .Net Framework to work properly, in addition to right version of Windows, drivers, hardware, etc. In Windows “8” Developer Preview, the easiest way to install .Net Framework is to “turn on” .Net Framework 3.5 and 4.5, which will require Windows Update. (Turn on or off Windows features) Even if those features have been turned on, AutoCAD 2012 setup process still wouldn’t allow to be proceeded because Windows “8” Developer Preview IS NOT an “officially” supported version. If I’m sure that .Net Framework does exist, bypassing the validation process in AutoCAD 2012 setup will make AutoCAD 2012 not only to be installed but run as well. That’s the whole idea basically.


    Sonic the Hedgehog
    Wednesday, October 19, 2011 4:50 PM
  • I have clean installed windows 8 for the third time now.. drivers are all in place, so I believe it's a hardware problem? I'm going to try install windows 7 then installing autocad 2012. If the problem persists, I believe the problem is from my hardware? anyway thank you for your help!
    Thursday, October 20, 2011 5:57 AM