none
Delay Activity is not working with SharePoint state machine workflow

    Question

  • Hello,

     

    I have a problem with Delay Activity in Sharepoint state machine workflow. This issue is kind of common to many people but so far I haven't come accross any working solution. In one of the workflow states, I want to add a delay activity to send email notification if no action is taken after certain time. Below is what I have done:

     

    In the targeted state:

    1) add one eventDriven activity to handle the normal process (approve the item)

    2) add another eventDriven activity to send the reminder email. In this eventDriven activity, I first add a delayActivity, set it to 2 minutes for test purpose. Then I add a Sharepoint SentEmail activity.

     

    With my test, the Dealy Activity is never invoked after timeout period. What should I do to make the delay activity work in the SharePoint state machine workflow? Is there any work around if the delay activity is simply not working there?

     

    Any suggestions are appreciated.

    Monday, August 13, 2007 8:13 PM

Answers

  • Hi Folks,

     

    I too had the similar problem with Delay Activity. But after installing the hotfix (KB932394) the delay problem got solved for me. But we need to follow some steps while installing the hotfix. Install the hotfix as per below ...

    1. Remove the workflow from Document library.
    2. Deactivate and Uninstall the features from your sharepoint portal.
    3. Install the hotfix.
    4. Reboot the Server.
    5. Install/activate the feature and attach the workflow to the document library.
    6. Delay should work now as expected.

    Hotfix url : http://www.microsoft.com/downloads/details.aspx?FamilyID=6096ce0f-d21e-47ac-afe2-d4e1c2fce670&displaylang=en

     

    Observed that the delay is not responding as per set time... its taking some 5-10 mnts extra time to wakeup.

     

    Try the above steps ... hope it will work now... if you come acorss any issues let me know....

    Wednesday, August 29, 2007 8:37 AM

All replies

  •  

    Jun,

     

    I am having the same problem.  There is a hotfix for this issue here: http://www.microsoft.com/downloads/details.aspx?FamilyID=6096ce0f-d21e-47ac-afe2-d4e1c2fce670&displaylang=en

     

    This hotfix is suppose to fix problems with delay, delayUntil, and delayFor activities

     

    Unfortunately, I installed the hotfix and am still having a problem where the Delay activities do not 'wake' up.  They just sit there past the time when they should be exiting pause mode.  I am using them in a Sequencial Workflow, but also saw this in a State Machine WF.

     

    I will try to install it again.  Also, the hotfix says it is for Windows server 2003 SP1, but I have SP2.  Not sure if this is supposed to be fixed in SP2 or not...

     

    Its worth a shot.

     

    Regards,

    Jonathan K. Herschel

    Tuesday, August 14, 2007 3:35 PM
  •  

    Can anyone verify that this Delay Activities 'not waking up' hotfix is working for them?  The hotfix says it is for Windows 2003 server SP1, but I am running SP2, but I had this problem, so I figured I would install the patch.  I still have this problem.

     

     A simple Yes / No would be appriecated.

    Wednesday, August 15, 2007 1:20 PM
  • The same thing happened to me also. After installing the hotfix, the delay activity is still not working.

     

    Thanks

    Wednesday, August 15, 2007 5:30 PM
  • Same thing for us; SP2 + hotfix still does not work

     

    Wednesday, August 15, 2007 8:34 PM
  •  

    Thanks all for letting me know it wasn't just me.  I am calling MS support today and will let you know the outcome.

     

    Jon

    Thursday, August 16, 2007 12:33 PM
  • I am also having the same problem.Wait activity just does not wake up.I have even tried placing it before createtask activity and noticed that no tasks even gets created.So that means its waiting for ever.

    I also tried installing the hotfix that does not work either.

    Please let me know if you can fix the bug.

     

    Thursday, August 16, 2007 3:11 PM
  • So far, I’ve gotten feedback from 7 other developers (in forums) who are having the same problem where this update (Hotfix) is not working correctly for the Workflow delay activities, specifically Windows Server 2003 SP2 (anybody have problems on different platform?)

     

    So, I called MS support this morning and they transferred me to .NET support team.  Apparently it is a Microsoft .NET Framework 3.0 issue (Artical ID: 932394).  They took down my information and informed me that due to the overwhelming popularity of SharePoint, that it would take 10-20 days until they could get back to me.  OY!

     

    So, I am going to look into other options /checks such as:

    • Uninstalling .net 3.0
    • creating a SP Designer workflow to see if I can something to work until the delay is fixed. (maybe crack it open to see what delay(s) it uses...)
    • Install VS 2005 SP1
    • find an alternative to delay (maybe System.Timer, etc..).
    • One person suggested to make sure your timezone is set on SP and SQL server, but I checked that and all is good.

     

    I will keep everyone updated if I find anything, but until then, we're in a jam.

     

    Regards,

    Jonathan K. Herschel

    Thursday, August 16, 2007 6:38 PM
  • I had a similar problem using a Delay activity as one leg of a ConditionedActivityGroup (CAG).  Installing the hotfix you mentioned earlier did not help.  The only thing that worked for me was to replace the Delay activity with a DelayFor activity.  Delay is WF.   DelayFor is SharePoint.  Perhaps that makes all the difference?  The one drawback of DelayFor (or its sibling DelayUntil) is that they tend to be rather "chatty" in terms of adding two extra entries to your Workflow History each time the delay begins/ends.   I hope you hear soon about a better (less "chatty") solution.

     

    Monday, August 20, 2007 11:01 AM
  • I tried using a DelayFor as well and the delays are waking up properly.  I was previously using DelayUntil.  I don't know why one would work and another wouldn't.  Now I just subtract the todays date from the future date and convert to days and then DelayFor x days...

     

    Jonathan K. Herschel

     

    Tuesday, August 21, 2007 1:08 AM
  • The DelayFor activity cannot work in a state machine workflow since the first child activity in an EventDrivenActivity has to implement IEventActivity. The DelayFor activity is only implementing the SequenceActivity and cannot be placed inside the EventDrivenActivity in state machine workflow. Looks like the only option for me is to use the Delay activity, which is not working. Is there any work around for state machine workflow?

     

    Any suggestion is appreciated.

     

     

    Tuesday, August 21, 2007 1:55 PM
  •  

    I've just tried installing this hotfix and problems with delays in SharePoint workflows remain. I have different issues, that is, workflow wakes up, but delays although set at 5 mins are much longer than that, in fact, they get longer with every rehydration. I have made a test while loop which checks counter and repeats until counter is ten. So far its been almost one day since the last (ninth) time workflow ran.

     

    This same test code does works without problems in regular windows workflow with console app.

    Wednesday, August 22, 2007 9:32 AM
  • Further investigation brought up this.

     

    Besides that hotfix try this one and check if it helps -

    http://support.microsoft.com/kb/932816

     

    It is available per request only.

    Wednesday, August 22, 2007 10:16 AM
  • Has anyone got this other fix working yet?

     

    Thursday, August 23, 2007 11:08 AM
  • me too facing the similar problem. If u get any solution pls share with me.

    Tuesday, August 28, 2007 10:42 AM
  •  

    Hi Folks,

     

    I too had the similar problem with Delay Activity. After installing the hotfix (KB932394) problem got solved. But we need to follow some steps while installing the hotfix. Install the hotfix as per below ...

    1. Remove the workflow from Document library.
    2. Deactivate and Uninstall the features from your sharepoint portal.
    3. Install the hotfix.
    4. Reboot the Server.
    5. Install/activate the feature and attach the workflow to the document library.
    6. Delay should work now as expected.

    Hotfix url : http://www.microsoft.com/downloads/details.aspx?FamilyID=6096ce0f-d21e-47ac-afe2-d4e1c2fce670&displaylang=en

     

    note that the if you set delay time less than 5 mnts it will not work as you expected. It will pause for min 5 mts.

     

    Try the above steps ... hope it will work now... if come acorss any issues let me know.... Smile

    Wednesday, August 29, 2007 6:42 AM
  • Hi Folks,

     

    I too had the similar problem with Delay Activity. But after installing the hotfix (KB932394) the delay problem got solved for me. But we need to follow some steps while installing the hotfix. Install the hotfix as per below ...

    1. Remove the workflow from Document library.
    2. Deactivate and Uninstall the features from your sharepoint portal.
    3. Install the hotfix.
    4. Reboot the Server.
    5. Install/activate the feature and attach the workflow to the document library.
    6. Delay should work now as expected.

    Hotfix url : http://www.microsoft.com/downloads/details.aspx?FamilyID=6096ce0f-d21e-47ac-afe2-d4e1c2fce670&displaylang=en

     

    Observed that the delay is not responding as per set time... its taking some 5-10 mnts extra time to wakeup.

     

    Try the above steps ... hope it will work now... if you come acorss any issues let me know....

    Wednesday, August 29, 2007 8:37 AM
  • Yes, this approach is working!!

     

    Actually, since I already had the hotfix installed, all I did is to deactivate/uninstall the workflow feature from SharePoint and reinstall/activate the feature again. It works for me pretty well without the extra dealy so far.

     

    Thank You,

     

     

    Wednesday, August 29, 2007 2:46 PM
  • I submitted a case to microsoft about a week ago and it was escalated on Monday.  they are working on it now.  I will let you all know if they find anything (whether it is an error in my code or a bug).

     

    Jonathan

    Wednesday, August 29, 2007 2:56 PM
  • OK, I have the additional few minutes delay for my case now.

     

    For those who still don't see the delay activity work, try to put it in a really simple example and do something as simple as log to history or send email with everything hard coded in the property window (no backend function in code).

     

    My first sample application using delay activity is still not working and that one has some onInvoked functions attached to the activities (send email) after the delay activity. I still need to find out what is wrong there.

     

    Thanks,

    Wednesday, August 29, 2007 3:09 PM
  • It is silly that one hotfix that requires special steps and reset does not have that mentioned in the KB, while many others that do not require that always restart.

     

    I too can confirm that this approach helped and workflows are now running with 5, 2 and even 1 minute interval (but require job-workflow property to be set accordingly). I currently have job-workflow set as follows

     

    stsadm -o setproperty -propertyname "job-workflow" -propertyvalue "every 1 minutes between 0 and 59" -url http://localhost

     

    and have so far not noticed any adverse affects on performance.

     

    My workflows pause and resume with 1 minutes intervals if set at one minute but from time to time it is inaccurate and the delay happens to be 2 minutes. Then several times again 1 minute and so on...

     

    hope this helps

     

    I'm glad that community can step together on issues like this, in MS managed newsgroup they just direct you to MSDN if your problem even smells like developer issue.

    Thursday, August 30, 2007 10:44 AM
  • Hi everyone,

    At first thanks for the solution. I have tried and the hotfix is working and the delay activity is restarting .But the situation remained the same for me as I wanted to use delay activity for sending reminder emails . And for that I used delay inside a while - listen combination. In that case the delay activity never seems to wake up . I have set the interval to 6 mins , but it just does not wake up. (or may be the listen activity does not come to know that the delay is active now) So I am at the same situation where i was 3 weeks a go. Do u guys have solved the problem of sending reminders?? If yes please let me know how to do it as thats the backbone of the system.

     

    thanks, 

     

     

    Friday, August 31, 2007 9:38 PM
  • I also have this problem and the hotfix didn't do anything for me. I'm even trying in a simple non-Sharepoint workflow and it's the same. Might work for a while, but after that the workflow just doesn't wake up anymore.

     

    Also, when it does wake up, it does at kind of random intervals like 5sec, 5sec, 1min, 30sec, 3min20sec, 40sec etc

    Monday, September 03, 2007 7:56 AM
  • Hello,

     

    The Delay Activity is not working for me all the time for the development environment where I constantly rebuild/re-deploy the workflow for changes. When it stops working, I have to restart the server and then it will start to work again. For the deployed workflows with no changes, if the delay activity is working, it will continue to work.

     

    For the send email issue, I found it is not related to the delay activity. It is related to the MethodInvoking function of SendEmail activity in state machine workflow. if I hardcode everything in the property window of the SendEmail activity without using the MethodInvoking function in the code, it works fine. Once I use the MethodInvoking function and assign some sendemail property (TO, BODY, etc.) from the backend code, the SendEmail function is not working anymore. I also find the same MethodInvoking problem with LogToHistoryListActivity in state machine workflow.

     

    If anybody has the same experience, please advice on any possible solutions.

     

    Thanks,

    Jun

    Tuesday, September 04, 2007 1:23 PM
  • All,

    Good News.

    I spoke with someone from MS regarding this issue and he sent the below follow-up email to me today.

     

    "I have been able to set up some local tests on my machine to narrow down the problem and have had a talk about this with the product group as well. The issue happens if the Delay is inside a replicator, there are many delays running in parallel, or if DelayFor is the last activity in a workflow, using just a delay activity in a workflow works fine.

     

    The product group is aware of these issues and is looking into all these scenarios. As of right now I [do] not have any time lines for a fix or an update, it could take a while to have a public fix available. I am the owner of this bug [and] will keep monitoring this issue and watch for updates..."

     

    If you can tweak your setup so that it doesn't fall in to the above scenarios, it may work, otherwise, I ended up using a regular Delay Activity which has the following settings: TimeoutDuration which is in the format of DD:HH:MM:CC (The CC is seconds b/c the SS caused a smiley Tongue Tied).  So, the following would be 50 days, 40 hours, 30 minutes and 00 seconds: 50.40:30:00.

     

    Instead of using the DelayUntil, try using a regular delay.  I took the DATETIME of today and subtracted it from DATETIME of 'your date' and converted it into Days,Hours,Minutes, & Seconds.

     

    Example:

    DateTime dtReminder1 = Convert.ToDateTime(workflowProperties.Item["Reminder 1 Date"]); // gets datetime from a field named 'Reminder 1 Date'
    TimeSpan tsDiff = dtReminder1.Subtract(dtToday); // subtract today from 'Reminder 1 Date'
    Double dblDays = tsDiff.Days; // get days
    Double dbltemp = tsDiff.Hours; // store total hours into temp variable
    Double dblHours = dbltemp % 24; // extract days (24 hours/day) from tsDiff, so you are left with just the hours

    Double dbltemp2 = tsDiff.Minutes; // store total minutes into temp2 variable

    Double dblMinutes = dbtemp2 % 60 // extract minutes (60 mins/hour) from tsDiff, so you are left with just the minutes

     

    You are left with the following:

    dblDays = # days, dlbHours = # hours, dlbMinutes = # of minutes.

     

    Instead of using the DelayFor, try using the regular delay.  This is allready set to use Hours Minutes and SEconds, so instead of using three settings (days, hours, minutes), convert into one string 00.00:00:00.

     

    Hope this helps!

    Jonathan K. Herschel

     

     

    Friday, September 07, 2007 7:34 PM
  •  

    Well, I was using a regular Delay activity all along and still have problems. I also have a case open with MS support, I'll let you know how it goes.
    Monday, September 10, 2007 12:26 PM
  •  

    Any further word on this issue? The pause hotfix works perfectly on our test environment, but when I attempt to enable it on production the paused workflows don't wake up. As far as I know the two environments are configured the same, and the steps I used to install the hotfix was the same on both servers.

     I really need to figure this out ASAP, so any sort of help would be greatly appreciated.  

     

    Thanks,

    Andrew

    Monday, September 24, 2007 3:29 PM
  • Hi folks

     

    I am facing the same Problem with the Sharepoint Designer. Workflows do not wake up after "delay" ist over. I was looking in several Blogs, Sites and Forums. Unfortunately I did not get any usefull help until today. The MS Patch thing does not seam to work, and MS is not giving much of help.

     

    What I heard was that there were Cases opened at MS, but without any good response.

     

    I will let you know if I get any news, and I'll stay tuned here if anyone knows more about this.

     

    Kind regards

    Sam

     

    Sunday, October 07, 2007 8:56 AM
  • Hi guys

     

    I had exactly the same issue as Sam, I have reported this to Microsoft and had a case open for about a month.  The end result for myself was that Microsoft had realised there is a bug in the Windows Workflow Foundation and it may be fixed in a server pack for WWF.

     

    Fairly useless really.

     

    David

     

    Monday, October 08, 2007 7:52 AM
  • Hi guys,

    I tried applying the hotfix. Its messages seem to imply everything just went fine. However, checking the assemblies in the GAC reveals that there are still the 3.0.0.0 versions installed, not the newer versions. Can anyone shed some light on that?

    Yours, Björn
    Wednesday, October 24, 2007 9:35 AM
  • I created a workflow with Sharepoint Designer which invokes a "Collect Data from User Activity."  This seems to work most of the time but since this "Collect Data from User" pauses until the task is completed, there are some problems retrieving the task values that were collected under this custom activity.

     

    After reading this thread, I believe that the Windows Wofkflow Foundation timer error is affecting workflows created in both Sharepoint Designer and VS 2005.

     

    Is this possible?

     

     

     

    Wednesday, October 24, 2007 1:22 PM
  • Just checking in...

    Still no word from MS with a fix.  I was told that since I have a case in, that I would be the first to get a 'fix', so I will let everyone know when I get that.

     

    As of now, I deployed a WF using the regular Delays, it passed on my one VM enviornment, but it hasn't been tested in prod yet.

     

    Jon

     

    Thursday, November 01, 2007 1:03 PM
  •  

    Does anybody know anything about this hotfix, which supposedly replaces hotfix 932394?  It's mentioned on this page, but you can't download it here - have to call MS support for it.  Has anybody tried it? 

     

    http://support.microsoft.com/kb/932816

    Tuesday, November 13, 2007 5:32 AM
  • Hello everyone,

    So there must be a few people that have delays successfully working. What environment are they properly functional in? Did you use the "non-public" hotfix available through Microsoft? I'm running Windows Server 2003 SP2 and cannot get them running for the life of me. I've tried the public hotfix and that didn't do anything. I'm convinced that I'm going to have to wait for another hotfix to solve this issue.

    This is getting pretty ridiculous that such a core activity isn't even working properly on all platforms. Delays are even more critical in a state machine workflow. How else are you supposed to listen and wait for a timer to finish before transitioning to the next state? Would a custom activity even be feasible? I haven't looked much into it...but why should I even have to write a custom activity to do what was supposed to work for me in the first place? Don't get me wrong...I think workflows are really cool and can do some amazing things...but there comes a point when you throw up your hands and ask "What were they thinking?!?".
    Tuesday, November 20, 2007 9:48 PM
  • Amen.

     

    Yes, I had Microsoft send me the "non-public" hotfix.  Didn't make a difference.  I had a follow-up call later that day from one of the Microsoft support guys asking me if it had fixed the issue.  I told him it hadn't and he said they'd look into it.  That was a week ago today and I haven't heard anything back yet.

     

    Out of curiosity, does everybody else having this problem also get a System.NullReferenceException coming from the OWSTIMER.EXE process showing up in the ULS log in Central Administration at around about the time you'd expect the workflow to be waking up after the delay?

     

    Tuesday, November 20, 2007 10:14 PM
  • Tuesday, December 04, 2007 8:57 AM
  • And it works Smile

    Tuesday, December 04, 2007 10:11 AM
  • After the update, what are the versions of System.workflow.activities, System.workflow.componentmodel and System.workflow.runtime? kb93239 suggests they would be something like 3.0.4203.X or higher, however, after the update those dlls are still stuck at 3.0.0.0 in the GAC here ...
    Tuesday, December 04, 2007 10:50 AM
  •  

    look at the product version : 3.0.4203.201 for me
    Tuesday, December 04, 2007 11:39 AM
  • It's STILL not working (yes, my DLLs in the GAC are of version 3.0.4203.201). Whenever a DelayUntil activity is processed, the workflow is frozen forever and never wakes up again.

    I can't believe Microsoft has now released 3 fixes for this problem but none of them worked.

    If you think it works, try to install/uninstall your workflow feature multiple times. After doing so, it stopped working for me.
    Tuesday, December 04, 2007 4:45 PM
  • I've installed this hotfix and it hasn't made a difference for me, either.  Still not working.  And still getting the following error in the Unified Logging Service log at about the time it would have been attempting to re-start the workflow.

     

    Timestamp Process TID Area Category EventID Level Message Correlation
    12/05/2007 09:55:57.17 OWSTIMER.EXE (0x07D4) 0x0848 Windows SharePoint Services Workflow Infrastructure 98d8 Unexpected System.NullReferenceException: Object reference not set to an instance of an object. at Microsoft.SharePoint.Workflow.SPWorkflowManager.RunWorkflowElev(SPWorkflow originalWorkflow, SPWorkflow workflow, Collection`1 events, SPRunWorkflowOptions runOptions)

     

    Does anybody else get a similar entry in their ULS log ("Workflow" category)?  Anybody *NOT* getting a similar error in their log?

     

    Tuesday, December 04, 2007 11:30 PM

  • Hey,

    where can I find the alternative to the delay activity: the DELAYFOR-activity?

    I can't find it within my visual studio toobox as well as not within the system.workflow.activities namespace.

    Any ideas?
    Thursday, December 06, 2007 3:41 PM
  • I haven't seen any errors like that in my ULS logs.

     

    On another note, I installed the new version of the hotfix KB932394 and it works...but inconsistently. No better than KB932816. Back to square one Sad

     

    I have a ticket open and have been directed to the dev team so I'm *hoping* to get some answers soon. However, at the rate they've been moving I think we'll be lucky to see a solution before the new year.

     

    -Adam

    Friday, December 07, 2007 7:36 PM
  • Are people experiencing this problem running their sharepoint installations on virtual servers or physical?  I can't imagine why it would make a difference, but we have our prototype sharepoint installation running on a virtual server.  I'm considering trying to get hold of a physical server and installing it on there just to test it, but if people are also experiencing the issue on physical servers then it might not be worth the headaches I'll have to go through to get the hardware...
    Monday, December 10, 2007 10:37 PM
  • Hey, I've got a potential fix here! There might be an issue with having the job-workflow property set to 1 minute. I gave my Microsoft support engineer my test program and he claimed he could not replicate the issue with the job-workflow property set to 5 minutes. He switched it to 1 minute like what is on my machine and he could then replicate the issue. It seems bizarre, but I set my job-workflow back to 5 minutes and so far it has been working consistently for multiple instances my test workflow for a few hours now. When set to 1 minute I couldn't get it to last longer then an hour. I have to test some more things and try different scenarios...but if anyone else who has been having problems out there can try the same thing and come back with their results it would be much appreciated. Here's a brief overview of the steps I have taken:

    1. Install the most recent copy of KB932394.
    2. Restart your server (don't know if this is needed but it won't hurt).
    3. Set the job-workflow property to 5 minutes. So you don't have to go digging for the command here it is:

    stsadm -o setproperty -pn job-workflow -pv "every 5 minutes between 0 and 59" -url http://yourserver

    4. Start and instance of a workflow with a delay in it. My example is a state machine workflow that continuously transitions back to the same state and waits for a 1 minute delay to trigger. It triggers every 5 minutes due to the job-workflow being set to 5 minutes.

    Personally I'm not 100% convinced by this solution. It seems clunky that I would have to set the job-workflow to 5 minutes, but I'd like to hear everyone's response if it ends up working for them. I'll keep everyone posted as I keep testing.

    Monday, December 17, 2007 8:02 PM
  • After billion of hour of test, I (developer team) and my colleague (system team) find this solution.

    First of all install the most recent patch KB932394

    1) If you recompile same workflow, you MUST change version of dll (Assembly.cs && workflow.xml) and install to the GAC WITH the old one.
    2) Don't remove workflow; if there are instance pending, you must complete the workflow. In producion don't remove anywere.
    2) If you have the delay activity stalled, you can simply restarting timer services.

    I hope this tips can help.


    Massimo
    Tuesday, December 18, 2007 9:36 AM
  • "Hey, I've got a potential fix here! There might be an issue with having the job-workflow property set to 1 minute. I gave my Microsoft support engineer my test program and he claimed he could not replicate the issue with the job-workflow property set to 5 minutes."

    Our job-workflow property is set to 5 minutes, which seems to be the default for SharePoint Server 2007 (we didn't change that intentionally, at least). However, the workflow timer still doesn't work.

    Appearently, the bug becomes prevalent if you exchange the workflow DLL, meaning that each time you replace the DLL containing the compiled workflow class in the GAC with a new one using gacutil, there is a risk that the workflow timers stop functioning.

    To revive the workflow timer, I found out that the following steps seem to do the trick:

    1. Stop all running instances of your workflow.
    2. Remove your workflow from every list it is attached to.
    3. Deactivate the feature which defines and provides your workflow.
    4. Run iisreset.exe.
    5. Install Microsoft's KB932394 patch (again).
    6. Restart the server.
    7. Reactivate the feature.
    8. Reattach the workflow.
    9. Run your workflow instances.

    I am not sure if all of the above is mandatory, however, restarting the server (not just IIS) seems to be so.

    As a side note, I was unable to find any proper documentation about command-line properties. The only piece of information I found is this:

    http://www.microsoft.com/resources/documentation/wss/2/all/adminguide/en-us/stsf01.mspx?mfr=true

    It's particularly funny that this page states: "
    For more information about setting properties, see "Introducing the Administration Tools for Windows SharePoint Services" in the Windows SharePoint Services Administrator's Guide", since the SharePoint Services Administrator's Guide does not contain any more information about the properties than this very page.

    So far, we are unable to employ workflows on a productive system due to the timer bug, which we intended to do as soon as the middle of January. Our customers would go mad if we told them that a workflow might or might not wake up (implying that our product might or might not work as expected), depending on some dubious condition even the folks at Microsoft don't seem to understand.

    MOSS is a really nice and powerful platform, but MS should get their priorities straight.
    Tuesday, December 18, 2007 1:24 PM
  •  Massimo G. wrote:

    First of all install the most recent patch KB932394
    If you recompile same workflow, you MUST change version of dll (Assembly.cs && workflow.xml)


    Thanks! Actually, this DID solve the problem. More precisely, in order to change to version number, look at the following places:
    - Assembly.cs
    - feature.xml
    - XML definition file of your workflow, e.g. workflow.xml
    - If your library contains any code-beside-classes for .aspx webpages in addition to the workflow, you have to update the version number in the reference tag of the aspx file as well (otherwise you will get the error message "file not found" when trying to render the aspx page, which can be confusing)

    I still believe this is pretty awkward though, since altering the version number each time I need to test slight changes I made to the code seems quite inconvenient to me.

    Let's hope Microsoft releases a fix to address that bug. Until then, we'll have to stick to changing version numbers.
    Tuesday, December 18, 2007 3:28 PM
  • I guess the downside here is that this workaround would probably only work for workflows created in Visual Studio, wouldn't it?  We're using a 3rd party workflow tool (Nintex) which basically acts as an interface over the top of the underlying Workflow Foundation stuff.  So we create our workflows using a drag and drop GUI within the web browser, meaning I don't have any .cs or xml files in which I can change the version number.

     

    Tuesday, December 18, 2007 11:00 PM
  • i have tryed all hotfixes and have installed sharepoint sp1

    and it still is not working on one of my virtual box (this one has only wss not moss on it).

     

    My timer was set to every 1 minute. I set to every 5 but it did not change anything.

     

    Any ideas?

     

    Desesperated.

    Saturday, January 05, 2008 12:23 AM
  • So my previous idea of setting job-workflow to 5 minutes only kinda worked, as did the suggestions afterward. However, I have been successful in getting this issue escalated to the product group. They are now publically announcing that there is a problem and are looking for input from everyone in order to put out a successful hotfix that will cover ALL cases. Everyone please take the time to read this blog:

    http://blogs.msdn.com/sharepoint/archive/2008/01/04/issues-with-the-delay-activity-in-sharepoint-workflows-we-need-your-help.aspx

    ...and add your comments. The more people that add their input the better chance that we have of getting an "all-encompassing" hotfix.
    Friday, January 11, 2008 2:08 PM
  •  

    I'd like to note one thing about this topic. Really, after applying hotfix NetFX30-KB932394-X86.exe the situation has changed to the better. But my joy was too early. During debugging when I came across some error in my workflow the process was terminated. Indeed, it’s normal. But! After that delay action didn’t want to work. A tried restart timer service but it didn’t help. What a nuisance! And I had to reboot my developer server and it worked. May be it’s just a case, I don’t know… So, some strange behavior it’s just in present concerning delay action…

    Monday, January 14, 2008 7:29 AM
  • Hi friends,

         

    I did the steps bellow based on adreas' post and It worked for me:

    1. Stop all running instances of your workflow.
    2. Remove your workflow from every list it is attached to.
    3. Deactivate the feature which defines and provides your workflow.
    4. Execute script (this is from a MS sample):

    @ECHO ON
    :: Stop IIS Admin Service
    net stop IISAdmin /y

    :: Above should also stop the following
    :: HTTPFilter
    :: Pop3Svc
    :: SMTPSvc
    :: W3svc

    :: Now Stop Sharepoint's Timer Service
    net stop SPTimerV3 /y

    :: Now restart things in reverse sequence from how we turned them off
    net start SPTimerV3

    net start W3SVC

    net start Pop3Svc

    net start SMTPSVC

    :: now start the parent of the above services
    net start IISAdmin

    :: Pause
    5. Install Microsoft's KB932394 patch (again).
    6. Redeploy the feature with Visual Studio (Install.bat).
    7. Reattach the workflow.
    8. Run your workflow instances.

     

    thanks,

     

    Renato Guimaraes

     

     

    Wednesday, January 16, 2008 12:43 PM
  • Hi Renato,

    do you think the actions you wrote above are necessary to produce every time you need to upload your project to the server? However I will do that in order to have my workflow working… Any way I’ll try…

    Wednesday, January 16, 2008 1:25 PM
  • Hi Aleksey,

     

           Before I did those actions and before I've installed the KB, my worklfow was taking 10 min more to start. For example, I set a delayactivity to 00:05.. So It took 15 min... Whe I intalled the KB It stopped to work and didn't wake up etc.

           After I did those steps my workflows are working ok. FOr example, sharepoin't property job-workflow is configured to 1 min. If I configure delay's the timeoutduration to 2min.. It takes 3 min.

         

           During my tests I didn't have to did those steps every time. I did more tests... For example, I added an activity to my workfow and I have to deactivate and activate a feature again. :-(((((((((

     

    thanks,


    Renato.

    Wednesday, January 16, 2008 4:18 PM
  •  bmichaelsen wrote:
    After the update, what are the versions of System.workflow.activities, System.workflow.componentmodel and System.workflow.runtime? kb93239 suggests they would be something like 3.0.4203.X or higher, however, after the update those dlls are still stuck at 3.0.0.0 in the GAC here ...
    I am having this same problem with the fix. Is there a way to get past this?
    Wednesday, February 06, 2008 9:50 PM
  •  

    Hi,

    It's obviously a misunderstanding. Really, having applied kb93239 you may have a look into the GAC to find the System.workflow.runtime assembly. If you look its properties on the tab "General" you'll find out that its version is 3.0.0.0. It seems that version hasn't been changed. But if you go to the other tab of properties window, to the tab "Version", you'll find out that the version of the source file has changed to the value "3.0.4203.201". You'll take the same result if you find the source file of the assembly and take a look to its properties.

    Hope it'll help.

     

    Thursday, February 07, 2008 5:23 AM
  •  

    Hi,

    It's obviously a misunderstanding. Really, having applied kb93239 you may have a look into the GAC to find the System.workflow.runtime assembly. If you look its properties on the tab "General" you'll find out that its version is 3.0.0.0. It seems that version hasn't been changed. But if you go to the other tab of properties window, to the tab "Version", you'll find out that the version of the source file has changed to the value "3.0.4203.201". You'll take the same result if you find the source file of the assembly and take a look to its properties.

    Hope it'll help.

    [\quote]Thanks. I do have the proper version, but new delay actions are still not firing. I have taken out the workflows, installed the fix, restarted the server, built a simple delay test and it doesn't fire.

     

    Any help is much appreciated.

    Thursday, February 07, 2008 3:39 PM
  • I agree delay is a bit mistery control in its behaviour... I suggest to look at the posts above. And also in case of using MOSS 2007 you can run following SQL-query in order to find out whether the delay control has been initialized properly and workflow is now in state of waiting. The query is applied to the table WSS_Content:

     

    select workflow.Id, Modified, Status1, scheduledworkitems.DeliveryDate from workflow inner join scheduledworkitems on scheduledworkitems.Id = workflow.Id

     

    And if you have at list one delayed task then you'll see returned record(-s). One can see the time when the executing will be resumed - it's the field DeliveryDate. If there is no any records at all - so there will be no any executing further.

    Unfortunately, I can't say where it can be shown in case of not using MOSS...

    Friday, February 08, 2008 5:46 AM
  • After not being able to get the hotfix to work, I tried updating the .NET 3.0 framework. After the update and a reboot, the assembly version is now 3.0.4203.835. So apparently the update overwrote the assembly updated by the hotfix. OK, I'm game. So I built a fresh workflow and it did not fire. Alright, I can handle this. So I tried to reinstall the patch. Upon doing so, I was given the error:

    The upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. Verify that the program to be upgraded exists on your computer and that you have the correct upgrade patch.
    Lovely. So I uninstall .NET 3.0 SP1 from the Add/Remove Programs and reboot, hoping that it will allow me to install the hotfix that I know doesn't work... Being so frustrated, I didn't realize that I was taking out the whole .NET 3.0 framework, not just the recent upgrade. Nice. Reinstalled the .NET 3.0 Framework. Reinstalled the hotfix. Verified the assemblies were changed. Restarted the server. So here is where I stand:

     

    Server 2003 SP2

    MOSS 2007 SP1

    Fix 932394

     

    I created a brand new workflow in SP Designer 2007 called DelayTest that notifies that the workflow fired, pauses for 5 minutes and then sends me another email. I decided to look into the Workflow database to verify that the workflow was registering there. I hit it with this:

     

    select workflow.TemplateId, workflow.Id, Modified, Status1, scheduledworkitems.DeliveryDate

    from workflow inner join scheduledworkitems on scheduledworkitems.Id =

    workflow.Id

    ORDER BY Modified DESC

     

    Here I can see my workflow is registering to fire five minutes after it was created:

    9DBEBF97-D63A-40C8-9584-3AF1EEE2596E | 19111829-6CCC-491E-BEFB-E7784B473A96 | 2008-02-08 17:00:47.000 | 2 | 2008-02-08 17:05:46.360

     

    However, this never happens and the time has exceeded 30 minutes.

     

    Does anyone know the status codes returned here (2 in this case)? I'm pretty sick of this problem and need to move on.

    Friday, February 08, 2008 5:25 PM
  • Well, then try the recipe suggested by Renato Guimaraes above, for myself I created a pity cmd-file:

    net stop iisadmin /y
    net stop w3svc /y
    net stop sptimerv3 /y
    net start sptimerv3
    net start w3svc
    net start iisadmin
    NetFx30-KB932394-X86.exe

     

    Notice that hotfix is situated in the same folder where the cmd-file is, of course Smile

    This file I execute having deinstalled my previous assembly.

    But even in my case that is not the solution every time. Time by time my workflow begins to work absurdly and I don't know why. So in that case I have to reboot my server in order to reset cache and other things used by MOSS. It helps.

    AND I forgot to say! I don't use SP Designer, I do my work in VS2005! And because of that I can tune my workflow in more detail. Though it MUST work in both case...

    And another notice... Pay attention on your windows updates... I've got an server (Windows 2003) which has a lot of updates and hotfixes installed on. And having tried to install my workflow on it I faced the fact that workflow is working extremally unrelible. The replicator-control in parallel mode sometimes works as usual and generates good tasks but another time it creates tasks which hang and refused to fire after delay. And in sql they are shown, the time passes by but nothing happens. Very weird.... Most likely some update is the cause of it. And I solved the problem just reinstalled windows... So I can't suggest anything else except to reinstall windows as an extreme means. Sad
    Monday, February 11, 2008 5:38 AM
  • Hi everyone,

    there is another nuance to solve the problem with delay activity...

    Please try following:

    Check your period of "job-workflow" property by using followin command: stsadm -o getproperty -propertyname "job-workflow" -url http://localhost

    If you see something like "property exist=no" so you need to execute command: stsadm -o setproperty -propertyname "job-workflow" -propertyvalue "every 5 minutes between 0 and 59" -url http://localhost

    Please pay attention on parameter "5 minutes"!!! Sometimes workflow refuses to work if this parameter has been set to value less then 5...

     

    And after that perform following sequence:

    1. De-associated all workflows from libraries
    2. Uninstall your features
    3. install the patch NetFX30-KB932394-X86.exe
    4. reboot the server
    5. re-install features
    6. re-associate the workflows

    It's very important to perform all the operations described above in exact order they were written. It helped me in case as it seemed to be absolutely hopeless...

    Hope it help.
    Tuesday, February 12, 2008 1:20 PM
  • hi how can i install that Windows6.0-KB932394-x86.msu to my system plz tell me

     

    Thursday, March 13, 2008 1:33 PM
  • I'm having the same problem with the Delay Activity not working. The activity after the delay/pause never gets triggered.

     

    On my development server, I have .NET Framework 3.0 with KB932816 installed and the delay works properly.

    On my production server, I have installed .NET Framework 3.0 SP1 which is supposed to include the KB932816 fix in it but it doesn't work!!

     

    What's the story?? We can't install .NET Framework 3.0 SP1? Anyone else facing this issue? Any luck with getting it resolved?

     

    .NET Framework 3.0 SP1

    http://support.microsoft.com/kb/945826

     

     

     

    Monday, April 07, 2008 4:25 AM
  • Hello aifong,

    Take a look at version of your workflow’s dll in GAC. Having applied SP1 for .Net 3.0 it must be 3.0.4203.835. If it is not so – try to reinstall SP1. Also, make sure you previously uninstalled the hot-fix KB932816. And one more remark. SharePoint 3 and MOSS 2007 suffer with leak of memory sometimes. In my case it caused unstable working just using delay activity. Probably it is because I’ve got not much RAM, only 2 GB. You can take a look into your log-files of sharepoint server and search a phrase like following – “Potentially excessive number of SPRequest objects …currently unreleased on thread ...  Ensure that this object or its parent (such as an SPWeb or SPSite) is being properly disposed”. It means that you’ve got leak of memory. And you should make sure that you dispose SPWeb and SPSite after they have been used. In case you get such records but do not use SPWeb or SPSite it is the bug in SharePoint 3 navigation, there it has words concerning navigation and menu (This relates to MOSS 2007 also). This bug fixes hot-fix KB-932621 (send by Microsoft on demand) in case of SharePoint 3. In case of using MOSS 2007 I couldn’t find any solution…

    Hope it help

     

    Monday, April 07, 2008 5:24 AM
  •  

    Hi Aleksey

     

    Thanks for your reply.

     

    The version on the server that has SP1 is indeed 3.0.4203.835. I have not previously installed the hot-fix on that server before. It's a fresh install with SP1 applied to it. I am also not using a custom workflow. I'm just using Sharepoint Designer to make it pause until a certain time and then just execute the activity "Log to History Log" which is simple enough.

     

    Hmm I don't think I have a problem with lack of memory either. The server has 8GB of Total Memory and 4GB of Available Memory yet the delay problem still occurs.

     

    Any other hints? Otherwise I'm going to uninstall SP1 and reapply the hot fix to see if that works.

     

    Thanks

    Monday, April 07, 2008 5:59 AM
  • aifong,

    Some more tips… As you probably know the service responsible for delay activity is SharePoint Service Timer. The period of rising events should be no less than 5 minutes, it is set by default. Try to check it up by command stsadm -o getproperty -propertyname "job-workflow" -url http://localhost. Look whether this service is working in services window.

    Also in my case some strange delays happen during making parallel tasks in replicator activity. In other words, the parallel tasks in replicator should be created simultaneously, but sometimes one or two are created and others not and seem go to ‘sleep’, but after about 20 minutes process arises and the rest of the tasks is created. Not always, but sometimes. Strange thing… Of course, there are a lot of processes inside workflow and anything can happen. It does not matter very much in my case for process of creating new tasks take place at night. May be try to wait for rising in about half an hour? Unfortunately,  I made my workflow in VS 2008, not in Sharepoint Designer...

    Try to examine your SQL-server state of workflow by command:

     

    select workflow.Id, Modified, Status1, scheduledworkitems.DeliveryDate

    from workflow inner join scheduledworkitems on scheduledworkitems.Id =

    workflow.Id

    for BD WSS_Content. After delay activity had been executed and task-rising was scheduled the SQL-query must return at least one record.

    Also, some people say that version of OS must be not less than Server 2003 SP2!

    Perhaps, that is all I can suggest. If nothing helps, your case is rather strange… In most cases SP1 for Net 3.0 solved the problem. Try to come back to hot-fix 932621, there is nothing to be done…

     

    Monday, April 07, 2008 6:50 AM
  • Dear, Aleksey Kozlov

     

    I am having a problem in delay activity. it just wont continue my workflow.

    I am trying to follow your guidance in the previous post.

    how can i check the version of my workflow?

    is it by getting the file in my %windows%/assembly

    and then right-click - properties?

    then find in the version tab?

     

    do you know why when i try to install KB932394

    it says

    "

    The upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. Verify that the program to be upgraded exists on your computer and that you have the correct upgrade patch.

     

    "

     

    I am using Windows 2003 Sp2, DotNet Framework 3.0 Sp1

     

    thanks in advance.

     

    Tuesday, April 08, 2008 2:31 AM
  •  

    DotNet Framework 3.0 Sp1 already installed the hotfix KB932394.

     

    Yestoday I executed "net stop sptimerv3 /y net start sptimerv3"  my workflow worked fine,but today it can't wake up again

    Tuesday, April 08, 2008 2:44 AM
  • Hello on3Cool,

    TomGang is right, SP1 for Net 3.0 already contains KB932394 and there is no sense to install the same hotfix over existing one. As I've already said the suggestion is trying to uninstall all the hotfixes and after that installing SP1 for Net 3.0. Then check up the version of System.Workflow.* dlls in the GAC. You are right, you can see it on the version tab or (in order to be assured) by using very helpful utility Lutz Roeder's Net Reflector. As far as I know the last version of that utility is 5.0.50. By using that you can look inside Net assemblies and find out not only the exact version but to decomplile them in very correct way. This ulility helped me greatly when I had to create my own page WrkStat.aspx and for that page the most of code was compiled inside dll called Microsoft.SharePoint.ApplicationPages. This utility is free, try to find it in Internet.

    And do not forget to reboot the system after all these manipulations....

    Hope it helps...
    Tuesday, April 08, 2008 4:51 AM
  •  

    Are you sure?

    i checked on

    "http://support.microsoft.com/kb/945826" i cant find kb932394.

     

    Cheers,

     

    Tuesday, April 08, 2008 4:51 AM
  • I read that on some forums... Also, at the bottom of the page devoted to kb932394 (http://support.microsoft.com/default.aspx?scid=kb;en-us;932394) there is a link to the page http://support.microsoft.com/kb/932816/ which is mentioned in SP1 for Net 3.0. It is said that kb932394 resolves the issue described in KB932816. KB932816 by itself describes some common issues and the first one is "Issue 1 - When a workflow unloads after persistence occurs, the timers may not resume". That is the our case when workflow seems to go to 'sleep'.

    So I think that SP1 for Net 3.0 should resolve the problem with delay activity...
    Tuesday, April 08, 2008 5:21 AM
  • Okey, Thanks guys ...

     

    After all, i still can't find any solution on my workflow.

    i suspect that, i might have a hardware problem in a timing 'things' on my server.

     

    what i would do, i'll try to create a temp site collection on my production server, and try my workflow there.

    because my problem is sometime the workflow runs properly but most of the time it doest run as i expected.

     

    Thank you very much once again.

     

    On3

     

    Tuesday, April 08, 2008 6:57 AM
  •  

    It's a already known bug.

    But Microsoft can't fix it until now.

    Somebody said he had fixed this issue,but I think just sometimes it works fine like me.

    DelayActivity is a so important activity in worlflow,but this issue already exists more than 1 year.

     

    Tuesday, April 08, 2008 7:05 AM
  • The behaviour seems to be inconsistent. Yesterday the delay workflow didn't work. Last evening, the server was rebooted. This morning, I tried the same workflow again and surprisingly the workflow went through. However, when I tried to run it the 2nd time, without changing anything, it got stuck in "In Progress" again. Not quite sure what to make of this.

    Wednesday, April 09, 2008 4:08 AM
  • Hi aifong,

    just one notice - may be the matter is that the process after delay can be risen again not EXACTLY at the time the delay activity had been set. It can occur AFTER that time during the period by wich the job-workflow service was initialized. As default it is 5 minutes. So, for instance, if you set the time of delay activity triggered at 5:00 PM than the event can occur not at once at 5:00 PM but during the period from 5:00 PM and 5:05 PM.

    Do not forget it!

    Earlier I spent a lot of time in vain trying to find the reason of not working delay instead of just waiting for some minutes.

    Wednesday, April 09, 2008 4:54 AM
  •  

    Hi,Aleksey Kozlov

    delay in your workflow always work fine?

     

    Wednesday, April 09, 2008 5:12 AM
  • Hello TomGang,

    in common I am content with delay activity... Earlier, without hotfix or sp1 it refused to work at all. After sp1 the situation improved. But nonetheless as I mentioned before there are some strange 'hanging' in creating new tasks by replicator activity when it works in parallel mode. Some tasks are made at once but others only after about 20 minutes... But that is not mortal for it is done at night when nobody works. I could find it out by taking look at the time of creating these tasks in BD, table AllUserData. Except that there is no any troubles...

    At the moment I've got well tested custom workflow ready for working. But anyway I treat workflow with some suspicion for I'm not quite sure in its reliability. Moreover, there are a lot of problems of another kind which are not resolved yet. First of all is the controlling of workflow's version. You cannot modify your workflow without removing all the tasks which had been made before. May be I'm wrong. Also the SP's performance is another trouble. Debugging after delay when control over processing workflow is given to another thread and you cannot watching and influencing the situation. And so on...

    So until I find out the way to solve all these problems I will not dare to put my workflow in operation state.

     

    Wednesday, April 09, 2008 6:04 AM
  • Hi Aleksey,

     

    Sadly, once, I had the workflow timed to run on a Friday night and come Monday, it was still waiting. Sad

     

    Normally when I do my testing, I would set it to Pause until a date in the past, so it logs that it waits for 0 seconds then it should run the next line after that. This is so I don't have to spend too much time waiting to troubleshoot the issue.

     

    aifong

     

     

     

    Wednesday, April 09, 2008 6:12 AM
  •  

    yes,we are facing the same problem.my workflow in wss3.0 seems not steady.Sometimes delay works fine,but sometimes it doesn't work.

     "delay"  is the only problem in my workflow,  I also will not dare to put my workflow in operation state.

    What did MS do in the passt.

    Wednesday, April 09, 2008 6:13 AM
  • it is maybe because of the workload on the server, since the delay activity works based on a thread.

    The more services working in the background, the longer delay activity will "wake up".

     

    i dont know, it just maybe Smile i am still searching on "why" it is inconsistent.

     

    on3

     

    Thursday, April 10, 2008 5:58 AM
  • If it is so (I mean delay's behaviour depends on system's threads) - it's complete nonsense, ... I wonder - the delay activity is the main point in building workflow and its working in such way forces the whole system to work unreliable.

    May be developers in MS will read this topic and react in some way...
    Thursday, April 10, 2008 7:30 AM
  •  

    Just thought I'd share how I finally tackled the issue.

     

    Basically my conclusion was that I couldn't rely on Sharepoint's workflow pause/delay action since the behaviour didn't seem to be consistent in my environment. So what I ended up doing was to create a SPJobDefinition that polls every 5 minutes and that would resume the workflow at the time that I needed it to. Seems to be more reliable now This blog article was helpful in creating a timer job.

     

    http://www.andrewconnell.com/blog/articles/CreatingCustomSharePointTimerJobs.aspx

     

    Hope that helps whoever else who is facing this issue.

     

     

    Monday, April 14, 2008 6:11 AM
  • I have removed all but one delay which happens at the end of my workflow and deployed it onto a new WIN2K SP2 server with MOSS and .Net 3.0 SP1.  I ran it once with no problem.  I made some updates to the code to take out some debugging code, recompiled with a new version, deployed to the GAC, stopped and started IIS and SPTimerv3. 

     

    I ran through a test which went beautifully.  That was last night.  This morning I tested again and now there are random 15 minute delays throughout the workflow. 

     

    Looks like I may need to try aifong's approach because I need to get this out into production.  Due to this, we're thinking about dropping SharePoint all together. 

    Wednesday, April 16, 2008 3:39 PM
  • I'm still hitting this issue.  I'll attempt the above solutions and see what happens.

     

    Tuesday, June 10, 2008 1:11 PM
  • I opened a case with Microsoft regarding this issue and here is the synopsis:

     

    This is a known bug which Microsoft is working on.  The hotfix is in development and there is no ETA on it as of 6/19/08.  The bug pertains to the SharePoint timer service and affects the workflow delay activity (pause until in SPD).  The issue occurs even with WWF SP1.

    Friday, June 20, 2008 1:10 PM
  • Wednesday, June 25, 2008 11:13 PM
  • All,
    I've been out of the SharePoint 'realm' for some time now, but am getting back in now.  I haven't fully investigated, but it appears there may be a fix in
    Microsoft Windows SharePoint Services 3.0 SP1?

    Issues that are fixed in Windows SharePoint Services 3.0 by the Windows SharePoint Services 3.0 Infrastructure Update ( http://support.microsoft.com/kb/953749/)

    Again, I haven't had a chance to fully look into it, but though it would be best to post this now as it could be weeks before I get a chance to look into it.

    Jonathan K. Herschel

    More information:
    A workflow does not resume automatically when a delay activity is triggered in Windows SharePoint Services 3.0 (http://support.microsoft.com/kb/953630/)

    Wednesday, July 16, 2008 12:14 AM
  • Microsoft support called us about this same fix today as part of an ongoing case.  Good news!  I have tested this fix and it appears to have fixed the problem.

     

    Wednesday, July 16, 2008 11:47 PM
  • Looks like the delay activity broke again... 

    This is what I am running:
    Win 2003 SP2 + latest updates
    MOSS/WSS SP2 + April 2009 Uber Updates
    .NET 3.0 SP2
    .NET 3.5 SP1

    Cannot get a simple workflow to work: Start -> Send Email -> Delay for 1 min -> Send Email -> End

    Workflow waits endlessly at the Delay Activity. Same WF runs like a charm on a test VPC that is unpatched and running older MOSS updates. Can anyone else confirm that the delay activity is broken again?
    Friday, September 04, 2009 3:13 PM
  • Same issue here.

    this issue really seems to be difficult to solve. We are experiencing similar problems at a customer of our. However, the workflow delay does not stop forever, it does resume, but not always after the time that has been set.

    Windows 2008 SP 1
    SharePoint Server 2007 SP 2
    .NET FX 3.5 SP 1

    We are using a delay in a while activity (While continue=false --> delay) and have seen that the workflow sometimes only wakes up after 10 minutes, 20, 25, ... at the very beginning it seems to occur earlier... at a later stage (i.e. workflow has been running for a longer time already), the delays seem to take longer, sometimes 20 hours (while at the beginning there seems to be a predictable delay, at a later stage it is sometimes totally out of logic).

    Any more ideas on how to solve this thing?
    See also http://social.msdn.microsoft.com/Forums/en-US/sharepointworkflow/thread/2390dcee-d2f3-4a55-a024-6ad14913568e

    Best regards,
    Alex

    ECSpand Services for your SharePoint - Find out more at www.ecspand.com
    Thursday, November 26, 2009 12:49 AM
  • Hi I am facing the same timer problem in .net framework 3.5 . Can anyone help me regarding this issue..

    Friday, July 23, 2010 7:13 AM
  • Hi I am facing the same timer problem in .net framework 3.5 . Can anyone help me
    Friday, September 10, 2010 7:32 PM
  • Same issue here.

    this issue really seems to be difficult to solve. We are experiencing similar problems at a customer of our. However, the workflow delay does not stop forever, it does resume, but not always after the time that has been set.

    Windows 2008 SP 1
    SharePoint Server 2007 SP 2
    .NET FX 3.5 SP 1

    We are using a delay in a while activity (While continue=false --> delay) and have seen that the workflow sometimes only wakes up after 10 minutes, 20, 25, ... at the very beginning it seems to occur earlier... at a later stage (i.e. workflow has been running for a longer time already), the delays seem to take longer, sometimes 20 hours (while at the beginning there seems to be a predictable delay, at a later stage it is sometimes totally out of logic).

    Any more ideas on how to solve this thing?
    See also http://social.msdn.microsoft.com/Forums/en-US/sharepointworkflow/thread/2390dcee-d2f3-4a55-a024-6ad14913568e

    Best regards,
    Alex

    ECSpand Services for your SharePoint - Find out more at www.ecspand.com

    I have been experiencing the same exact issue as Alex.  I have opened a premier support ticket with Microsoft and have been working on this for nearly three months.  They claim they cannot reproduce this issue, but I have it on my production 2007 MOSS servers  It is beyond frustrating, if you see Delay Activities that do not re-hydrate consistently, please call them and open a ticket...ITS A BUG and they need more evidence to prove that it’s their problem that needs to be fixed.  They will not charge you for a bug, but you may have to pay up front then request a refund.

    • Edited by Mike Walsh FIN Monday, January 03, 2011 2:14 PM 2010 reference removed. Wrong forum for that
    Friday, October 29, 2010 5:30 PM
  • Hello, Finally, I got it working after setting the propertvalue 'job-workflow' To check if the property is set ( most likely it is not set ) ? 1 stsadm -o getproperty -pn job-workflow -url http://sp2010vmc002:1000 if you get <Property Exist="No" /> then set it by the following ? 1 stsadm -o setproperty -pn job-workflow -pv "Every 5 minutes between 0 and 59" -url http://sp2010vmc002:1000 Finally, do a iisreset and restart the Sharepoint 2010 Timer service. Ref: http://technet.microsoft.com/en-us/library/cc424970(office.12).aspx http://social.msdn.microsoft.com/Forums/en-US/sharepointworkflow/thread/2390dcee-d2f3-4a55-a024-6ad14913568e
    Thursday, March 15, 2012 5:53 AM
  • Hi All,

    I use Windows 7 ultimate for my development environment which have Sharepoint 2010 with SP1 installed.

    I created a simple sequential workflow using Delay Activity, and I set it to delay for 5 minutes.

    As you got, my workflow never wake up after executing Delay Activity. So, I read lots of article over internet, and I find some useful article. As the article suggest I try to :

    1. Set the current throttle : stsadm -o setproperty -pn workflow-eventdelivery-throttle -pv "45"

    2. Set the current batch size : stsadm -o setproperty -pn workitem-eventdelivery-batchsize -pv "250"

    3. Set the interval setting : stsadm -o setproperty -pn job-workflow -pv "Every 5 minutes between 0 and 59" -url "http://myurl"

    4. I retract the workflow solution

    5. Reset IIS

    6. Re-deploy may workflow solution

    but it still doesn't work !

    Finally I got the Delay Activity working after installing some Windows Update. Below is my update list :

    After installing the updates, I restart my computer, and then retract and re-deploy my workflow solution.

    And It running Well..

    Hope this will usefull for you all..

    Actually until now, I still understand how to exactly solve this problem..

    • Proposed as answer by Pebuardi R Monday, May 21, 2012 4:57 PM
    Monday, May 21, 2012 4:56 PM