none
Table header doesn't repeat on new page after applying hot fix

    Question

  • Good day,

    I am working on a report that uses a Tablix. I want the headers of the Tablix to report on every new page. I clicked in the Tablix Properties to repeat header rows on each page and keep header visible while scrolling. But headers do not repeat. I also went on the internet and downloaded the latest HotFix that was recommended to fix this problem but the headers still do not repeat. Is there something that I am missing.

    Thursday, September 26, 2013 2:28 PM

Answers

All replies

  • Which version of Reporting Services are you using?

    Thursday, September 26, 2013 3:19 PM
  • Hi,

    Please try the below link for your solution and let us know if it does not resolve your issue:

    http://www.sqlcircuit.com/2012/03/ssrs-how-to-repeat-column-header-in.html

    Thanks,

    Vishal

    • Proposed as answer by Jason A Long Friday, September 27, 2013 2:53 PM
    • Unproposed as answer by Set_Shot Friday, September 27, 2013 8:49 PM
    Thursday, September 26, 2013 4:14 PM
  • Good day,

    I am working on a report that uses a Tablix. I want the headers of the Tablix to report on every new page. I clicked in the Tablix Properties to repeat header rows on each page and keep header visible while scrolling. But headers do not repeat. I also went on the internet and downloaded the latest HotFix that was recommended to fix this problem but the headers still do not repeat. Is there something that I am missing.


    Try this link .

    sathya - www.allaboutmssql.com ** Mark as answered if my post solved your problem and Vote as helpful if my post was useful **.

    Thursday, September 26, 2013 4:37 PM
    Moderator
  • Microsoft SQL server reporting services designers version 10.50.2500.0
    Friday, September 27, 2013 1:49 PM
  • Tried this fix and now I get an error as follow

    An error occurred during local report processing

    The definition of the report/

    The tablix has an invaild tablixMember. All TablixMember. All Tablix memeber elements in a TablixCoulmnHierachy must have the KeepWithGroup property set to "NONE".

    Friday, September 27, 2013 1:53 PM
  • The link you sent has no bearing on what I am tring to accomplish.
    Friday, September 27, 2013 1:54 PM
  • No this does not resolve my issue. Now I get this error.

    Tried this fix and now I get an error as follow

    An error occurred during local report processing

    The definition of the report/

    The tablix has an invaild tablixMember. All TablixMember. All Tablix memeber elements in a TablixCoulmnHierachy must have the KeepWithGroup property set to "NONE".

    Friday, September 27, 2013 3:09 PM
  • Hi Set_Shot,

    Since you have a tablix but not a matrix, you should revert back the changes you made in COLUMN groups.

    Using the article posted by Vishal, locate the top most Static row in ROW groups and set property RepeatOnNewPage to true.

    Thanks.


    Remember to mark as an answer if this post has helped you.

    Friday, September 27, 2013 3:48 PM
  • Good Day Igor,

    Now I get this error,

    All tablixMember elements in a TablixColumnHierachy must have the RepeatOnNewPage property set to False.

    Friday, September 27, 2013 8:49 PM
  • So set them to false.

    Remember to mark as an answer if this post has helped you.

    Friday, September 27, 2013 8:51 PM
  • I did but the header still do not appear on each page.
    Friday, September 27, 2013 8:58 PM
  • In order to get to the Static Groups, you will need to select the "Advanced Mode" option under Column Groups.  After that you will need to select the Static groups in your row groups that are headers you want to repeat and modify the RepeatOnNewPage property to True.
    Friday, September 27, 2013 8:58 PM
  • Can you post the rdl file along with some data, so I could look in your report more close?

    Remember to mark as an answer if this post has helped you.

    Friday, September 27, 2013 8:59 PM
  • How do you post a rdl file??
    Friday, September 27, 2013 9:28 PM
  • Hi Set,

    In Reporting Services, we can set the tablix header repeat on each page.

    • If you are use a matrix, please right matrix and select “Tablix Properties”. Then check the “Repeat header columns on each page”.
    • If you use a table, please refer to the steps below to set it.
      1.Click the coin on the group and select “Advanced Mode”.
      2.Select the first static group on the row groups.
      3.Set the “RepeatOnNewPage” to true in the Properties window.

    And you get the error "All tablixMember elements in a TablixColumnHierachy must have the RepeatOnNewPage property set to False." This is caused by that you have multiple tablix header rows, some header rows' RepeatOnNewPage are set  to Ture, and some are set to "False". If we have multiple header rows on a tablix, the RepeatOnNewPage prperoty should be the same.

    If you have any questions, please feel free to ask.

    Regards,


    Charlie Liao
    TechNet Community Support

    Monday, September 30, 2013 9:28 AM
    Moderator
  • You can open an account at SkyDrive and download your RDL file there. Data will be needed to execute your RDL file.

    Remember to mark as an answer if this post has helped you.

    Monday, September 30, 2013 12:47 PM
  • Good Day Igor,

    I created a account on skrdrive and uploaded the report and data file.

    Vendor_Unpaid_claims_Status_summary

    Is there anything else I have to do??

    very new to this thanks for your help.

    Monday, September 30, 2013 2:55 PM
  • Good Day Charile,

    I did the steps that you have provided. But the headers still do not print on the next page(s).

    Regards,

    Set_Shot

    Monday, September 30, 2013 3:07 PM
  • Can you paste the link to your report?

    Remember to mark as an answer if this post has helped you.

    Monday, September 30, 2013 7:57 PM
  • You have to make the folder public or put the file in a public folder, so others can access it.

    Remember to mark as an answer if this post has helped you.

    Tuesday, October 01, 2013 2:17 PM
  • It is pl;ace in a public folder
    Tuesday, October 01, 2013 3:53 PM
  • I modified your report. Please get it from here and test it.

    https://skydrive.live.com/?cid=527f6c5d2a176ca4#cid=527F6C5D2A176CA4&id=527F6C5D2A176CA4%21140


    Remember to mark as an answer if this post has helped you.


    Tuesday, October 01, 2013 7:28 PM
  • Thanks Igor it works perfectly.
    Wednesday, October 02, 2013 9:01 PM
  • Igor, Thanks again for your help.

    But I need to know what you did because I'll have more reports in the future.

    If possible can you send me the steps you did to correct this problem.

    Thanks,

    Set_Shot

    Wednesday, October 02, 2013 9:21 PM
  • Your welcome.

    Here is what I did.

    1. Somehow the total row of your report had "KeepWithGroup" = Before. I changed it to None.

     

    2. Then I set correct values for the tablix header.

    Thanks.


    Remember to mark as an answer if this post has helped you.

    • Marked as answer by Set_Shot Friday, October 18, 2013 8:27 PM
    Thursday, October 03, 2013 2:03 PM