none
The report definition for report 'report.rdlc' has not been specified

    Question

  • Hello,

    I created a simple report, bound the report to the ReportViewer-Control.

    But the only thing I see is this error message
    "The report definition for report 'report1.rdlc' has not been specified"

    I searched this forum and found thread about this problem. There somebody suggested to prepend report name with namespace in ReportEmbeddedResource property. I tried that but with no luck. Somebody also suggested to check BuildAction property of .rdlc file and set it to Embedded Resource. But i cannot find this property in Visual Studio. Where is it?

    Examininig resulting .exe file generated by project shows that there is no embedded resource with .rdlc file. How can i embed .rdlc into .exe?

    Thanks

    Thursday, August 31, 2006 1:29 PM

Answers

  •  Shamez wrote:

    Select the Report in Solution Explorer, then look at your property window - the first property is Build Action. Make sure it's set to Embedded Resource. Let us know if this doesn't help.

    -Shamez

    This is true only for C# and possibly VB projects. But when your project is in C++ there is no BuildAction in property window.

    There is ugly workaround: you can go to project's property pages, open linker/input page and add report file name to "Embed managed Resource File" manually. That will add /ASSEMBLYRESOURCE:"report.rdlc" to linker command line.

    Monday, September 04, 2006 9:48 AM
  • Select the Report in Solution Explorer, then look at your property window - the first property is Build Action. Make sure it's set to Embedded Resource. Let us know if this doesn't help.

    -Shamez

    Friday, September 01, 2006 7:54 PM

All replies

  • Select the Report in Solution Explorer, then look at your property window - the first property is Build Action. Make sure it's set to Embedded Resource. Let us know if this doesn't help.

    -Shamez

    Friday, September 01, 2006 7:54 PM
  •  Shamez wrote:

    Select the Report in Solution Explorer, then look at your property window - the first property is Build Action. Make sure it's set to Embedded Resource. Let us know if this doesn't help.

    -Shamez

    This is true only for C# and possibly VB projects. But when your project is in C++ there is no BuildAction in property window.

    There is ugly workaround: you can go to project's property pages, open linker/input page and add report file name to "Embed managed Resource File" manually. That will add /ASSEMBLYRESOURCE:"report.rdlc" to linker command line.

    Monday, September 04, 2006 9:48 AM
  • no it dosent helps

    i am still getting the error

    Thursday, June 07, 2012 4:30 AM
  • no it dosent helps

    i am still getting the error

    I did all the above proposed solutions (adding namespace & setting build action) and still get the same error:
    'The report definition for report 'ReportXXX' has not been specified'
    Sunday, February 17, 2013 10:01 AM
  • I am also still getting the same error as specified above.

    Edward R. Joell MCSD MCDBA

    Monday, August 12, 2013 3:02 PM