none
A transport-level error has occurred when sending the request to the server on SQL Server 2008 R2

    Question

  • Hi All,

    Recently we are facing the connection disconnection issue on SQL Server 2008 R2 for long running query from client machine and given the below mention error.

    Msg 10053, Level 20, State 0, Line 0

    A transport-level error has occurred when sending the request to the server. (provider: TCP Provider, error: 0 - An established connection was aborted by the software in your host machine.)

    all script running fine on server itself without any issue. Please help me to fix the issue.

    Regards,

    Pawan Singh


    Thanks

    Monday, December 23, 2013 5:00 PM

Answers

  • That error indicates the client was unable to talk to the SQL Server for a period of time.  This almost always is a networking issue of some kind.  However, it can also occur if the SQL Server is too busy to respond due to some other problem, like RAM or CPU maxed.

    Thursday, December 26, 2013 1:50 PM
  • Hi,

    Also, check if max server memory is set to small by accident. Use the default settings to allow SQL Server to change its memory requirements dynamically based on available system resources. The default setting for min server memory is 0, and the default setting for max server memory is 2147483647 megabytes (MB). 

    To set a fixed amount of memory

    1. In Object Explorer, right-click a server and select Properties.

    2. Click the Memory node.

    3. Under Server Memory Options, enter the amount that you want for Minimum server memory and Maximum server memory.

    Thanks.


    Tracy Cai
    TechNet Community Support

    Thursday, January 02, 2014 3:38 AM

All replies

  • did you make sure that remote query timeout is set as 0

    EXEC sys.sp_configure N'remote query timeout (s)', N'0'
    GO
    RECONFIGURE WITH OVERRIDE
    GO


    Ramesh Babu Vavilla MCTS,MSBI

    Tuesday, December 24, 2013 6:58 PM
  • Thanks Ramesh for your response 

    sp_configure has set it's default value 600 should we need to changes it to 0 Please suggest.


    Thanks

    Wednesday, December 25, 2013 8:30 AM
  • hi,

    as per MS default value is 600 which is 10 mins, however you can change this value, refer below article.

    http://technet.microsoft.com/en-us/library/ms189040(v=sql.105).aspx


    Regards,
    Praveen D'sa
    MCITP - Database Administrator - 2008
    sqlerrors

    Wednesday, December 25, 2013 10:04 AM
  • Hi,

    The error message "Unable to write data to the transport connection: An established connection was aborted by the software in your host machine." indicate the issue is related to network connectivity.

    Check if relevant error message in SQL error log.

    Do you use TCP Chimney Offload? It is a networking technology that helps transfer the workload from the CPU to a network adapter during network data transfer. By default, TCP Chimney Offload is disabled in both these locations. However, OEM installations may enable TCP Chimney Offload in the operating system, in the network adapter, or in both the operating system and the network adapter. If it is enabled, I suggest you disable TCP Chimney Offload, RSS Feed, NetDMA according to: http://support.microsoft.com/kb/951037

    Thanks.


    Tracy Cai
    TechNet Community Support

    Thursday, December 26, 2013 7:16 AM
  • HI Tracy,

    I checked the TCP Chimney is was in Automatic status.

    i disabled both the TCP Chimney and Rss Feed  because NetDMA already in disable state, but after this setting same error occurs . Please let me know in case service restart required.

    Regard,

    Pawan Singh


    Thanks

    Thursday, December 26, 2013 12:51 PM
  • Hi,

    Check whether Auto_close option is set to true in the sql server database hwich you are trying to connect.

    Regards

    Kiran

    Thursday, December 26, 2013 1:18 PM
  • That error indicates the client was unable to talk to the SQL Server for a period of time.  This almost always is a networking issue of some kind.  However, it can also occur if the SQL Server is too busy to respond due to some other problem, like RAM or CPU maxed.

    Thursday, December 26, 2013 1:50 PM
  • Hi All,

    is there any chance for operating system that may be the cause of this error because some the colleague are not facing this error because they are using Windows XP operating system. Please suggest. 


    Thanks

    Tuesday, December 31, 2013 9:00 AM
  • Hi Kiran,

    Auto close option is off for the database.


    Thanks

    Tuesday, December 31, 2013 9:03 AM
  • Hi,

    Also, check if max server memory is set to small by accident. Use the default settings to allow SQL Server to change its memory requirements dynamically based on available system resources. The default setting for min server memory is 0, and the default setting for max server memory is 2147483647 megabytes (MB). 

    To set a fixed amount of memory

    1. In Object Explorer, right-click a server and select Properties.

    2. Click the Memory node.

    3. Under Server Memory Options, enter the amount that you want for Minimum server memory and Maximum server memory.

    Thanks.


    Tracy Cai
    TechNet Community Support

    Thursday, January 02, 2014 3:38 AM
  • HI Tracy,

    we did not changed the memory settings it's set to as per the default setting.


    Thanks

    Wednesday, January 08, 2014 5:38 PM