locked
the default settings SQL Server does not allow remote connections

    Question

  • Hi, I just downloaded VS Express a few days ago.  I tried running the personal website wizard, got the code generated, and I hit Ctr + F5 to run it and drive test the thing.  I get the following message:

     Server Error in '/WebSite2' Application.

    An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified).

    What can it be?  I am running a brand-new machine w ith Win XP Professional SP2.  I am trying to migrate my skills from ASP (VBScripts) to this .Net thing.  I get this pretty quickly, but I need to have some directions on how to start this.  I can't even play with the code because I am getting this error message.  I tried disabling Norton's antivirus  and Norton's firewall (Windows firewall is disable).

    Any ideas?

    Regards,


    Carlos

    info@paesano.com

    Thursday, September 21, 2006 2:14 AM

Answers

All replies

  •  

    Have a look at the following KB article, it will take you through the process of allowing remote connections.

    How to configure SQL Server 2005 to allow remote conections
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;914277

    Thursday, September 21, 2006 4:04 AM
  •  

    Hi,

     

    I have read the paragraph given in  the http://support.microsoft.com/default.aspx?scid=kb;EN-US;914277 and set the my setting as per the instruction. But still I am getting the same message.

    the default settings SQL Server does not allow remote connections.. What should I do.?
    Wednesday, March 12, 2008 1:44 PM
  • I had this problem and it turned out the application would only work with the default instance in SQL Server (i.e. no named instance).  Since this was the only DB in my SQL 2005 install, and not being a SQL person, I backed up the DB, uninstalled SQL 2005, deleted all the folders and files, rebooted, reinstalled SQL 2005 with all defaults, reapplied SP2 and its update, restored the DB and then was able to get the app to successfully establish a connection.  This was a pain in the butt but there was nowhere in the app to specify a named instance.

     

     

    Webster

    Tuesday, April 22, 2008 2:53 PM
  • An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections.

    what can i do with massahe?

    help me please

     

    Saturday, May 03, 2008 9:18 AM
  • Hey,

    May be your problem is same as mine.
    This is  the first my connection string:"Server=(local);Database=AdventureWorks;uid=sa;pwd=password;"
    And I got that error mesages. Then I try fixed follow the abow tutorial almost day and I were still got the same error message.
    At last, I changed the connection string same as this  "Server=(local)\\SQLEXPRESS;Database=AdventureWorks;uid=sa;pwd=password;"
    and I connected successfull

    So, Besure your connection string is correct first. Good luck
    Tuesday, June 10, 2008 8:39 PM
  •  After days and days, hours and hours I have this problem resolved.

     

    I contacted someone with a little more resources(Microsoft Directly) then myself, and here is what they found:

     

    This error is caused by a bug when you uninstall and reinstall SQL server. To fix this error is relatively simple:

     

    Locate the following folder(This is the location in vista):

    C:\Users\*YourUserName\AppData\Local\Microsoft\Microsoft SQL Server Data\SQLEXPRESS

     

    Delete the SQLEXPRESS Folder.

     

    Start the SQL Server Configuration Manager

     

    SQL Server will repopulate that folder.

     

     

     

     

    Thursday, July 17, 2008 9:02 PM
  • What would be the location in Windows 2003 Server?

     

    Thanks in advance.

    Friday, July 18, 2008 12:48 PM
  •  

    I have the exact problem. I use SQL Server 2005 Developer edition. What and where if I need to delete anything to make this to work? I am running Windows Vista.
    Friday, July 25, 2008 4:05 PM
  • Hello all!

     

    I got the same message, but I am not using SQL Server, but MS Access 2007. Everything works fine in my local machine, but after uploading the web site to the server I got this message.

    My data base is connecting with no problem, but the message above shows up when I try log in to the Admin part of the site using the ASPNETDB.MDF created by the Visual Web Developer 2008 Express Edition, after following the intruction under the ASP.NET Configuration Wizard.

     

    Any idea about what is going on here?

    Thanks

    Carlos Henrique

    chlc1966@yahoo.com

    Monday, August 25, 2008 6:15 PM
  • Hello,

    can you solve your aspnetdb problem? i have the same problem with you but i can not fix it.

     i connect database and get kind of data from database but the users can't login the forum area, because of

    this problem:

    An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)

    i hope you have solved your problem. i hope to hear from you soon. Bye...

     

     

    Okan PULUKÇU

    okan_ceng@hotmail.com

    Sunday, August 31, 2008 4:19 PM
  • I've tried almost all the solutions mentioned above and still am getting the same error. Any one please help me on this ..
    Thursday, July 16, 2009 5:53 PM
  • Starting the SQLBrowser service did it for me
    Friday, July 17, 2009 2:25 AM
  • Hi

    I got the reasons for the following error. This error is comming because you have to enable remote connection for sql server

     

    Sqlcmd: Error: Microsoft SQL Native Client: An error has occurred while establishing a connection to the server.
    When connecting to SQL Server 2005, this failure may be caused by the fact that under
    the default settings SQL Server does not allow remote connections.

     In the following url theire is ways to enable remote connections in sql server

    http://sqlservererror-info.blogspot.com/2009/07/error-has-occurred-while-establishing.html

    Regards

    Friday, July 17, 2009 11:57 AM
  • Friday, July 17, 2009 12:32 PM
  • same with me, some developer had turned off the SQL Browser and so it was not connecting, re-started the service and it connected.
    Tuesday, September 15, 2009 3:51 PM
  • This helped to resolve my issue successfully

    Thanks
    Thursday, October 01, 2009 12:57 PM