locked
Windows 8 don't recognize my DVD burner

    Question

  • Hi there,

    I recently installed Windows 8 Developer Preview x64 (with development tools) and everything seems to work just fine.

    I installed the OS via USB. Now, I've just realized that it doesn't recognize my DVD burner!

    The drive is OK (in Windows 7 (dual boot) it works perfectly).

    Has anyone ever had this problem? Is there a way to fix it or the only solution is to wait for the Beta (anyway, when should it be released?)?

     

    Thanks in advance!

    Monday, January 23, 2012 10:22 AM

All replies

  • Hi squall567,

    please get all your updates, including optional ones. Go to the Device Manager, check for DVD/CD-ROM drives drivers-Right Click-Update Driver-choose the second option to Browse my computer for driver software- Browse... to Computer-Windows7 -Windows- System 32- then find the folder 'driver' or DriverStore, I'm not sure which of these two contains your CD-ROM drivers, so you may try both, one after the other, and install whatever the Device Manager finds on its own.

    In case the ROM drives are not visible at all, you may have to download the drivers from your device manufacturer's site/the driver disk supplied by them.

     

     


    Irfan
    Monday, January 23, 2012 1:14 PM
  • Is this a IDE/ATAPI DVD Burner? Is yes, configure it as Master, not as slave.
    "A programmer is just a tool which converts caffeine into code"

    Monday, January 23, 2012 1:22 PM
  • Nope, it's Sata drive.

    Actually, to be more precise, it's a LG bluray-rewriter.

     

    Anyway, under the Device Manager there's no DVD/CD-ROM. It's like the drive is disconnected (but it's not!).

    Monday, January 23, 2012 1:34 PM
  • Is this a IDE/ATAPI DVD Burner? Is yes, configure it as Master, not as slave.

    Hello Andre.Ziegler,

    please explain what you meant by'configure it as Master'.


    Irfan
    • Edited by Irfanfare Monday, January 23, 2012 2:01 PM language
    Monday, January 23, 2012 1:41 PM
  • Hi there,

    I recently installed Windows 8 Developer Preview x64 (with development tools) and everything seems to work just fine.

    I installed the OS via USB. Now, I've just realized that it doesn't recognize my DVD burner!

    The drive is OK (in Windows 7 (dual boot) it works perfectly).

    Has anyone ever had this problem? Is there a way to fix it or the only solution is to wait for the Beta (anyway, when should it be released?)?

     

    Thanks in advance!

    I have the same problem but, the difference is that I am using 32bit version of Windows 8. The drive shows in Windows 7 but, in Win 8 nothing happens. I have tried everything which @Irfanfare said but still nothing.

    I think there was an update somekind of compatibility one and after insatalling that DVD stopped showing in Win 8.

    Monday, January 23, 2012 1:59 PM
  • Hi Ahmad Wahid,

    you may Search for Restore your computer to an earlier time in Settings, then go to Advanced Tools, Open System Restore. Now, restore your computer to date/time when your DVD drive was working well.


    Irfan
    • Edited by Irfanfare Monday, January 23, 2012 2:42 PM to complete
    Monday, January 23, 2012 2:12 PM
  • Hello Andre.Ziegler,

    please explain what you meant by'configure it as Master'.


    Irfan

    IDE allows to connect 2 drives. So 1 must be configured as Master and 1 as slave:

    http://en.wikipedia.org/wiki/Parallel_ATA


    "A programmer is just a tool which converts caffeine into code"

    Monday, January 23, 2012 2:53 PM
  • "Andre.Ziegler" wrote in message news:a3254881-a1b3-4c21-a633-a1feb33b333b...

     

    IDE allows to connect 2 drives. So 1 must be configured as Master and 1 as slave:



     
     
     
    ....  or set both to Cable Select. :)

    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth
    Monday, January 23, 2012 3:24 PM
  •  
    ....  or set both to Cable Select. :)

    yes, this is also possible.
    "A programmer is just a tool which converts caffeine into code"

    Monday, January 23, 2012 8:18 PM