locked
"The operation could not be completed. Access denied"

    Question

  • Hello people,

    I´m a really annoying issue with VS Express, and I can´t seem to find any way around it.
    If I load a project in VS and press F5, the build is successful and the program runs,
    but only ONE time! If run my program again, I get the following message:
    "The operation could not be completed. Access denied".

    However if I skip debugging by pressing CTRL+F5, everything works fine.
    If I restart VS, I can use F5 once again, but still only one time,
    then another restart is required.

    Below is the output from the build. To me it looks like the build process
    completes every time, and that it is the debugging that for some reason
    gives me this access denied.

    I earlier had an evaluation version of VS Pro, with the exact same error.
    Any clues as to what might be causing this? Anyone know any applications
    that could tell me exactly what VS is trying to access when this message is returned?

    Cheers,

    Daniel

    ------ Build started: Project: Rapporter, Configuration: Debug Any CPU ------

    C:\WINNT\Microsoft.NET\Framework\v2.0.50727\Vbc.exe /noconfig /imports:Microsoft.VisualBasic,System,System.Collections,System.Collections.Generic,System.Data,System.Drawing,System.Diagnostics,System.Windows.Forms /nowarn:42016,41999,42017,42018,42019,42032,42036,42020,42021,42022 /rootnamespace:WindowsApplication1 /doc:obj\Debug\Rapporter.xml /define:"CONFIG=\"Debug\",DEBUG=-1,TRACE=-1,_MyType=\"WindowsForms\",PLATFORM=\"AnyCPU\"" /reference:C:\WINNT\Microsoft.NET\Framework\v2.0.50727\System.Data.dll,C:\WINNT\Microsoft.NET\Framework\v2.0.50727\System.Deployment.dll,C:\WINNT\Microsoft.NET\Framework\v2.0.50727\System.dll,C:\WINNT\Microsoft.NET\Framework\v2.0.50727\System.Drawing.dll,C:\WINNT\assembly\GAC_MSIL\System.Web.Services\2.0.0.0__b03f5f7f11d50a3a\System.Web.Services.dll,C:\WINNT\Microsoft.NET\Framework\v2.0.50727\System.Windows.Forms.dll,C:\WINNT\Microsoft.NET\Framework\v2.0.50727\System.Xml.dll /main:WindowsApplication1.My.MyApplication /debug+ /debug:full /out:obj\Debug\Rapporter.exe /resource:obj\Debug\WindowsApplication1.Form1.resources /resource:obj\Debug\WindowsApplication1.Resources.resources /target:winexe Form2.Designer.vb Form2.vb Module2.vb "My Project\AssemblyInfo.vb" "My Project\Application.Designer.vb" "My Project\Resources.Designer.vb" "My Project\Settings.Designer.vb"

    Rapporter -> F:\program\ie\Mina Dokument\Visual Studio 2005\Projects\Rapporttest\Rapporttest\bin\Debug\Rapporter.exe

    ========== Build: 1 succeeded or up-to-date, 0 failed, 0 skipped ==========

    Tuesday, January 16, 2007 11:42 AM

Answers

  • go to Project Properties

    go to the Debug tab

    uncheck "Enable the Visual Studio hosting process".

     

    Tuesday, January 16, 2007 2:36 PM

All replies

  • Hello

    The only experience I have had with IDE access denied messages etc is when I am running vshost, and I haven't seen that since 2003; albeit I am not running the express VS.

    If you do not need to use vshost, try turning it off and see if this solves the problem.

    Sorry I can't be more helpful.

    Richard

    Tuesday, January 16, 2007 1:23 PM
  • How would I go about to turn that off?

    I can´t find anything under "Services",
    and I see no process running named vshost...

    Cheers,

    /Daniel

    Tuesday, January 16, 2007 2:27 PM
  • go to Project Properties

    go to the Debug tab

    uncheck "Enable the Visual Studio hosting process".

     

    Tuesday, January 16, 2007 2:36 PM
  • Are you using two instnances of visual studio?

    When you try and run the project and get the access denied error is it in the output window or is it a message box? 

     If it's in the output window can you post the entire contents of the output window as it will help us diagnose the probem.

     

    Tuesday, January 16, 2007 4:09 PM
  •  Dick Donny wrote:

    go to Project Properties

    go to the Debug tab

    uncheck "Enable the Visual Studio hosting process".

    Cheers, I´ll try this tomorrow when I get back to work.

     

     

     

     

     

     

     

     

     Jared Parsons MSFT wrote:

    Are you using two instnances of visual studio?

    When you try and run the project and get the access denied error is it in the output window or is it a message box? 

     If it's in the output window can you post the entire contents of the output window as it will help us diagnose the probem.

     

    I´m only using one instance of visual studio.

    Unfortunatly it´s only a message box, and the message I posted earlier is all the information I´m getting.

    Tuesday, January 16, 2007 7:41 PM
  •  Dick Donny wrote:

    go to Project Properties

    go to the Debug tab

    uncheck "Enable the Visual Studio hosting process".

     

    Wow, works like a charm!

    Thanks alot mate. Any idea what features I might be losing
    by turning of the hosting process?

    /Daniel

    Wednesday, January 17, 2007 6:20 AM