none
The server was unable to save the form at this time. Please try again

    Question

  • Having created a new custom list (even with only a text field) I am unable add new items to the list - the error message is Unexpected response from server. The status code of response is '0'. The status text of response is ''. when in 'quick edit'.

    If I try to add or modify an item in the list by clicking 'add new item' I get "The server was unable to save the form at this time. Please try again."

    I have restarted the Sharepoint Search Host Controller server but to no avail. I have 24Gb RAM for this server so it's not a memory issue (8Gb available). I have also tried from various browsers including Chrome and Safari - still the same error message.

    This error only occurs on lists. I can edit document properties in a library and have no problems with calendar entries.

    There are no entries in the event viewer, so where do I need to begin looking to find out what is (or rather is not) happening?

    • Edited by gjross Wednesday, January 09, 2013 7:10 PM
    Wednesday, January 09, 2013 2:20 PM

All replies

  • One thing I noticed in SP 2013 is that if your list has unique permissions and a user/group has permissions only on that list and has limited or no access at the site level, then you run into this error: "The server was unable to save the form at this time. Please try again."

    This can be resolved by either giving that user/group atleast read access at the site level or in my case I had to create a new permission set (since we cant update limited access permission set) which is same as limited access but with the additional permission of "Use Remote Interfaces  -  Use SOAP, Web DAV, the Client Object Model or SharePoint Designer interfaces to access the Web site."

    I am not sure if this is a bug or as per design, but not allowing a user who has needed permissions at the list level but limited access at site level doesnt seem right. Never ran into this issue in prior version of SharePoint. I tested and this additional permission doesnt seem to violate any security at site level. But implement this at your risk. No guarantees provided and not responsible for any issues with this implementation if any.

    Monday, January 14, 2013 4:49 PM
  • I had asked the similar question here

    http://social.technet.microsoft.com/Forums/en/sharepointadmin/thread/e60b6b23-c5dd-4697-96ee-e9d5514fc2fc

    no answers yet..


    Raghavendra Shanbhag | Blog: www.SharePointColumn.com
    Please click "Propose As Answer " if a post solves your problem or "Vote As Helpful" if a post has been useful to you.
    Disclaimer: This posting is provided "AS IS" with no warranties.

    Monday, January 14, 2013 6:04 PM
  • I spent a couple of days on the phone to Microsoft and, whether by luck or judgement, we managed to remove the problem.

    From Central Admin, create an extension of the web application - create a new IIS site and use the rest of the defaults. Create a new list and test that items can be added to that list.

    We went back to the original web application and tested adding a new item, sure enough it worked. Then delete the newly created extension.

    The theory was that by creating the extension, the web.config file was rewritten and removed the error, although the chap at Microsoft couldn't be 100% sure.

    Monday, January 14, 2013 7:53 PM
  • Good to know that it worked for you.. It didn''t work for me :( But i really don't think it should be only with web.config changes. Did you try comparing the web.config files? Did you find any changes. If not it would be helpful if you can provide/share the web.config so that i can validate with the one i have.


    Raghavendra Shanbhag | Blog: www.SharePointColumn.com
    Please click "Propose As Answer " if a post solves your problem or "Vote As Helpful" if a post has been useful to you.
    Disclaimer: This posting is provided "AS IS" with no warranties.

    Tuesday, January 15, 2013 6:22 AM
  • Did you try creating an extension of an already existing web application? Your other post seems to suggest that you created a new web app rather than an extension of the one causing the issue.
    Tuesday, January 15, 2013 9:31 AM
  • yup.. i did that but no luck, so had asked for the web.config.

    Raghavendra Shanbhag | Blog: www.SharePointColumn.com
    Please click "Propose As Answer " if a post solves your problem or "Vote As Helpful" if a post has been useful to you.
    Disclaimer: This posting is provided "AS IS" with no warranties.

    Tuesday, January 15, 2013 10:58 AM
  • I've just been fighting the same error message (Unexpected response from server. The status code of response is '0'. The status text of response is ''.) with the Content Search webpart. Internet Explorer developer tools (F12) showed that a request for:

    /_vti_bin/client.svc/ProcessQuery

    was being redirected to /_login which would then redirect to /_windows and then back to /_vti_bin/client.svc/ProcessQuery. This repeated a few times before giving up.

    It turned out that anonymous authentication was disabled in IIS Manager and enabling it fixed it. I guess that I didn't have access to the client.svc web services so it tried to prompt me to login but /_login knew that I was already logged in so sent me back.

    As a quick test, try getting to <yoursite>/_vti_bin/Client.svc/web/lists in a browser and see what happens.

    Hope this helps.

    • Proposed as answer by BenisJ Thursday, January 24, 2013 6:14 PM
    Tuesday, January 15, 2013 4:22 PM
  • +1 for "It turned out that anonymous authentication was disabled in IIS Manager and enabling it fixed it."  I have had the same problem for days, finally enabled anonymous authentication across the board and I can now save things to Sharepoint.  Thanks Tom.
    Thursday, January 24, 2013 6:14 PM
  • +2 for "It turned out that anonymous authentication was disabled in IIS Manager and enabling it fixed it."    I had the same problem and enabling Anonymous authentication in IIS manager for the SharePoint web application fixed the issue.

    Andre Galitsky, MCTS, Richmond, VA -- My SharePoint Blog: http://sharepointnomad.wordpress.com

    Monday, February 18, 2013 2:18 PM
  • Hi All,

    Enabling Anonymous access is not really a solution. Can anybody explain WHY you need anonymous authentication enabled, and propose a more secure solution to granting the proper rights to the proper roles/users?

    Thanks

    Per Solli

    Monday, April 01, 2013 4:07 PM
  • I too solved this issue by enabling anonymous access.  I'm also curious as to what a more secure solution might be.  How does anonymous access effect my Sharepoint server?
    Monday, April 01, 2013 5:59 PM
  • grant "Visitor" permissions to all users and problem is solved
    Friday, April 26, 2013 11:01 AM
  • I have upgraded a site collection from SP 2010 tpo SP2013 and i am getting this issue while adding a new item.

    "The server was unable to save the form at this time.  Please try again.". Any resolutions !!??

    Thursday, May 16, 2013 8:30 AM
  • Hi Tomwaters

    Definately a fix, i have 24GB on my server as well and enabling anonymous access and doing an IIS reset fixes the issue.

    The other issue it fixes is when you search for a person, it now shows the names etc. and does not give you an error anymore.

    Cheers Mate.

    Wednesday, June 12, 2013 9:00 AM
  • I have had a similar problem.  I found out that it is not a permissions problem, but a problem with some custom workflow activities from a pervious version of SharePoint (2007).  These activities were not installed after the upgrade to 2013 and forms with workflows that used these actions would not save.  Disabling the workflow allows the new item to be saved.  It appears SP 2013 is somehow making sure that the workflow will run successfully before allowing a new item to be written.

    Maybe this is not the typical problem, but maybe worth having on here for future readers of this thread.

    Friday, August 23, 2013 10:51 PM
  • Hi all

    I have a similar problem in SharePoint 2013!
    We have Intranet website and in subsite I created a small forms in a list, with a fiew fiels.
    When I validate form, I have immediatly this error : The server was unable to save the form at this time. Please try again

    I checking everything, anonymous access, disabled WorkFlows features, added everyone in visitor group.... but it's the same....
    Any idea ?

    Eric, what do you mean "Disabling the workflow allows the new item to be saved" ???
    if you use Workflow moved from SP 2007 to 2013 ?

    Many thanks.

    Wednesday, August 28, 2013 9:29 AM
  • Hi DarkMoutch,

    Sorry, reading my reply again I obviously was not clear on what I meant.  What I meant by disabling the workflows was to go into the list list/library with the problem and remove the SharePoint Designer wokflow.  This deletes the association of that workflow with that list, and doesn't actually delete the wokflow.  Then you can still open the workflow with SPD and do maintenance on it.

    Only do this for workflows created with SPD though.  If you delete a workflow created in SharePoint (e.g. the Aproval WF) then it is gone.

    I wouldn't be surprised if other things can cause the above message though.  In SP 2007 I had some problems with InfoPath forms and it turned out to be that I needed to add the 'Use Remote Interfaces' permission to the permission level being used (contribute I think).  I haven't made it that far to test this with 2013 though.  To adjust this go to the top level of the site collection -> site settings -> site permissions -> permission levels (in the ribbon).

    Wednesday, August 28, 2013 3:54 PM
  • May be you have not given the permissions correct to the user.

    So go to permission level and assign "Use Remote Interfaces  -  Use SOAP, Web DAV, the Client Object Model or SharePoint Designer interfaces to access the Web site." this permission to the user.

    Hopefully it will help you.

    Pratik Purohit

    MCTS, MCP

    Friday, September 13, 2013 5:00 AM
  • Thanks Eric and Pratik,

    Saved my day. I had user group with "Restricted Read"  site level  and "Contributor" on document library.

    I was getting into same issue mentioned above. I have used your solution of adding permission level to user group.

    Thanks,

    Prashanth

    Friday, January 24, 2014 7:05 AM
  • I was facing same issue following steps worked for me.

    1) Enable 'Manage content types' in the library setting.
    2) Add the 'Link to a document' content type.
    3) Edit the properties of the document and save.

    Please let me know if its fixed

    Regards,

    Omkar

    Monday, June 09, 2014 8:20 AM
  • This resolved for me, thanks.
    Tuesday, September 02, 2014 4:58 AM