locked
Invalid DOS Path Error - Unable to Open VSS database

    Question

  • Hi our network has recently changed the network mapping of a shared drive where our VSS database is located.  This has caused the VSS program to complain a dos path error.  I tried remapping the database to the new path where the srcsafe.ini is located but I had no luck.

    The new path is somewhat similar to the one below

    \\hr.serv.acme.com\hr-shared-drv\application\vss\srcsafe.ini

    previously it was:

    \\hrserv34-v3\application\vss\srcsafe.ini

    Previously we had no problems.  I've checked the permissions and no problems there.  What could have been made wrong? I'm running VSS v 6.0d on Windows NT.

    Can anybody send me a comprehensive list of probable root causes?
    Monday, June 26, 2006 7:34 AM

Answers

  • Do you have read/write access to the shared drive? Can you create a file in the database location from the client computer?

    Make sure you have correct permissions set on both network share and the files on disk.

    Do you get this error in VSS or VS?

    In VS you may need to unbind everything and bind to the new database using change source control dialog or modify the location of the database in HKLM\Software\Microsoft\SourceSafe\Databases\<your database name>

     

    Monday, June 26, 2006 3:49 PM
  • Hmm… VSS should not have problem with this path as long as your user account has read and write access to the files on this share. From what I understand you mapped network share to a drive and is able to access the database this way. This is very strange as VSS only using file access to operate with the database. The only difference I see is that mapped disk path is shorter, but you still have reasonably small path so I’m not sure what is happening. Another possibility is that perhaps you have some sort of antivirus that has more strict control for accessing files of the network share.

    Have you tried accessing this database from another computer (preferably with Windows XP on it)?

    Tuesday, June 27, 2006 10:05 PM

All replies

  • Do you have read/write access to the shared drive? Can you create a file in the database location from the client computer?

    Make sure you have correct permissions set on both network share and the files on disk.

    Do you get this error in VSS or VS?

    In VS you may need to unbind everything and bind to the new database using change source control dialog or modify the location of the database in HKLM\Software\Microsoft\SourceSafe\Databases\<your database name>

     

    Monday, June 26, 2006 3:49 PM
  • Yes I already mentionend I have sufficient permission please read carefully.  I can create a new database but I cannot connect to the existing database since the remapping of the drive share.

    I did found a work around though, and that is directly mapping the database to the mapped drive path instead of the whole \\server-name\foldershare\application-folder\vss\srcsafe.ini path.  The database config would be defined as F:\applicationfolder\vss\srcsafe.ini.  With this I was able to reopen the database

    I dunno why VSS rejects folders shares with structures like that.  Previously the foldershare had worked for me.  I don't know about the change source control dialog.  Can you tell me how to navigate to it? In the first place I cannot open the database or VSS for that matter.

    I didnt checked the registry either.  Some of my colleagues has hypothesized is that because the foldershare had "-" and that VSS refuses to recognize such path names.

    \\hr.serv.acme.com\hr-shared-drv\application\vss\srcsafe.ini

    I'm out of root causes.  All I get from Microsoft support are very vague answers.

    Tuesday, June 27, 2006 5:39 PM
  • Hmm… VSS should not have problem with this path as long as your user account has read and write access to the files on this share. From what I understand you mapped network share to a drive and is able to access the database this way. This is very strange as VSS only using file access to operate with the database. The only difference I see is that mapped disk path is shorter, but you still have reasonably small path so I’m not sure what is happening. Another possibility is that perhaps you have some sort of antivirus that has more strict control for accessing files of the network share.

    Have you tried accessing this database from another computer (preferably with Windows XP on it)?

    Tuesday, June 27, 2006 10:05 PM