none
Web Service Permission Problem

    Question

  • I am having a problem with permissions since moving a 2005 reporting services database to Server 2008. I have install SSRS and the report website works fine, the web service (ReportExecution2005.asmx) also works fine provided I pass in the credentials of an Administrator of the server (which I dont want to do).

    I have created a user account that I would like to use. I made it a member of SQLServer2005ReportingServicesWebServiceUser

    I also give it full permissions on the IIS folder:

    C:\Program Files\Microsoft SQL Server\MSSQL.2\Reporting Services\ReportServer

    I also made this user a System Administrator of SSRS using the Server Properties tool in Management Studio.

    However I am still not able to run reports using the web service unless I login as a machine administrator.

    If I try to browse to the location:

    http://mydomain.com/reportserver/ReportExecution2005.asmx

    I am able to get the XML no problem loging in as my newly created user. It just will not allow me to execute.

    Can anyone help?

    Many Thanks

    Some info on IIS. The Report Server is using a Classic pool with NetworkService identity (v2.0 .NET). Network Service also has full permissions on the IIS folder.

    Authentication:

    Anon : Disables

    ASP.NET Impersonation: Enabled

    Forms Auth: Disabled

    Windows Auth: Enabled

    Tuesday, September 10, 2013 12:26 AM

Answers

All replies

  • Hello Martin,

    There is no need to modify the permissions within IIS; SSRS do have it's own permission system. You have to add the user at least to the "Browser" role in SSRS to give the user permission to open the report.


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Tuesday, September 10, 2013 6:51 AM
  • Hi, I have added the user to the group SQLServer2005BrowserUser giving browser access to all reports. However this did not solve the problem. Remember the user is already a System Administrator inside SSRS.
    Tuesday, September 10, 2013 8:29 AM
  • Solved this problem. Had to delete the user from windows and start again.
    • Marked as answer by Martin McNally4 Wednesday, September 11, 2013 12:38 AM
    Wednesday, September 11, 2013 12:38 AM