sticky
Solution: Intellisense broken in all WPF Projects after installing SDK/MSDN

    General discussion

  • There have been several reports where intellisense has completely stopped working for all projects after installing a version of the Windows SDK or MSDN.  We have been able to track down the source of this problem.  This seems to only affect installs of the SDK/MSDN post the installation of Visual Studio.  One registry value has been incorrectly reset after these installs causing this failure.  This issue has been handed off to setup team for a future fix. 

     

    In the meantime, if you encounter this issue, it can be fixed using regedit.  First, determine if you are seeing this same issue by opening regedit and looking at the key:

    HKEY_CLASSES_ROOT\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32

    If (Default) is empty you are hitting this issue.  To correct the problem, change the value of (Default) to point to the location of TextMgrP.dll on your system (C:\Program Files\Common Files\Microsoft Shared\MSEnv\TextMgrP.dll in my case with a C: OS drive and accepting all the defaults).  Restart Visual Studio and intellisense should be working again.  Thanks to everyone who submitted reports of this issue and gave us the additional details needed to track it down quickly.

     

    Update: If you are running a 64-bit version of Windows, you will need to make sure you are running the correct regedit version (%systemroot%\syswow64\regedit - see http://support.microsoft.com/kb/305097) and you will need to locate the correct path to TextMgrP.dll (such as C:\Program Files (x86)\Common Files\Microsoft Shared\MSEnv\TextMgrP.dll)

    Wednesday, February 13, 2008 9:57 PM

All replies

  • Microsoft SDK Team,

     

    Thank you all for your very fast response and solution to this issue.  All us WPF developers appreciate your outstanding work!  Thank you.

    Tuesday, February 19, 2008 10:49 AM
  • Note that the MSDN team has posted an official solution here:

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=2892404&SiteID=1

     

    Monday, March 17, 2008 6:13 PM
  • I'm sorry but I tried the method above and it doesn't work. I suffered a lot without the intellisense for the XAML files. Any other suggestion?

    Thanks.
    Wednesday, March 19, 2008 9:51 AM
  • I’ve answered your duplicate post on another thread here http://forums.microsoft.com/forums/ShowPost.aspx?PostID=3028989&SiteID=1

     

    --Karin

     

    ||Karin Meier||Windows SDK PM||Build Environment.Samples.Community|| http://blogs.msdn.com/KarinM||

     

    Wednesday, March 19, 2008 2:32 PM
  • I had the same problem, tried the fix on a 64-bit system and it didn't seem to be helping.

     

    However, I wasn't checking all the xaml files in my project.  Only one of the xaml files I was working on wasn't getting the intellisense, so I added a new window to the project and presto, intellisense was working again!

     

    I closely compared both files to see if possibly the namespaces could be the culprit and nothing was different there.  So, I deleted the file that wasn't getting intellisense and created a new one with the same name.  Now, VS2008 says Visual Studio has encountered an unexpected error when I try to open my new file in the designer.  Weee, a new problem!

     

    Finally, I deleted the new file that had the original name, manually edited the project file with notepad to remove the page and compile xml nodes that mentioned that file.  I'm glad to report everything worked fine again when I re-opened my project and created my new window with the name I wanted.

    Thursday, May 22, 2008 4:20 PM
  • I tried the fix mention above and also tried repairing VS 2008. Still does not work. Any other work arounds/solutions?
    Thursday, September 18, 2008 6:39 PM
  • Hi,
    I am also facing intellisense issue in VS2008. I have correct reg entry. I still tried to re register the  TextMgrP.dll and tried to repair VS2008 but still it is not working for me. Any help would be really helpful. Its really painful to work without intellisense in XAML.
    Thursday, September 25, 2008 2:19 PM
  • I
    I do also have the same issue. I checked the registry (not empty, good path), i registered also the DLL using cmd... Still no XAML Intellisense.
    Now i'm tring to "repair" VS2008. A "few" minutes later : nothing more i still only have  !--, CDATA or ? nothing more...

    I'm having : .Net 3.5 SP1 (and older), SDK for VS 2008 SP1 tools, SDK for VS 2008 .Net Framework tools, SDK for VS 2008 SDK Reference Assemblies and Intellisense, french language modules, MSDN for 2008, and Windows XP SP3 ...

    Any clue ?
    Thanks in advance.
    • Edited by wonderliza Tuesday, October 07, 2008 1:56 PM
    Tuesday, October 07, 2008 1:55 PM
  • I am also having this problem on a 64 bit machine (Fresh install running Vista Business, SQL Server 2008, .NET 3.5SP1 and Visual Studio SP1).  I installed .NET 3.5SP1 first, then SQL Server 2008, then visual studio.  I have tried manually registering the TextMgrP.dll and repairing Visual Studio to no avail.  Any updates from anyone?
    Eric Kaufman
    Tuesday, October 14, 2008 8:10 PM
  • Also, this is an error I get in the output window when I try and view XAML:

    The Microsoft.VisualStudio.Xaml ({E58C2A8B-BCC4-4559-AD59-D62EB6D58A22}) did not load because of previous errors. For assistance, contact the package vendor. To attempt to load this package again, type 'devenv /resetskippkgs' at the command prompt.

    If I try to go to Tools > Options > Text Editor > I can click on General and Tabs.  However if I click on Formatting or Miscellaneous then I get the error: "An error occured loading this property page".

    To reiterate:
    1. When I run '%systemroot%\syswow64\regedit' the Default is 'C:\Program Files (x86)\Common Files\Microsoft Shared\MSEnv\TextMgrP.dll'.  This file exists locally.
    2. I have tried to register (as an administrator with 'regsvr32 "%CommonProgramFiles(X86)%\Microsoft Shared\MSEnv\TextMgrP.dll"' to which I receive the prompt 'DllRegisterServer in C:\Program FIles (x86)\Common Files\Microsoft Shared\MSEnv\TextMgrP.dll succeeded.'
    3. I have tried repairing Visual Studio.
    4. I have tried uninstalling and reinstalling visual studio.
    Anything else work for anybody else?

    Eric Kaufman
    Tuesday, October 14, 2008 8:21 PM
  • I have the exact same problem as Eric.

    I've checked the registry value and it is linked to that .dll file...

    Has anyone come up with a solution to this?
    Friday, November 07, 2008 6:43 PM
  • thing was that xml editor does not support intellisense...

    I set the default to source code editor which does support intellisense

    Friday, November 07, 2008 7:05 PM
  • That's it ! Thanks a lot joCh_asdf, it solved my problem : i was using the XM editor. I changed it to text code editor.
    Wednesday, November 12, 2008 10:34 AM
  • Eric,
    Did you every find a solution for this problem?  I have the exact problem you list above and I've tried both repairing and manually registering the dll. Nothing works.

    Thanks
    Bubba Richard
    Wednesday, January 21, 2009 5:05 PM
  • Richard,
    Did you try my solution ? It worked for me :
    "That's it ! Thanks a lot joCh_asdf, it solved my problem : i was using the XML editor. I changed it to text code editor."
    Thursday, January 22, 2009 10:00 AM
  • wonderliza,

    I tried it and it did not work. Still no intellisense, no color coding no nothing. Just plain black and white text.  No XAML Gui designer etc.

    Sunday, February 01, 2009 10:22 PM
  • Sorry to say, but this post was absolutly useless for me:
    I've described my problem here: http://social.msdn.microsoft.com/Forums/en-US/vswpfdesigner/thread/6c7a9c6c-d565-46ae-83ed-d39998c0fd41/
    Monday, February 16, 2009 1:50 PM
  • Thanks a lot for your help, it works great ;-) 
    Friday, March 06, 2009 12:09 AM
  • Eric,
    Did you every find a solution for this problem?  I have the exact problem you list above and I've tried both repairing and manually registering the dll. Nothing works.

    Thanks
    Bubba Richard

    I tried both too and it still don't work (the default key is not empty). I have VS 2008 team suite SP1, before i install this version i had vs 2008 express and proffesional and there where everything ok.
    Wednesday, April 08, 2009 8:23 PM
  • I have the same problem. No intellisense whatsoever in either XAML or XML editors.
    My environment is:
    • WinXP SP3
    • VS2008 Pro SP1
    • All the updates, hotfixes
    • SDK 6.1, but the key HKEY_CLASSES_ROOT\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32 looks great, TextMgrP.dll is properly registered (though the HKEY_CLASSES_ROOT\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395} key has only InProcServer32 subkey, usually there are more).
    But still no intellisense. The XAML editor has also stopped to support region folding - no collapse/expand markers are shown. This is unlike the XML editor, which works fine with this respect.
    Browsed zillion forums, no answers. It worked prior SP1.
    Any help is appreciated.
    Thursday, April 16, 2009 8:47 AM
  • I uninstall Visual studio, all updates and hotfixes, delete VS keys by regedit and install VS again and now it's workig (intellisense is OK).  If you want try this
    Thursday, April 16, 2009 10:16 AM
  • Thanks for the advise. I wonder what Microsoft recommends.
    Full reinstall is just too time consuming for me...
    Thursday, April 16, 2009 11:18 AM
  • I don't have an

    HKEY_CLASSES_ROOT\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32 key.

    Instead it is:

    HKEY_CLASSES_ROOT\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\ProxyStubCLs id32

    VS2008 pro
    vista

    Tuesday, October 13, 2009 4:24 AM
  • After reading many web pages looking for a solution. I figure it out by myself. here is what i did.

    go to Tools->options->Text Editor->file extension. there you have to add the xaml extension and select Web service Editor with Encoding.  that woks beautifully.
    Tuesday, November 10, 2009 1:00 AM
  • Hi Guys,

    I finally found the answer with this lovely post...trust me it works all the time...

    http://forums.silverlight.net/forums/p/170563/384565.aspx

    I ran steps 1 to 4 pay close attention to my reply on that post...i had to chande location to vs studio IDE location before running all the Reset sequence steps befor it worked so even if you open vs command prompt still change location to "Common7/IDE" before running the steps 1 to 4 or it might not reset vs properly...Enjoy! 

    ps i did this on windows 7 ultimate 64-bit, vs studio team system 2008 on a Dell xps 700, intel core2 duo, for those interested!


    This Above all: to thy Self be True - William Shakespeare
    Tuesday, April 06, 2010 2:59 PM
  • Is the source code editor...
    Wednesday, April 14, 2010 9:13 AM
  • This was great solution.

    Wednesday, May 12, 2010 10:27 AM
  • In the meantime, if you encounter this issue, it can be fixed using regedit.  First, determine if you are seeing this same issue by opening regedit and looking at the key:

    HKEY_CLASSES_ROOT\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32

    I have also got the intellisense broken in the xaml........Please help me urgently

    Opening the regedit means?where can i find it?

    i am new at this....please  help

    Friday, May 14, 2010 7:50 AM
  • To find regedit: Start button -> Run

    Enter "regedit"

    From there you should see the Registry Editor application.

    Tuesday, May 18, 2010 9:43 PM
  • After reading many web pages looking for a ripper solution. I figure it out by myself. here is what i did.

    go to Tools->options->Text Editor->file extension. there you have to add the xaml extension and select Web service Editor with Encoding.  that woks beautifully.

    My problem was also solved with this method. Thanks very much for your sharing.
    Wednesday, July 07, 2010 3:04 AM