none
Cannot use TFService from VS 2012: HTTP code 400 Bad Request

    Question

  • Hi all!

    I signed up for TFService and created a project, then I connected to TFService using VS 2012 and created some empty folders and empty branch for the project. Everything was good. The next day I wasn't able to use Source Control Explorer or Pending Changes and I couldn't check anything in. VS 2012 connects to TFService but then gives me this when I try to use Source Control Explorer:

    ---------------------------
    Microsoft Visual Studio
    ---------------------------
    Error

    The request was rejected by the server.

    Technical information:

      HTTP code 400: Bad Request
    ---------------------------
    OK  
    ---------------------------

    How to resolve this?

    Thanks!

    I have VS 2012 Ultimate installed on Windows 8 Pro 64-bit. My project page is https://vborovikov.visualstudio.com/

    Monday, November 05, 2012 8:17 PM

Answers

All replies

  • Hi Vladislav,

    Thank you for your post.

    Can you use other TFService features in VS?

    Can you log on your TFService site via IE browser?

    Regards,


    Lily Wu [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, November 06, 2012 6:46 AM
    Moderator
  • Hi Lily,

    I can establish a connection to TFService in VS, but it gives me three error messages (HTTP code 400) in a row when I open a Team Explorer. It doesn't allow me to check files in or shelve them showing the same error. Web Access only seems to be working fine.

    I can log on to my TFService site via IE and Firefox without any problem.

    Thanks,

    Vladislav

    Tuesday, November 06, 2012 9:32 AM
  • I've resolved the issue by creating a new workspace and removing the old one.
    Tuesday, November 06, 2012 10:49 PM
  • Hi,

    I'm new here and I have the same problem I cannot get VS2012 to connect to TFS Online. keep getting 400 error over and over again. Have spend 3 days trying to get to it. I have a desktop and a laptop, it all gone bad when I add few projects to tfs. Can you so kindly guide how about you fix the problem. 

    Cheers,

    William

    Thursday, August 29, 2013 3:16 AM
  • Hi William,

    Did you try to create a new workspace? (go to Source Control Explorer and choose "Workspaces..." from the Workspace list on the tool bar)

    Best,

    Vlad

    Monday, September 09, 2013 4:34 PM