none
Policy settings prevent opening Internet forms with managed code

    Question

  • Hi:

    I am having infopath issue.  Our users are trying to open infopath forms it comes up with this error. 

    Infopath cannot open the following file \\servername\infopath.xml Infopath cannot open the form.  To fix this problem, contact your system administrator. 

    Detail of the Message

    Form Template: http//.....xsn Infopath cannot open the selected form because of an error in the form's code.  Policy settings prevent opening Internet forms with manged code. 

    I have looked all over the Internet.  I have tried every solution people have suggested.

    1) Access across domain is enabled.

    2) Full-trust option is checked.

    3) Add the trusted domain within the form.  (Within Internet options in Infopath forms)  

    4) I have also done that within Internet Options on the browser. 

    5) Remove code in the form options

    Any ideas. 

    Thanks,

    kkmick

     

     

    Thursday, February 24, 2011 3:15 PM

Answers

  • Hi,

    So there is another problem.
    It can be come from the infopath view that didn't work well.

    I think you have 3 tests to do to understant the problem and correct it:

    • Go to your form option and modify compatibility tab to put the form as "Infopath 2007" type and not "Infopath browser enabled". publish the form and see if you've got the error.
    • Remove all the content of the default view of your infopath form to see if there is not a control or an activex that cause problem.
    • Create a basic form server form with one line of code and publish this form on your server sharepoint. See if this form open well or if you've got the same error.

    With the response of this 3 test, we will find the error.

    Hope this helps.


    Visit my blog : http://rmatayron.blogspot.com/
    • Marked as answer by David HM Friday, March 04, 2011 1:04 AM
    Friday, February 25, 2011 6:53 AM

All replies

  • Hi,

    Have you try to put your SharePoint site into the "Intranet" zone in Internet Explorer?
    If yes, is the problem occur on each machine of your firm?
    If that's right, it could be a GPO on your PC taht restrict the use of InfoPath.

    Hope this helps.


    Visit my blog : http://rmatayron.blogspot.com/
    Thursday, February 24, 2011 5:56 PM
  • Hi Remi

    I have also tried that already.  It is already there.  (The Sharepoint site is in the Intranet zone)  I forgot to put that in on my list.  It is happening on every machine. 

     

    kkmick

     

    Thursday, February 24, 2011 7:01 PM
  • Hi,

    So there is another problem.
    It can be come from the infopath view that didn't work well.

    I think you have 3 tests to do to understant the problem and correct it:

    • Go to your form option and modify compatibility tab to put the form as "Infopath 2007" type and not "Infopath browser enabled". publish the form and see if you've got the error.
    • Remove all the content of the default view of your infopath form to see if there is not a control or an activex that cause problem.
    • Create a basic form server form with one line of code and publish this form on your server sharepoint. See if this form open well or if you've got the same error.

    With the response of this 3 test, we will find the error.

    Hope this helps.


    Visit my blog : http://rmatayron.blogspot.com/
    • Marked as answer by David HM Friday, March 04, 2011 1:04 AM
    Friday, February 25, 2011 6:53 AM
  • I have InfoPath 2010 and I recived the same problem ..,

    I tried all of the above but no news :(


    thank u for help
    Wednesday, December 07, 2011 7:28 PM
  • It worked ..., I changed security ...,

    I changed it to full trusted

    instead of automatic identify

    from developer tap-> Security and trust


    thank u for help
    Wednesday, December 07, 2011 7:40 PM
  • Thank you Tareq.

    It's worked for me!!!

    Sunday, June 10, 2012 5:31 AM
  • This form template is not enabled for viewing in the browser.

    rubbish 

    Saturday, August 11, 2012 1:26 PM