none
WPF Bing maps and slow start times

    Question

  • I have an application that I am writing for Surface 2. When the application starts, it takes a good 18-20 seconds for the map control to get loaded. At this point, the map is not databound to any datasource so there are no pushpins to display, only the map proper. But while the map is getting loaded it is locking up the UI thread during this time so the application is completely unresponsive. If I comment out the map control, it works just fine and loads instantly.

    Furthermore, this application starts almost instanstly on other computers even with the map loaded, it is only slow on the actual Surface unit.

    Any help would be appreciated.

    Thanks


    • Edited by cnosam Monday, March 12, 2012 3:23 PM
    Monday, March 12, 2012 3:23 PM

Answers

  • Then I think it must have to do with the network connection.  Best of luck!

    -Luis.


    Luis Cabrera. Platform Program Manager -- Microsoft Surface @luisito_cabrera Disclaimer: This post is provided "AS IS" with no warranties, and confer no rights.

    Thursday, March 15, 2012 4:15 PM

All replies

  • I would say it depends a lot on hour you are building you map control in order to have it fully ready.
    Next how is your network connection ?
    Do you have any antivirus running or any update going on

    Do you have sample project to reproduce ?

    regards

    serge


    Your knowledge is enhanced by that of others.

    Tuesday, March 13, 2012 7:28 AM
  • The WPF Bing map is owned by the Bing maps team. Let me see if I can find some information for you... If not, we will move this question to the Bing maps forum.

    Thanks!
    Luis Cabrera


    Luis Cabrera. Platform Program Manager -- Microsoft Surface @luisito_cabrera Disclaimer: This post is provided "AS IS" with no warranties, and confer no rights.

    Tuesday, March 13, 2012 8:22 PM
  • I got a hold of the bing maps team, and they have not seen this issue before. Since the map connects to the internet it is possible that there will be a short delay due to the network connection.

    Does this happen the second time you launch your application? Or just the first time? Does it happen in both windows mode and surface mode?

    Thanks!

    -Luis.


    Luis Cabrera. Platform Program Manager -- Microsoft Surface @luisito_cabrera Disclaimer: This post is provided "AS IS" with no warranties, and confer no rights.

    Wednesday, March 14, 2012 7:50 PM
  • I got a hold of the bing maps team, and they have not seen this issue before. Since the map connects to the internet it is possible that there will be a short delay due to the network connection.

    Does this happen the second time you launch your application? Or just the first time? Does it happen in both windows mode and surface mode?

    Thanks!

    -Luis.


    Luis Cabrera. Platform Program Manager -- Microsoft Surface @luisito_cabrera Disclaimer: This post is provided "AS IS" with no warranties, and confer no rights.


    I built a sample surface application that has just the map control in it. I tried it inside and outside of the surface shell. With that application it was really random to how fast it would start. The first time it took maybe 15 seconds. The second time, it was maybe 3. Third would be maybe 10. Then 3, 15, etc. It was all over the place.
    Wednesday, March 14, 2012 9:18 PM
  • Then I think it must have to do with the network connection.  Best of luck!

    -Luis.


    Luis Cabrera. Platform Program Manager -- Microsoft Surface @luisito_cabrera Disclaimer: This post is provided "AS IS" with no warranties, and confer no rights.

    Thursday, March 15, 2012 4:15 PM
  • Hi, I'm having a slow startup issue with the Bing WPF Map Control too. Were you able to determine what caused it?

    Even in an application with just the map control on a center with a zoom, it's painfully slow. I can load a Bing map silverlight instance in a web browser on the same machine in much less time, even while this is trying to load. It is also random for me too, sometimes it's quicker 4 secs or slower 15-20 secs. Does the WPF Map control download a lot more data than the silverlight browser bing? It can't be a network issue, everything else loads very quickly including bing maps in the browser. I also tried disabling the firewall.

    Thanks,

    Andrew

    Tuesday, April 24, 2012 1:37 AM