none
Finding the document specification by message type "<Message>" failed. Verify the schema deployed properly.

    Question

  •  

    Hi

    iam getting Finding the document specification by message type "<Message>" failed. Verify the schema deployed properly Error.

     

    Iam publishing a web service through schemas using " Biztalk web service publishing wizard" . I have created that web service using two schemas naming request and response. Now i have added this as web service reference to another biztalk project in which iam calling this web service and sending a request from my orchestration to this web service and retriving a response from it.

     

    Before adding the web reference it was orchestration was working fine and giving me result.but after adding this web reference iam getting the error like Finding the document specification by message type "<Message>" failed. Verify the schema deployed properly.

    I hope problem is there in web reference.

     

    Can anyone explain me the reason for this and give me a solution.Please.

     

     

    Tuesday, July 29, 2008 10:08 AM

Answers

  •  mercedes_Kranthi wrote:

    Hi Smith,

    Thanks for your reply. But my requirement is to consume a web service not WCF service. So iam trying to publish it through wizard and moreover iam using biztalk server 2006. If you get any info on this, then please let me know. Thanks again.

     
    For the clients the WCF service is the same service as old Web asmx service if you are using the simple HTTP bindings.
    Tuesday, July 29, 2008 4:17 PM

All replies

  • Hi,

     

    If you are using BizTalk 2006 R2, you should probably look at publishing as WCF services rather than web services. The WcfBasicHttp adapter will give you compatibility with regualr ASMX web services, but the newer adapter is more advanced and will give you more configuration options.

     

    It may be worth testing wih the WcfBasicHttp adapter and see if it fixes things.

     

    Regards,

     

    Alan.

     

    Tuesday, July 29, 2008 10:41 AM
  • Hi Smith,

    Thanks for your reply. But my requirement is to consume a web service not WCF service. So iam trying to publish it through wizard and moreover iam using biztalk server 2006. If you get any info on this, then please let me know. Thanks again.

    Tuesday, July 29, 2008 3:15 PM
  •  mercedes_Kranthi wrote:

    Hi Smith,

    Thanks for your reply. But my requirement is to consume a web service not WCF service. So iam trying to publish it through wizard and moreover iam using biztalk server 2006. If you get any info on this, then please let me know. Thanks again.

     
    For the clients the WCF service is the same service as old Web asmx service if you are using the simple HTTP bindings.
    Tuesday, July 29, 2008 4:17 PM
  • Thanks Leonid. I will try this.

    Wednesday, July 30, 2008 5:31 AM