locked
Error authenticating with OData

    Question

  • Howdy! I'm trying to connect to an OData feed. I navigate to it in the browser, it asks for credentials (Basic), I enter them, and then am presented with the metadata for the feed.

    When I try and connect with Data Explorer, I enter the feed url, got to basic, and enter my credentials. When I hit save, it thinks for a second and then tells me my credentials are invalid. I double checked and they are valid. Opened up fiddler, and it doesn't even look like Excel is even trying to authenticate with the server.


    Thanks!

    Monday, June 17, 2013 5:47 PM

All replies

  • After review fiddler logs, it looks like Data Explorer is talking with the server, but the oData feed doesn't seem to happy with the responses.

    Edit: I should note that I'm using NTLM authenticate through IIS.

    Monday, June 17, 2013 6:09 PM
  • I am encountering a similar issue.  I am using Data Explorer which I downloaded from this site.

    http://www.microsoft.com/en-us/download/details.aspx?id=36803

    I am running MS Office Professional Plus 2013 64 bit.  The Data Explorer looked like a good tool to allow a user to filter large data before bringing into Excel; however, we have to have authentication on our OData feed.

    The OData feed works fine with basic authentication when accessed via browser, but when accessed via Data Explorer I get similar behavior.  Is this a bug in Data Explorer?

    I noted some other issues with Data Explorer and OData when testing with a feed that did not use authentication.  Should not use Remove Duplicates as OData does not support distinct.  Also Keep Top and Remove Top filtering failed.

    Thursday, June 20, 2013 8:24 PM