locked
Internet Speed (Slow over WiFi)

    Question

  • Is there anyone else having internet connection issues in Windows 8? I have a home Wifi that usually gets very high internet speeds. However, Windows 8 only seems to get very spotty and slow internet speeds. Most times, the connections will time out. Any else having similar problems?
    Thursday, September 15, 2011 6:24 AM

All replies

  • Hey there,

    Are you still experiencing the same performance issue? How about when connecting via Ethernet?

    Does Windows Update provide an updated NIC driver for your network card?

    Regards,

    Bobby 

    Thursday, September 15, 2011 11:13 PM
    Answerer
  • Still having the problem. I am not even able to complete a connection to WU without it timing out. I'm really baffled here... I feel like I've tried everything!
    Friday, September 16, 2011 4:36 AM
  • I know it seems dumb, but I would totally reset your router. Often, Wi-Fi seems like the first thing to go. The other obvious solution might be updating your driver. What model computer do you have?

    Friday, September 16, 2011 5:02 AM
  • Since the manufacturers have not created drivers for Windows Developers Preview, I suggest you update to the most current Windows 7 driver.
    If that doesn't work, they try to install in compatibility mode.

    For the driver/drivers you downloaded use the compatibility troubleshooter to install them to see if that resolves the problem.
    You can do this by:

    ·         Enter the Start screen

    ·         Move your mouse to the bottom left of the screen to expand the Charms section

    ·         Select Search

    ·         Type Compatibility

    ·         Click Settings in the right column

    ·         Click Run programs made for previous versions of Windows

    ·         Then follow the prompts and direct the troubleshooter to the installer for your computer's driver.

     
    Let us know if this helps.


    Marilyn
    • Proposed as answer by Irfanfare Friday, December 16, 2011 11:55 AM
    Friday, September 23, 2011 12:44 AM
    Moderator
  • Hey mate, I think i have an issue for that :) Try to do like i say.

    1. Go to Control Panel and select Network and Sharing Center.

    2. In left side of window you'll find Change Adapter Settings.

    3. Select it, and you should see screen with connections, find your wifi connection (wich is connected).

    4. Press right mouse button on that connection and select DIAGNOSE. This is troubleshooter and he fix problem if there is any problem. If not I don't know how to help you.

    If it works glad to help :D

     

    Cheers

     

     

    Monday, October 17, 2011 11:30 PM
  • What chipset is your adapter using? If it is a Broadcom WLAN device/chipset, you likely will see that the device is set to use low power nad when you disable this option so it is using a full power mode, it will suddenly start working well with Windows 8. Sometimes you can get the device to work when this is set, but if the machine goes to sleep it is more likely the device will get into a set where windows thinks it is off and there is not any other apparent setting to turn the radio power on.
    Friday, December 16, 2011 7:37 AM
  • Friday, December 16, 2011 11:13 AM