locked
SQL Server 2012 RC0 MDS Configuration Manager, "Number of members to apply business rules to:" edit results in misnomer error message during upgrade from CTP3

    Question

  • We went through upgrade and repair of our MDS database yesterday. The upgrade was on Master Data Services database baked up from SQL Server 2008 R2 with SQL Server Denali CTP3 release Master Data Services used as MDS application. Database was restored on alternate SQL Server 2008 R2 and newly installed Master Data Services for SQL Server 2012 RC0 Configuration Manager was used to upgrade and repair the database. Upgrade and repair Master Data Services appeared to complete free of any error messages, MDS application appeared to function without any issues I could immediately attribute to upgrade itself, hence, for the moment I consider upgrade successful.
    One of the issues we experienced in CTP 3 release was, perhaps more on perception side, timing of validation of business rules. The system level setting number of members considered for business rule was set to 500 ( top limit for CTP 3 ). The feeling shared by the team was the number was small, well below of what SQL Server can handle, and hence, validation was thought of as a slow process. Don't get me wrong. The team has wide experience with maintaining data catalogues using various technologies, and if I can describe in better detail, the perception was that SQL Server was handling in 10 minutes what it should be able to handle in 7 1/2 minutes kind of feeling.
    Seeing 10,000 members applied with business rule for RC0 wizard was a huge plus. I have not tried to tweak this setting when running through "create new" database. However, I did try to change setting when upgrading our Denali CTP3 database, to check how it responds to customization. To my surprise the wizard responded with error message ( an message box ) regarding limit being 1 to 500, matching CTP3 configuration limit values. Yet, when recovered from this message, edited email profile and finally clicked "Apply" button to save settings, the value for "Number of members to apply business rules to:" was still saved as 10,000. The value I tried was 9,999.
    It seems we need to synch up the message, the number of members applied with business rules, and the system setting displayed by the wizard. Without investigating details regarding what is going on under the hood, on the surface the message regarding limit being 1-500 for RC0 appear to me a misnomer, cosmetic issue. I guess to some extent having fresh install and running into cosmetic issue while checking area of particular interest is more of a reason to this message than real technical issues. The product appeared to work well, responds much snappier than CTP3 and overall look and feel is refined. It would be so nice to get detail regarding misnomer error message out of the way.


    Miron
    Sunday, January 01, 2012 1:12 AM

Answers

  • Hi Miron

    This looks like an issue. The default of 10,000 should work well because we've done a fair amount of work between CTP3 and RC to improve business rule validation performance. Unfortunately this bug means that (at least for the time being) you can't use the Configuration application to set the value to anything higher than 500 (even though the default is 10,000).

    Arun


    Arunjeet Singh (Microsoft SQL Server Master Data Services)
    Wednesday, January 04, 2012 12:06 AM

All replies

  • Hi Miron

    This looks like an issue. The default of 10,000 should work well because we've done a fair amount of work between CTP3 and RC to improve business rule validation performance. Unfortunately this bug means that (at least for the time being) you can't use the Configuration application to set the value to anything higher than 500 (even though the default is 10,000).

    Arun


    Arunjeet Singh (Microsoft SQL Server Master Data Services)
    Wednesday, January 04, 2012 12:06 AM
  • Hi,

    I think I will need the log file to get more information about your issue. You can uncomment one line in: c:\Program Files\Microsoft SQL Server\110\Master Data Services\Configuration\MDSConfigTool.exe.config. The line with the LogFileListener. then see if you see any exception details in the log file and send it.

    Dont forget to comment to line again so you will not keep logging forever.

    I found a solution of this issu 

    http://www.techyv.com/questions/sql-server-2012-rc0-error-starting-master-data-configuration-manager

    Monday, February 20, 2012 9:20 AM
  •  Hello paulqandrew,

    To the extent I could follow the link the message reads unrelated to the issue reported. Here is the quote:

     

    Before creating an MDS web application, you must correct the following errors:
    Internet Information Services (IIS) is not configured on this server.
    The required .svc handler mappings are not installed in IIS. For more information, see http://go.microsoft.com/fwlink/?LinkId=226284.
    For web application requirements, see http://go.microsoft.com/fwlink/?LinkId=215355.

     

    Forgive me but could it be you need to report it as a separate issue? The message seems a bit off from message reported here, message reads: "Number of members to apply business rules to:".

    If I missed something, please do let me know.

    Thanks for chiming in.

    Miron.

    Miron

    Tuesday, February 21, 2012 9:12 AM