locked
Canon Printer Driver not working?

    Question

  • This is a bit strange actually, at first just plugged in my printer and Windows 8 recognized it instantly. It didn't even had to install anything.

     

    If i opened the printer status it would say that it could connect to the printer and that its online. But every time i try to print anything i got an error saying that the printer could not be reached and that it is not responding...

    Tried to download the drive from canon itself and the same...

     

    The printer is a ip4600, not sure if others are having the same problem, couldn't find anything on this matter.

    Wednesday, September 21, 2011 7:04 PM

Answers

  • Hi.

     

    Could you please open the Devices and Printers folder, right-click your printer and select Printer Properties. Then look on the Advanced tab, and tell me what driver name is listed in the "Driver" drop-down?  Thanks - that will allow us to repro your issue.

    Wednesday, September 21, 2011 10:01 PM
  •  Weird... tried plugging it into another usb port (i had tried 3 ports already, but there was 1 left that i usually plug my mouse in)... It didn't recognized the installed printer, nor added another one, but when i send anything to print to the supposedly offline printer it went fine XD
    Friday, September 23, 2011 4:48 PM

All replies

  • Hi.

     

    Could you please open the Devices and Printers folder, right-click your printer and select Printer Properties. Then look on the Advanced tab, and tell me what driver name is listed in the "Driver" drop-down?  Thanks - that will allow us to repro your issue.

    Wednesday, September 21, 2011 10:01 PM
  • Of course :P

     

    It's actually the same name of the printer itself:

     

    Canon Inkjet iP4600 Series

     

    Thank you for the quick reply.

    Wednesday, September 21, 2011 11:22 PM
  • Cool - that's the driver from Windows Update. We'll take a look. Thanks for the report.
    Thursday, September 22, 2011 3:03 AM
  •  Weird... tried plugging it into another usb port (i had tried 3 ports already, but there was 1 left that i usually plug my mouse in)... It didn't recognized the installed printer, nor added another one, but when i send anything to print to the supposedly offline printer it went fine XD
    Friday, September 23, 2011 4:48 PM