locked
OpenGL Compatibility support on Win8

    Question

  • I was watching the video from Build by Uday Shivaswamy and he was discussing that windows 8 should already be compatible with most applications. I have an application (game) that I am developing on that works in windows 7 and just tried it on Win8 for kicks. Unfortunately it doesn't seem to work, and I was wondering if it was because it requires OpenGL (although i had heard that OGL should work just fine) or maybe because it requires OpenAL. Either way I would like to get it running on Win8 (albeit not in metro form of course) 

    Is there a way to get in contact with the Compatibility team and see what is going on?


    • Edited by Mayarnel Friday, October 14, 2011 6:25 PM
    Wednesday, October 12, 2011 10:55 PM

Answers

  • So yeah, it was the drivers, I 'updated' to the drivers on intels website 8.15.10.2509  -. Although i think technically they are 'older' than the specific drivers loaded onto the tablet for Build,  OGL is setup and works correctly with these ones and does not with the specialized driver.

    I did have to manually install them because it kept failing the driver installation, and even telling it to 'search in this folder' came back with 'you already have the latest' so it requires you to specifically find the driver, and force it.


    Edit: Also, it may change drivers again on your for whatever reason so you may have to set them back in the future

    Now included a few posts down are the steps I use to manually force a driver.

    This also includes editing the .inf before forcing the drivers to identify that you are on the right OS:

    http://social.technet.microsoft.com/wiki/contents/articles/troubleshoot-compatibility-issues-in-windows-8-developer-preview.aspx

    ...

    tl;dr : edit the inf and retry setup, if that doesnt work keep the modified inf and force the drives with steps below


    • Marked as answer by Mayarnel Friday, October 14, 2011 6:24 PM
    • Edited by Mayarnel Thursday, October 20, 2011 10:36 PM
    Friday, October 14, 2011 6:24 PM

All replies

  • Firstly, I suggest follow steps on:

    http://social.technet.microsoft.com/wiki/contents/articles/troubleshoot-compatibility-issues-in-windows-8-developer-preview.aspx

    If that didn't resolved your problem, then please post some more detail of your application that you have issues and if it possible post following:

    1)Name of software

    2)Vendor

    3)Version

     

    Or just post back as much as you know and Windows Compatibility Team would monitor here and would address it. Since Windows 8 is pre-beta , some compatiblity issues are expected.

    Thursday, October 13, 2011 11:23 AM
  • A few things here. I double checked my app and while I didnt recall it saying so explicitly before, it does indeed complain about not having the right video drivers for OpenGL to work.

    I had checked windows update, but it says its checked for updated and 'installed updates: never". And had previously tried compat mode also to no avail.

    I was reading around a bit and found this article explaining how to modify the INF for the latest intel drivers to install on windows 8

    http://www.eightforums.com/hardware-drivers/2519-intel-hd-graphics-2000-3000-a.html

    Only I try that and it doesnt finish the install. I was using the 8.15.10.2509  drivers. The other fellow was using 2476 (64_8.15.10.2476).  I did get the message where it says they aren't signed, but right after that it would fail. I don't actually have the power adapter for it today, so I was about to try installing them manually when the battery finally went out.

    Edit: Oh and it likes to tell me that my version of .net is outdated (or just wrong?) I'm ignoring that since im just guessing the setup doesnt recognize the .net version running on win8

    ....

    Next things I will try, installing driver manually. Getting the 2476 version and try to use that.



    • Edited by Mayarnel Friday, October 14, 2011 6:47 PM
    Thursday, October 13, 2011 6:03 PM
  • So yeah, it was the drivers, I 'updated' to the drivers on intels website 8.15.10.2509  -. Although i think technically they are 'older' than the specific drivers loaded onto the tablet for Build,  OGL is setup and works correctly with these ones and does not with the specialized driver.

    I did have to manually install them because it kept failing the driver installation, and even telling it to 'search in this folder' came back with 'you already have the latest' so it requires you to specifically find the driver, and force it.


    Edit: Also, it may change drivers again on your for whatever reason so you may have to set them back in the future

    Now included a few posts down are the steps I use to manually force a driver.

    This also includes editing the .inf before forcing the drivers to identify that you are on the right OS:

    http://social.technet.microsoft.com/wiki/contents/articles/troubleshoot-compatibility-issues-in-windows-8-developer-preview.aspx

    ...

    tl;dr : edit the inf and retry setup, if that doesnt work keep the modified inf and force the drives with steps below


    • Marked as answer by Mayarnel Friday, October 14, 2011 6:24 PM
    • Edited by Mayarnel Thursday, October 20, 2011 10:36 PM
    Friday, October 14, 2011 6:24 PM
  • Whoa, just rebooted again and my drivers changed! - so originally i was on the 9.17.10.2482 drivers (dated 8/11/2011), then i updated to 8.15.10.2509 (dated 9/5/2011) (those worked), then mysically after a reboot just now it somehow found some new drivers 9.17.10.2511?? (dated 8/31/2011). The 2511 drivers didnt work either, still gives me an error - different though - says it cant create the GL context (old one said it just wasnt supported)

    Updated back to the 2509 again and my app again works.


    • Edited by Mayarnel Friday, October 14, 2011 6:49 PM
    Friday, October 14, 2011 6:45 PM
  • Mayarnel,

    When you say you 'manually' installed the drivers, what does that entail?

     

    I dug into the downloaded drivers, found the INF file and tried to install that route, no luck. I also tried to search for new drivers via device manager and got the 'you already have the latest...' message as well.

     

    If I run the setup file it says I do not meet system requirements.

     

    Thoughts?

    Thursday, October 20, 2011 3:59 PM
  • So my standard process, which could be shortened if I knew better shortcuts (probably?)

    I go to the metro screen

    Slide from side to get charm bar -> select search

    Search / select 'Control Panel' -> brings up metro UI'd control panel

    Select bottom option 'More Settings' -> takes you to the desktop control panel

    Under 'appearance and personalization' I select 'Adjust screen resolution' -> brings up display 

    Tap 'Advanced settings' in the bottom right -> takes you to graphics adapter

    Tap 'Properties' in the adapter type -> brings up the graphics drivers

    Tap the 'Driver' tab -> gives you all your driver info

    Tap 'Update driver' -> asks you where you want to search

    'Browse my computer for driver software' -> locate and install driver software manually

    NOTE: there is an option here DO NOT 'search for a driver in a location', rather underneath it is the option we want:

    Tap "Let me pick from a list of device drivers on my computer' -> takes you to driver update screen

    IMPORTANT! tap 'Have Disk...' button in bottom right corner of screen (above next/cancel) -> takes you to disk location finder

    Tap "browse" -> opens locate file box

    Browse to location of the inf, I saved the 2509 drivers on my HDD to C:\gfx_drivers

    So the file is located in C:\<downloaded dir>\Graphics\igdlh64.inf

    Select igdlh64.inf and tap 'open' -> browse box will now say for me C:\<driver_dir>\Graphics

    Tap 'OK' -> "Intel(R) HD Graphics Family" will now show in the model window and complain that it is not digitally signed

    Tap 'next' -> driver will install - screen will temp go black for a sec - dont worry it comes back

    - window will tell you that it was successfully installed (hopefully!)

    Tap close -> this will take you back to the 'Intel(R) HD Graphics Family Properties' window with the driver details

     

    Verify that the driver version states 8.15.10.2509

    ?????

    Profit

    ......................

    As a side note my drivers get 'updated' by windows about every day or so? This will pull them back to the 2511 and you'll need to reinstall the drivers using these same steps unless you disable windows updates. I chose not to disable them, as I will forget to check for updates later, so i just fix my drivers every day.

     

     

     

     

     






    • Edited by Mayarnel Thursday, October 20, 2011 4:27 PM
    Thursday, October 20, 2011 4:03 PM
  • Edited:

     

    I was not able to make get my device to work the same way as described, but I did follow the INF edit instructions in the link above and that actually worked for me. I am now on 2509 and have OpenGL...Sweet

     

    Thank you

     


    • Edited by peeklay Thursday, October 20, 2011 8:59 PM
    Thursday, October 20, 2011 7:47 PM
  • Cool, yeah I tried the inf edit originally but the setup still wouldnt work for me, hence the force on the display drivers. (although probably still using the edited INF)
    • Edited by Mayarnel Thursday, October 20, 2011 10:29 PM
    Thursday, October 20, 2011 9:01 PM