none
Biztalk not picking up the file from Receive port/location/directory

    Question

  • I am a rookie on Biztalk and just experimenting...Any help from veterans/experts is wholeheartedly appreciated. Per the tutorial I am running I have done all the steps correctly. the application has compiled and I was able to config & administer it successfully thru BT admin console. I created a sample orchestration using FILE | Pass thru ffor XML file types encoded with UTF-8. When I start the application it is NOT picking up the input file from the input file location. Any idea what I am dooing wrong? Your help is greatly appreciated

    Sunday, July 11, 2010 8:53 PM

Answers

  • Check the Event log.
    Could be a permissions problem on the receive location, or a file mask mismatch, or as Breezy states the host instance is not started.
    (p.s. an in-process Host instance is just a windows service and can be set to start automatically)

    Monday, July 12, 2010 1:32 AM
    Answerer
  • Besides checking that host instance is started and receive location is enabled. Please verify that file is not read only. Read-only or system files are not picked up by the File receive adapter.  

    The File receive adapter also does not pick up files for which it has insufficient rights and files that cannot be exclusively locked. To correct these problems, verify the security settings of the receive location and ensure that any files present are not being held by other processes. Ensure that the service account for the BizTalk Host that picks up the file must have proper permissions

    You can also use the Microsoft FileMon utility to monitor what’s going on.

    Regards,

     

    Monday, July 12, 2010 1:43 AM
  • Hi,

    Please check followings:

    1.  The host instance associated with file adapter receive is running.  Make sure receive location is enabled.

    2. The user associated with host instance has sufficient rights to the file location

    3. The file is not read only.

    4. The correct file path is specified in the receive location.

    5. The correct filter for file extention is applied in receive location configuration i.e if it set as *.txt, then this will not pick xml files.

    6.  Do you see any info in event log?

    Regards,

    Tariq Majeed


    Please mark it as answer if it helps
    Monday, July 12, 2010 2:21 AM

All replies

  • Check that you have started the host instance

    It's seems that the host Instance will not start automatically

    Monday, July 12, 2010 1:22 AM
  • Check the Event log.
    Could be a permissions problem on the receive location, or a file mask mismatch, or as Breezy states the host instance is not started.
    (p.s. an in-process Host instance is just a windows service and can be set to start automatically)

    Monday, July 12, 2010 1:32 AM
    Answerer
  • Besides checking that host instance is started and receive location is enabled. Please verify that file is not read only. Read-only or system files are not picked up by the File receive adapter.  

    The File receive adapter also does not pick up files for which it has insufficient rights and files that cannot be exclusively locked. To correct these problems, verify the security settings of the receive location and ensure that any files present are not being held by other processes. Ensure that the service account for the BizTalk Host that picks up the file must have proper permissions

    You can also use the Microsoft FileMon utility to monitor what’s going on.

    Regards,

     

    Monday, July 12, 2010 1:43 AM
  • Hi,

    Please check followings:

    1.  The host instance associated with file adapter receive is running.  Make sure receive location is enabled.

    2. The user associated with host instance has sufficient rights to the file location

    3. The file is not read only.

    4. The correct file path is specified in the receive location.

    5. The correct filter for file extention is applied in receive location configuration i.e if it set as *.txt, then this will not pick xml files.

    6.  Do you see any info in event log?

    Regards,

    Tariq Majeed


    Please mark it as answer if it helps
    Monday, July 12, 2010 2:21 AM
  • Also check to ensure that the Enable Service Window is not checked and configured for a specific time. This can be found on the Schedule config option on the Receive Location.
    Tuesday, August 30, 2011 5:36 PM
  • Hi Frnds,

    I m too facing similar issue. In my case the biztalk server used to pick select file.

    in my configuration, i mentioned as it pick all xml file like *.xml

    In my case if i m droping fill at receive location, Engine unable to pick all files. I m not able to figure out this uncertain behavious. Could any one let me know what was the issue.

    I opened all file in IE & VS and  there is no problem with them.

    Could any one suggest me what is the issue. In my current case i m using BizTalk server 2006. I havent face this type of issue in last 3 year.. could any one suggest the soluton for the same.

    Thanks,


    • Edited by Singh AK Saturday, April 14, 2012 8:59 AM correction
    Saturday, April 14, 2012 8:55 AM
  • Few things to try IMO

    • Those File which does not get copied, Try to Cut And Paste again in the same folder and see if it makes them to picked by BizTalk
    • Try creating a new folder for receive location and put those files which does not gets copied.
    • If you are sure that you will always gets .xml files in the receive folder, use *.* instead of *.xml and see if it makes a difference?
    • Are those files are read only ? Because BizTalk will not pick them if they are read only? Please check them .

    Also I would suggest you to start a new thread for this issue.


    HTH,
    Naushad Alam

    When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer
    alamnaushad.wordpress.com
    My new TechNet Wiki "BizTalk Server: Performance Tuning & Optimization"


    Saturday, April 14, 2012 9:09 AM
    Moderator
  • Hi  Naushad,

    Cut -paste & other receive location is working fine .

    Even i tested cut paste before,  its working fine... 

    Normally i use to get this type of scenario daily.. Is there is permanent workaroud for the same. I m getting this issue at staging environment.

    Is teh problem is with the machine ... Because the same MSI i m executing at other servers and i haven't this kind of problem in other servers.

    Saturday, April 14, 2012 9:25 AM
  • Normally i use to get this type of scenario daily.. Is there is permanent workaroud for the same. I m getting this issue at staging environment.--> Run MessageBox Viewer on your staging environment. Also check If all the BizTalk SQL Jobs are running or not. What is the size of the BizTalk messagebox and tracking database?  

    HTH,
    Naushad Alam

    When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer
    alamnaushad.wordpress.com
    My new TechNet Wiki "BizTalk Server: Performance Tuning & Optimization"

    Saturday, April 14, 2012 9:33 AM
    Moderator
  • Hi Naushad,

    The size of tracking database is 2.1 GB.

    I m unable to run the Messagebox viewer. As i have to run the command on client environmen. And we use to access that through SSL VPN. And i unable to move Exe to the staging environment.

    As per you may i know what may be the possible issues....  so that i could discuss teh things with client and propose valid scenario, so may they will allow to run the messagebox viewer exe on the server. that.. 

    Thanks,

    Saturday, April 14, 2012 10:30 AM
  • Hi 

    Yes, I think You should propose first thing to run the  MessageBoxViewer tool to client. That can report if there are anything wrong in the env. This seems like environment issue rather than application issue.


    HTH,
    Naushad Alam

    When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer
    alamnaushad.wordpress.com
    My new TechNet Wiki "BizTalk Server: Performance Tuning & Optimization"

    • Proposed as answer by Singh AK Saturday, April 14, 2012 10:52 AM
    Saturday, April 14, 2012 10:47 AM
    Moderator
  • Thanks Naushad.

    Sure i will try to run MessageBox Viewer  by consulting the client.

    Thanks for your gr8 help.

    Saturday, April 14, 2012 10:53 AM