none
.Net Frame Work Possibly Corrupt

    Question

  • My computer seized up and became unresponsive yesterday while playing a game.  I had to hard reboot, and it happened again (froze) with an error message that my .net framework was possibly corrupt.  I booted into safe mode and restarted,  was able to run the windows 7 os fine, accessed my files and games etc, but still got the error message.  I attempted to re install the .net frame work, first turning it off in the control panel, but find the setup fails each time and i get the following report.  I have also had a few additional issues since this has occurred.  Microsoft is unable to check for updates to existing problems, and I am unable to update my Nvidea control panel and drivers due to a run time error.

    The error report is below, please advise and thanks in advance for any assistance.

    I should also note, i tried to system restore, it was successful, but did not fix the issue

    [08/26/13,23:47:14] VS Scenario: [2] CSupportedPlatformCheck failed : You must use "Turn Windows features on or off" in the Control Panel to install or configure Microsoft .NET Framework 3.5 SP1.

    [08/26/13,23:47:14] VS Scenario: [2] Failed to pass the Warnings/Blocks checks in CVSScenario::Start()

    [08/27/13,00:02:49] VS Scenario: [2] CSupportedPlatformCheck failed : You must use "Turn Windows features on or off" in the Control Panel to install or configure Microsoft .NET Framework 3.5 SP1.

    [08/27/13,00:02:49] VS Scenario: [2] Failed to pass the Warnings/Blocks checks in CVSScenario::Start()

    [08/27/13,00:20:18] Microsoft .NET Framework 3.5 (x64) 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 (x64) 'package'. MSI returned error code 1603

    [08/27/13,00:20:35] Microsoft .NET Framework 3.0SP1 (x64) (CBS): [2] CBS Component is marked to be uninstalled but CBSPackageName is not authored - CCBSComponent::SetManager()

    [08/27/13,00:20:35] Microsoft .NET Framework 3.0SP1 (x64) (CBS): [2] CBS Component can't be uninstalled as CBSPackageName is not authored - CCBSComponent::SetManager()

    [08/27/13,00:21:00] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 (x64) 'package' is not installed.

    [08/27/13,00:25:44] VS Scenario: [2] CSupportedPlatformCheck failed : You must use "Turn Windows features on or off" in the Control Panel to install or configure Microsoft .NET Framework 3.5 SP1.

    [08/27/13,00:25:44] VS Scenario: [2] Failed to pass the Warnings/Blocks checks in CVSScenario::Start()

    [08/27/13,00:31:48] Microsoft .NET Framework 3.5 (x64) 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 (x64) 'package'. MSI returned error code 1603

    [08/27/13,00:32:20] Microsoft .NET Framework 3.0SP1 (x64) (CBS): [2] CBS Component is marked to be uninstalled but CBSPackageName is not authored - CCBSComponent::SetManager()

    [08/27/13,00:32:20] Microsoft .NET Framework 3.0SP1 (x64) (CBS): [2] CBS Component can't be uninstalled as CBSPackageName is not authored - CCBSComponent::SetManager()

    [08/27/13,00:32:45] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 (x64) 'package' is not installed.

    [08/27/13,06:38:30] VS Scenario: [2] CSupportedPlatformCheck failed : You must use "Turn Windows features on or off" in the Control Panel to install or configure Microsoft .NET Framework 3.5 SP1.

    [08/27/13,06:38:30] VS Scenario: [2] Failed to pass the Warnings/Blocks checks in CVSScenario::Start()

    [08/27/13,06:44:30] Microsoft .NET Framework 3.5 (x64) 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 (x64) 'package'. MSI returned error code 1603

    [08/27/13,06:44:45] Microsoft .NET Framework 3.0SP1 (x64) (CBS): [2] CBS Component is marked to be uninstalled but CBSPackageName is not authored - CCBSComponent::SetManager()

    [08/27/13,06:44:46] Microsoft .NET Framework 3.0SP1 (x64) (CBS): [2] CBS Component can't be uninstalled as CBSPackageName is not authored - CCBSComponent::SetManager()

    [08/27/13,06:45:01] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 (x64) 'package' is not installed.

    [08/27/13,06:59:19] Microsoft .NET Framework 3.5 (x64) 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 (x64) 'package'. MSI returned error code 1603

    [08/27/13,06:59:22] Microsoft .NET Framework 3.0SP1 (x64) (CBS): [2] CBS Component is marked to be uninstalled but CBSPackageName is not authored - CCBSComponent::SetManager()

    [08/27/13,06:59:22] Microsoft .NET Framework 3.0SP1 (x64) (CBS): [2] CBS Component can't be uninstalled as CBSPackageName is not authored - CCBSComponent::SetManager()

    [08/27/13,06:59:23] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 (x64) 'package' is not installed.


    • Edited by Fraynetrain Tuesday, August 27, 2013 1:34 PM
    Tuesday, August 27, 2013 1:33 PM

All replies

  • Please use this tool to verify your .NET Framework(s):

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with .NET Framework 3.5 selected, then post the first 15 lines AND the LAST 15 lines of the tool log here.

    Reading the error messages you posted, it appears that you are running Windows 7. Is that correct? If so, is your OS updates with SP1?

    As .NET Framework repair procedures differ depending on the Windows version, we will proceed once the information requested above is provided.

    Tuesday, August 27, 2013 1:48 PM
  • I am running windows 7 home premium service pack one, and have windows update up to date

    First 15

    ======================================================================
    [08/28/13,20:43:07] Beginning of new SetupVerifier activity logging session
    [08/28/13,20:43:07] Activity log file location: C:\Users\Owner\AppData\Local\Temp\setupverifier_main_08-28-13_20.43.07.txt
    [08/28/13,20:43:07] Error log file location: C:\Users\Owner\AppData\Local\Temp\setupverifier_errors_08-28-13_20.43.07.txt
    [08/28/13,20:43:07] Build created on September 10, 2012
    [08/28/13,20:43:07] Detected operating system: Windows 7 (x64)
    [08/28/13,20:43:07] For more information about repairing the .NET Framework, see http://support.microsoft.com/kb/2698555 and http://go.microsoft.com/fwlink/?LinkID=246062
    [08/28/13,20:43:07] Install state for .NET Framework 1.0: not installed.
    [08/28/13,20:43:07] Install state for .NET Framework 1.1: not installed.
    [08/28/13,20:43:07] Install state for .NET Framework 2.0: installed with service pack 2.
    [08/28/13,20:43:07] Install state for .NET Framework 3.0: installed with service pack 2.
    [08/28/13,20:43:07] Install state for .NET Framework 3.5: installed with service pack 1.
    [08/28/13,20:43:07] Install state for .NET Framework 4 Client: installed with no service packs.
    [08/28/13,20:43:07] Install state for .NET Framework 4 Full: installed with no service packs.
    [08/28/13,20:43:07] Install state for .NET Framework 4.5: not installed.
    [08/28/13,20:43:07] Windows directory: C:\Windows

    Last 15

    [08/28/13,20:43:19] Section [Registry GE - .NET Framework 3.5 SP1 (Wow6432Node)] - stop parsing entries
    [08/28/13,20:43:19] Section [Files - .NET Framework 3.0 SP1AndLater (Common)] - start parsing entries
    [08/28/13,20:43:19] Section [Files - .NET Framework 3.0 SP1AndLater (Common)] - stop parsing entries
    [08/28/13,20:43:19] Processing custom action 'Custom Action - .NET Framework 2.0 test application'
    [08/28/13,20:43:19] ExecutablePath = 'Netfx20TestApplication.exe'
    [08/28/13,20:43:19] FriendlyName = '.NET Framework 2.0 test application'
    [08/28/13,20:43:19] TimeoutSeconds = '300'
    [08/28/13,20:43:19] WaitOnExit = 'true'
    [08/28/13,20:43:19] Silent = 'true'
    [08/28/13,20:43:19] Launching process 'Netfx20TestApplication.exe' now
    [08/28/13,20:43:19] Process successfully launched. Waiting 300 seconds for it to complete.
    [08/28/13,20:43:19] Process 'Netfx20TestApplication.exe' exited with return code 0
    [08/28/13,20:43:19] Not running action 'Files - .NET Framework netfxperf.dll' for product '.NET Framework 3.5 SP1' because the OS condition does not match
    [08/28/13,20:43:19] Verification succeeded for product .NET Framework 3.5 SP1

    Thursday, August 29, 2013 1:46 AM
  • Your .NET Framework 3.5 verifies as correctly installed and configured.

    From the log: "Process 'Netfx20TestApplication.exe' exited with return code 0".

    As .NET 3.5 is an extension of 2.0, this means your .NET 2.0, 3.0 and 3.5 are all OK.

    Do you know for sure what .NET version your game requires? If it possibly needs .NET 4.0, you can repeat the verification process for 4.0.

    If 4.0 checks out as well, you'll need to contact tech support for the game in question for further assistance.

     

    Thursday, August 29, 2013 1:08 PM
  • I believe i re installed .net 4.0 last night and the installation ran smoothly.

    My issue is upon loading windows on a fresh reboot, i get an error message about the framework being corrupt as a program "curse client" fails to load.  This isn't as much of an issue as that program is not very important, but my computer has been crashing when trying to run both World of Warcraft and Google Chrome at the same time, although each time it does this it seems to be random, rather than something that occurs each time.  Could this be related to something else?  Sorry if i am way off here, not the most computer literate.

    Thursday, August 29, 2013 1:46 PM
  • Did you check your .NET 4.0 with the verification tool?

    Please run the tool with .NET 4.0 selected, then post the LAST 15 lines of the tool log here.

    If you can install .NET 4.0 successfully, then it becomes corrupt after a reboot, you have OS issues that normally require OS reinstallation to cure.

    If your 4.0 does not show as corrupt, try removing, then reinstalling the failing program "curse-client".

    Saturday, August 31, 2013 3:03 PM