none
Menustrips keeps resetting position to lefthand corner?

    Question

  • Every time I save and close my application and reopen it, most of the menustrips has had their position reset. It's driving me cracy as I have about 20 of them, and manually putting them back in place is a lot of work.

    Was searching both here and on google and couldn't find any similar problems. Has anyone encountered this problem before or does anyone have an idea to a solution?

    Regards
    Martin
    Friday, January 10, 2014 8:06 AM

Answers

All replies

  • Hi,

    Welcome to MSDN.

    In order to make this issue clear, you could share more information with us.

    >>Every time I save and close my application and reopen it, most of the menustrips has had their position reset.

    1. Do you mean you save the changes and reopen it with Visual Studio? If so, have you saved it by pressing "Ctrl+Shift+S" or by "File->Save All" ?

    2. How the position be resetted? you could share the information by sharing the images of the positions before saving and after saved.

    If you are not able to post images, you could upload them to http://sdrv.ms/1affYwh.

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, January 13, 2014 2:54 AM
    Moderator
  • Yea in Visual Basic. I "save all" and close, then reopen it in Visual Basic.
    Once I choose to show the design, the menustrips that is in different places of the app, all goes to the very upper lefthand corner, either of the application or it's assigned groupbox.
    Monday, January 13, 2014 5:06 AM
  • Are you setting the MenuStrip's Dock setting to None? After reopening the project, what is the Dock setting for them? What is the Location's X and Y after opening it?
    Have you modified your InitializeComponent method?
    Monday, January 13, 2014 5:47 AM
  • Are you setting the MenuStrip's Dock setting to None? After reopening the project, what is the Dock setting for them? What is the Location's X and Y after opening it?
    Have you modified your InitializeComponent method?

    Hi,

    I marked the reply of Jayson as answer, since it shows the way checking these settings to solve this issue.

    In addition, you could reset these settings to test.

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, January 20, 2014 5:58 AM
    Moderator