none
The partner transaction manager has disabled its support for remote/network transactions

    Question

  • Hi People,

    I developed a .net 2.0 windows applications using TransactionScope. Client applications access a MSDE database on server via LAN. The program works fine when I tested on my own computer where database is on the same machine. But when I deployed database to the server, I got a message "The partner transaction manager has disabled its support for remote/network transactions Exception from HRESULT: 0x8004D025".

    I did some google search and tried to turn on the network access checkboxes in component services on the server, but problem persists.

    Can anyone help? Thanks.

    Eric

    Thursday, February 02, 2006 2:29 AM

Answers

  • First verify the "Distribute Transaction Coordinator" Service is
    running on both database server computer and client computers
    1.      Go to "Administrative Tools > Services"
    2.      Turn on the "Distribute Transaction Coordinator" Service if it is not running

    If it is running and client application is not on the same computer as
    the database server, on the computer running database server
    1.      Go to "Administrative Tools > Component Services"
    2.      On the left navigation tree, go to "Component Services > Computers
    > My Computer" (you may need to double click and wait as some nodes
    need time to expand)
    3.      Right click on "My Computer", select "Properties"
    4.      Select "MSDTC" tab
    5.      Click "Security Configuration"
    6.      Make sure you check "Network DTC Access", "Allow Remote Client",
    "Allow Inbound/Outbound", "Enable TIP" (Some option may not be
    necessary, have a try to get your configuration)
    7.      The service will restart
    8.      BUT YOU MAY NEED TO REBOOT YOUR SERVER IF IT STILL DOESN'T WORK
    (This is the thing drove me crazy before)

    On your client computer use the same above procedure to open the
    "Security Configuration" setting, make sure you check "Network DTC
    Access", "Allow Inbound/Outbound" option, restart service and computer
    if necessary.

    On you SQL server service manager, click "Service" dropdown, select
    "Distribute Transaction Coordinator", it should be also running on
    your server computer.

    Hope it helps,

    Eric
    Wednesday, February 22, 2006 3:18 AM
  • Hi,

    It's me again. I just found that not only restart the service but also you need to reboot the server in order for this to work.

    Eric

    Friday, February 03, 2006 7:11 AM

All replies

  • Hi,

    It's me again. I just found that not only restart the service but also you need to reboot the server in order for this to work.

    Eric

    Friday, February 03, 2006 7:11 AM
  • Hi Eric (morningsunshine)

     

    I'm also getting the same error. Could you please help me to fix the problem. You had said you made some changes to the server component , could you describe me the step by step procedure.

     

    Thank You

    Nitu

     

    Tuesday, February 21, 2006 9:24 PM
  • First verify the "Distribute Transaction Coordinator" Service is
    running on both database server computer and client computers
    1.      Go to "Administrative Tools > Services"
    2.      Turn on the "Distribute Transaction Coordinator" Service if it is not running

    If it is running and client application is not on the same computer as
    the database server, on the computer running database server
    1.      Go to "Administrative Tools > Component Services"
    2.      On the left navigation tree, go to "Component Services > Computers
    > My Computer" (you may need to double click and wait as some nodes
    need time to expand)
    3.      Right click on "My Computer", select "Properties"
    4.      Select "MSDTC" tab
    5.      Click "Security Configuration"
    6.      Make sure you check "Network DTC Access", "Allow Remote Client",
    "Allow Inbound/Outbound", "Enable TIP" (Some option may not be
    necessary, have a try to get your configuration)
    7.      The service will restart
    8.      BUT YOU MAY NEED TO REBOOT YOUR SERVER IF IT STILL DOESN'T WORK
    (This is the thing drove me crazy before)

    On your client computer use the same above procedure to open the
    "Security Configuration" setting, make sure you check "Network DTC
    Access", "Allow Inbound/Outbound" option, restart service and computer
    if necessary.

    On you SQL server service manager, click "Service" dropdown, select
    "Distribute Transaction Coordinator", it should be also running on
    your server computer.

    Hope it helps,

    Eric
    Wednesday, February 22, 2006 3:18 AM
  • Hi Eric(morningsunshine)
           Thanks for your help it was really great solution provided by you and  it definitely saved Complete day of work, I was getting the error for very long time back now it got resolved and we are using the seperate database server. One thing  after following  your steps I restrated the client  machine only then it worked properly.

    Regards
    Ronytabh Pramanik.

    Thursday, February 23, 2006 11:07 AM
  • Hi,

    I plan using transaction scopes in my app. I am developing on a Win XP Prof. SP2 machine with SQL Server Personnel Edition. And I couldn't find how to enable MSDTC on my computer. I have to make this because i get an exception telling "no MSDTC avail on Computer". So I tried to start that service but couldn't find the service entry called MSDTC or DTC. Does MSDTC comes  with Sql Server Enterprise-Standart  edition? Or it is part of OS? Any help is appreciated.

     

    Best regards,

    Slm.

    Thursday, March 23, 2006 3:33 PM
  • I had the same problem.
    Exselent solution.
    Many STHANKS!!!

    Monday, April 10, 2006 10:21 PM
  • Hi Eric,
    Thanks for your help. But I get another error:

    "The transaction has already been implicitly or explicitly committed or aborted (Exception from HRESULT: 0x8004D00E)"

    Can anyone help me?!

    Monday, May 15, 2006 8:34 AM
  • Hi,

    I actually also encountered this problem from time to time on my developing machine, while never on client computer. What I did was find the MSDTC service and do a restart on that service and that seems to work for me. I think there must be a configuration issue somewhere.

    Anyone knows the true reason for this will be appreciated.

    Eric

     

    Thursday, May 18, 2006 10:34 PM
  • Hi Ngoc Luu,

    We had the same problem, turned out to be the transaction timing out.

    Hope it helps.

     

    -T

     

     

    Saturday, May 20, 2006 8:24 PM
  •  It worked.

    Thanks.

    Thursday, August 24, 2006 9:12 PM
  • Unfortunately this did not work for me. All settings are the same on the client and on the remote server. Everything rebootet, service is running on both machines. But I allways get this timeout error. Any other idea what I could try?

    Friday, October 20, 2006 9:24 AM
  • Hi Eric,

    i was so happy when i read ur post beacuse its about my problem, but i still have problems and hope u can help me.

    first, the option u specify does not exist on the server im working on (running windows server 2000) although it does exist on my computer (client machine) which is running windows xp. unfortuntly thats not the only problem since we will host the web application on a shared company server (not ours) i cant control the properities of that server. can u help me in this please.

    thanx & regards

    Ghassan

    Thursday, December 07, 2006 8:26 AM
  • Hi Ghassa,

    I think in order to use this transaction approach you need to configure the server. Can you try to get the IT administrator to do this? Otherwise, I suggest you just use the standard transaction management approach, which is a transaction object on your data connection object. This is widely used.

    Cheers,

    Eric

    Tuesday, December 12, 2006 5:58 AM
  • Hi Eric,

    thanx for your concern, the problem was that im using the standard transaction & have no idea why this message appears to me, and as i said before our server  run windows server 2000 and not 2003 so i cant do like you did, by the way the problem solved, it was something in the communication between my computer and the server, so i adjust the firewall settings and have no problem now.

    thanx again,

    Ghassan

    Thursday, December 14, 2006 12:52 PM
  • Thanks a lot.
    Monday, March 12, 2007 1:03 PM
  • Note for VISTA users.

    On the client computer to get to the equivelent settings:

    1     Run dcomcnfg
    2
         
    Expand the “Component Services” node, then the “My Computer” node, then the “Distributed Transaction Coordinator” node
    3
          
    Right-Click on the “Local DTC” node and select “Properties”
    4
         
    On the “Local DTC Properties”, select the “Security” tab
    5
         
    Select Network DTC Access, Allow Inbound, Allow Outbound, No Authentication Required, and Enable XA Transactions
    • Proposed as answer by Sravanthi M Thursday, May 23, 2013 5:35 AM
    Monday, May 21, 2007 1:54 AM
  • Hi Eric,
    I have my SQL Server 2000 running on a Windows 2000 Server. How do I configurate Windows 2000? Because I cannot see "Security Configuration", it is only available on my Win XP client machine.

     morningsunshine wrote:
    First verify the "Distribute Transaction Coordinator" Service is
    running on both database server computer and client computers
    1.      Go to "Administrative Tools > Services"
    2.      Turn on the "Distribute Transaction Coordinator" Service if it is not running

    If it is running and client application is not on the same computer as
    the database server, on the computer running database server
    1.      Go to "Administrative Tools > Component Services"
    2.      On the left navigation tree, go to "Component Services > Computers
    > My Computer" (you may need to double click and wait as some nodes
    need time to expand)
    3.      Right click on "My Computer", select "Properties"
    4.      Select "MSDTC" tab
    5.      Click "Security Configuration"
    6.      Make sure you check "Network DTC Access", "Allow Remote Client",
    "Allow Inbound/Outbound", "Enable TIP" (Some option may not be
    necessary, have a try to get your configuration)
    7.      The service will restart
    8.      BUT YOU MAY NEED TO REBOOT YOUR SERVER IF IT STILL DOESN'T WORK
    (This is the thing drove me crazy before)

    On your client computer use the same above procedure to open the
    "Security Configuration" setting, make sure you check "Network DTC
    Access", "Allow Inbound/Outbound" option, restart service and computer
    if necessary.

    On you SQL server service manager, click "Service" dropdown, select
    "Distribute Transaction Coordinator", it should be also running on
    your server computer.

    Hope it helps,

    Eric
    Thursday, June 07, 2007 3:03 PM
  • Hi...
    I have implemeted transaction service on my local system using Compensatabletransactionscope Activity...
    i have done the changes in Administrative tools..
    but still problem persists... iam using sqlserver2000.
    pls guide me.


    Friday, June 08, 2007 5:27 AM
  • thanks, it work!!
    Friday, August 03, 2007 1:58 PM
  • Hi Eric,

                I too got the same error. I did all the procedure as u mentioned before.still it shows the same error.Can u pls help me out in this regard

    Wednesday, September 05, 2007 5:25 AM
  • This helped a lot.  It worked the first time. Thank You

     

    Monday, October 08, 2007 8:11 PM
  •  

    This post is very useful.
    Thursday, November 08, 2007 8:50 AM
  • Hi Hardy,

    did you solve your problem with your Windows 2000 Server?
    I have the same problem.
    Using TransactionScope in a .NET App on WinXP client -> SQL2000 on Win2000
    Could turn out to be firewall problem...

    Any help is greatly appreciated!

    Stefan
    Tuesday, December 04, 2007 10:04 AM
  • Hello,

     

    I'm not able to find any tab or button named "Security Configuration" under "MSDTC" tab as mentioned in 5th point, My OS is Win2000 Server and I'm using SQL Server 2005.

     

    Please help me as I'm alos facing the same problem. As I'm configuring "Transactional publication with updatable subscriptions".

     

    Thanks in Advance.

     

    Rohit

    Wednesday, March 19, 2008 9:37 AM
  • Eric,

     

    Just wanted to say thanks for the post. I was having this same problem and your solution post definitely saved me a lot of time trouble shooting.

     

    Thanks again,

    Larry

     

     

    Friday, April 04, 2008 8:26 PM
  • Thank you very much.

    Your solution is great.

     

    Regards.

     

    Joaquín Tribaldos

     

    Thursday, May 08, 2008 11:19 AM
  • Hi Eric,

        I have done all the above settings i restart my system(xp proffessional),sql2005 express Both resisded in the same machine. still the problem presists could you please help me out to resolve the issue.

    Thanks
    vijay
    Wednesday, June 18, 2008 6:12 AM
  • YES!!  Thank you!  I have spent several hours trying to fix the error message, crawling the web for answers and trying all sorts of things.  But THIS worked!!  Thanks a ton.  I also had to restart the computer running the remote database in order for the settings to take effect... however I did NOT need to restart the local (client) database machine.  I will point some people to this solution.

     

    Thursday, June 26, 2008 6:46 PM
  • I recently had to install commerce server 2002 talking to SQL Server 2005 on a separate server, I did this many times and had several problems, but this time I had a different problem, My pipeline was failing and event log shows some transaction related error. I compared my MSDTC settings on other servers where Commerce Server was installed and running fine. After search for half a day I finally found your post on it, and the second point in your post actually did the magic, i.e., restarting the Distribute Transaction Coordinator on SQL Server, finally fixed my problem.

    Here is the error log message, which got fixed by your post.

    Event Type:    Error
    Event Source:    Commerce Server 2002
    Event Category:    None
    Event ID:    4104
    Date:        9/24/2008
    Time:        1:48:28 PM
    User:        N/A
    Computer:    XXXXXXXX
    Description:
    Pipeline Error: Component Execution failed for component[0x3]  hr: 0x8004E003
    ProgID: Commerce.RedeemPromoCodes
    Exception of type 'System.EnterpriseServices.TransactionProxyException' was thrown.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Thanks a lot for your posting....I appreciate the help

    Kiran Bheemarti

    Wednesday, September 24, 2008 6:14 PM
  •  

    I just had this error. And restarting MSDTC and the server did not help.

     

    I learned that the same sqlConnection reference must be reused for all operations within the transaction scope.

     

    The methods below utilize Microsofts SqlHelper class. The connection is closed automatically after each operation is completed.

     

    WORKING EXAMPLE:

     

    c = SharedDAL.GetSqlConnection()

    Using scope As New TransactionScope()

    c.Open()
    newEntryID = CreateEntry(fileName, url, accountID, c)
    columns.Save(newEntryID, c)
    scope.Complete()

    End Using

     

    NON WORKING EXAMPLE:

     

    c = SharedDAL.GetSqlConnection()

    Using scope As New TransactionScope()

    c.Open()
    newEntryID = CreateEntry(fileName, url, accountID, c)
    columns.Save(newEntryID, SharedDAL.GetSqlConnection())
    scope.Complete()

    End Using

     

     

    I do not know why it was an issue with my code. Since Micrsofts example is clearly using two different connections.

    http://msdn.microsoft.com/en-us/library/system.transactions.transactionscope.aspx

    Thursday, October 02, 2008 8:04 PM
  • It is of great help to me !!!

    Thanks eric

    -

    paniraj n

    Friday, October 17, 2008 12:30 PM
  • Hello,

    Would you have an idea of all the security implication that kind of manipulation has?

    And thanks, it solved my problem but I do hope it is not going to be too much of a security hole.

    Best regards
    Wednesday, December 17, 2008 7:58 AM
  • Chyzo, to which part of thread do you refer when you asking your question? What kind of manipulation you are concerned about?
    Val Mazur (MVP) http://www.xporttools.net
    Wednesday, December 17, 2008 11:21 AM
  • Hello All,

    I work in an environment where my SQL 2005 Servers are managed by a different department, and they have decided that allowing "Network DTC Access" in Component Services is not something they want to support.

    My questions are:

    1. Is there another way to get this functionality to work?
    2. If the answer to my first question is "No", is another way to get a single transaction to span two or more connection objects?

    thanks,

    theBoringCoder @ Work

    Monday, March 09, 2009 5:14 PM
  • If I am not mistaken, in a case of SQL Server 2005 if you are using TransactionScope in your code to wrap your transaction and if all the connections to database server inside of this transaction point to the same server, then provider automatically promotes transaction to local mode, which might work in your case.
    Val Mazur (MVP) http://www.xporttools.net
    Wednesday, March 11, 2009 10:05 AM
  • Hi I am using Windows server 2008 R2 x64 and SQL Server. I had the same problem with commit transaction on distributed SQL for linked servers. I made the MSDTC option in Component services and restarted my servers but I still have problem. The message now has changed to following:

     

    OLE DB provider "SQLNCLI10" for linked server "MY_LINKED_SERVER" returned message "No transaction is active.".

     

    Any idea?

    Monday, June 21, 2010 1:51 AM
  • I was having the same problem as you because my servers was not on the same domain. What resolved my problem was to select No Authentication Required in MSDTC option on both servers.

    Thursday, July 22, 2010 3:55 PM
  •  

    The operation could not be performed because OLE DB provider "SQLNCLI" for 

     

    linked server "SMSSVR\SQLEXPRESS" was unable to begin a distributed 

     

    transanction.

     

    help me guys


    Monday, September 20, 2010 9:30 AM
  • It worked.

    I have not restarted computer

    Kumsi


    Kumsi
    Thursday, September 23, 2010 4:38 PM
  • Hi,

    System reboot is not required actually

    i have found article which gives you better understanding which option you required according to setup or environment

    http://msdn.microsoft.com/en-us/library/aa561924(v=bts.20).aspx

    Thanks!!!
    Varinder Sandhu http://varindersandhus.blogspot.com/
    • Proposed as answer by Varinder Sandhu Wednesday, December 22, 2010 1:09 PM
    Wednesday, December 22, 2010 1:09 PM
  • Thanks MorningSunShine.... your suggestion worked for me.
    Wednesday, December 22, 2010 2:10 PM
  • First verify the "Distribute Transaction Coordinator" Service is running on both database server computer and client computers
    1.      Go to "Administrative Tools > Services"
    2.      Turn on the "Distribute Transaction Coordinator" Service if it is not running

    If it is running and client application is not on the same computer as the database server, on the computer running database server

    Run dcomcnfg
    1.      Go to "Administrative Tools > Component Services"
    2.      On the left navigation tree, go to "Component Services > Computers
    > My Computer" (you may need to double click and wait as some nodes need time to expand)
    3.      Right click on "My Computer", select "Properties"
    4.      Select "MSDTC" tab
    5.      Click "Security Configuration"
    6.      Make sure you check "Network DTC Access", "Allow Remote Client",
    "Allow Inbound/Outbound", "Enable TIP" (Some option may not be necessary, have a try to get your configuration)
    7.      The service will restart
    8.      BUT YOU MAY NEED TO REBOOT YOUR SERVER IF IT STILL DOESN'T WORK

    Thanks Shiven:)
    • Proposed as answer by S Kumar Dubey Thursday, July 28, 2011 5:34 AM
    Friday, February 25, 2011 10:38 AM
  • Thanks morningsunshine Users Medals Users Medals Users Medals Users Medals Users Medals its working....
    Tuesday, March 15, 2011 2:42 PM
  • Hello there,

    I agree that this link is very usefull:

    http://msdn.microsoft.com/en-us/library/aa561924(v=bts.20).aspx

    After setting up MSDTC on both servers, my call to stored procedure on other server didn't work.

    There was same error "The partner transaction manager has disabled its support for remote/network transactions Exception from HRESULT: 0x8004D025"

    I realize that there was a few problems:

    1. Couldn't ping remote server (Setup for WINS server wasn't OK).

    2. Firewall on remote server disallowed connections (so I had to enable DTC ports (TCP IN/OUT))

    3. I didn't have to restart servers.

    I hope this would be helpfull for someone.

    Regards

    Wednesday, March 30, 2011 7:02 AM
  • Hi Ngoc Luu,

    We had the same problem, turned out to be the transaction timing out.

    Hope it helps.

     

    -T

     

     


    That was the problem that I ran into as well. I'm glad to see it worked out, wonderful advice by morningsunshine.  This is exactly why I come here. I have been to many forums over the past 5 years or so and I find this one to be extremely informative. One can find a great bit of education when it comes to Microsoft technology or even help with most any career you may have studied. Most careers today almost all involve some sort of software technology.

    Wednesday, June 29, 2011 4:59 AM
  • First verify the "Distribute Transaction Coordinator" Service is
    running on both database server computer and client computers
    1.      Go to "Administrative Tools > Services"
    2.      Turn on the "Distribute Transaction Coordinator" Service if it is not running

    If it is running and client application is not on the same computer as
    the database server, on the computer running database server
    1.      Go to "Administrative Tools > Component Services"
    2.      On the left navigation tree, go to "Component Services > Computers
    > My Computer" (you may need to double click and wait as some nodes
    need time to expand)
    3.      Right click on "My Computer", select "Properties"
    4.      Select "MSDTC" tab
    5.      Click "Security Configuration"
    6.      Make sure you check "Network DTC Access", "Allow Remote Client",
    "Allow Inbound/Outbound", "Enable TIP" (Some option may not be
    necessary, have a try to get your configuration)
    7.      The service will restart
    8.      BUT YOU MAY NEED TO REBOOT YOUR SERVER IF IT STILL DOESN'T WORK
    (This is the thing drove me crazy before)

    On your client computer use the same above procedure to open the
    "Security Configuration" setting, make sure you check "Network DTC
    Access", "Allow Inbound/Outbound" option, restart service and computer
    if necessary.

    On you SQL server service manager, click "Service" dropdown, select
    "Distribute Transaction Coordinator", it should be also running on
    your server computer.

    Hope it helps,

    Eric


    Thanks a lot :) that worked great!!

    Sam

    Wednesday, July 27, 2011 9:53 AM
  • First verify the "Distribute Transaction Coordinator" Service is
    running on both database server computer and client computers
    1.      Go to "Administrative Tools > Services"
    2.      Turn on the "Distribute Transaction Coordinator" Service if it is not running

    If it is running and client application is not on the same computer as
    the database server, on the computer running database server
    1.      Go to "Administrative Tools > Component Services"
    2.      On the left navigation tree, go to "Component Services > Computers
    > My Computer" (you may need to double click and wait as some nodes
    need time to expand)
    3.      Right click on "My Computer", select "Properties"
    4.      Select "MSDTC" tab
    5.      Click "Security Configuration"
    6.      Make sure you check "Network DTC Access", "Allow Remote Client",
    "Allow Inbound/Outbound", "Enable TIP" (Some option may not be
    necessary, have a try to get your configuration)
    7.      The service will restart
    8.      BUT YOU MAY NEED TO REBOOT YOUR SERVER IF IT STILL DOESN'T WORK
    (This is the thing drove me crazy before)

    On your client computer use the same above procedure to open the
    "Security Configuration" setting, make sure you check "Network DTC
    Access", "Allow Inbound/Outbound" option, restart service and computer
    if necessary.

    On you SQL server service manager, click "Service" dropdown, select
    "Distribute Transaction Coordinator", it should be also running on
    your server computer.

    Hope it helps,

    Eric
    Can anyone provide insight on how to script these changes so the changes can be made without using a GUI?
    Make everything as simple as possible, but not simpler.
    -Albert Einstein
    Tuesday, August 16, 2011 4:48 PM
  • This was the solution that did it for me; the last solution didn't work because my MSDTC tab didn't have all the options needed.  I will clarify that I was able to do it without changing the authentication setting.  Nice fix, thanks!
    Wednesday, November 02, 2011 7:39 PM
  • Hey, Currently we are also facing the same issue with one of our client. The client has disabled remote transactions in their environment. We did a POC to test the remote transactions: 1. Applied transaction on same server (server running the package and the server hosting the database are same) - SUCCESS 2. Applied transaction on different server (server running the package and the server hosting the database are different) - FAILS We suggested to implement the step Eric has suggested us. Thanks!! Eric :)

    Cheers!! Swapnil (03 Feb 2012)

    Hi Guys,

    Some more inputs after changing the settings.

    We have enabled Allow Remote Transactions on the server hosting the SQL Instance.

    Now the error has been changed

    from "The partner transaction manager has disabled its support for remote/network transactions"

    To "The transaction manager has disabled its support for remote/network transactions"

    Hence the remote server where the SQL Instance is running, is now allowing remote transactions but the local server where we want to use the transactions is not pointing to the DTC Service of the server hosting the SQL Instance.

    In short, there are 2 settings we need to check:

    1. The Server hosting the SQL Instance, should allow remote servers to use its DTC Service.

    2. The Server where the transactions are used, should point to the DTC of the server hosting SQL Instance.

    For point2, you can do point to by Adminstrative Tools -> Component Services -> My Computer Properties -> MSDTC -> Remote coordinator host name:_____

    Currently working on the point 2. Will update on the status. Thanks !!

    - Swapnil (11 Feb 2012)

    Friday, February 03, 2012 6:58 AM
  • this ended up working for me(run on server A):

    EXEC sp_serveroption @server = 'ServerB',@optname = 'remote proc transaction promotion', @optvalue = 'false' ;

    Thursday, September 20, 2012 8:15 PM
  • Thank you. Your solution was concise and worked right away. I wish I had read this before spending all that time reading other stuff.
    Thursday, November 29, 2012 4:14 PM
  • Hi All,

    For Windows 2008 server you can find the desired tab by following these steps:

    1.      Go to "Administrative Tools > Component Services"
    2.      On the left navigation tree, go to "Component Services > Computers
    > My Computer>Distributed Transaction Coordinator" (you may need to double click and wait as some nodes
    need time to expand)
    3.       Right click on "Local DTC", select "Properties"
    4.      Select "Security" tab
    5.      Make sure you check "Network DTC Access", "Allow Remote Client",
    "Allow Inbound/Outbound" (Some option may not be
    necessary, have a try to get your configuration)

    6.      The service will restart
    7.      BUT YOU MAY NEED TO REBOOT YOUR SERVER IF IT STILL DOESN'T WORK
    (This is the thing drove me crazy before)

    I hope this will help solve your problems.


    Vt - MCTS

    Tuesday, January 08, 2013 8:22 AM
  • Hi!!

    I have made the DTC related changes and rebooted the laptop as well but still same error message. I have sql server 2008 running on the same laptop where my code is running - so, no firewall related issues either.

    I have Windows 7 installed on my laptop.

    Any other ideas? 

    thanks so much for your time!



    • Edited by VK-0001 Wednesday, September 25, 2013 6:21 PM
    Wednesday, September 25, 2013 6:20 PM
  • Here's one example......

    declare @cmd varchar(4000)

    set @cmd='select * from openquery(oracledb,''select * from employeedata where hiredate>'''+convert(varchar,@dateof,101)+''')'''

    exec sp_executesql @cmd

    You can put numerous queries in there, use temporary tables, and then use the output.  It also lets you get around the limitation of OPENQUERY that prevents you from having dynamic commands.

    Lauren

    Wednesday, November 13, 2013 2:23 AM
  • Hi Eric,

    My client application is not on the same computer and your given solution perfectly works for me. But i have an issue here.

    I have such many Client applications and I don't want to do it manually on each machine separately.

    Is there a batch script or some generalized way which can enable all my application machines.

    Please suggest.

    Wednesday, May 21, 2014 10:55 AM