none
Cortana not working via Wi-Fi

    Question

  • Cortana can't seem to connect to the internet via Wi-Fi. IF Wi-Fi is on, it says "Interests aren't available at this time and can't connect for web searches.

    If I turn Wi-Fi off Cortana works fine through cellular data.

    Update: Enabling Wi-Fi Sense fixes the issue, so the bug seems to be tied to the Wi-Fi Sense setting.

    Update 2: It seems like enabling Wi-Fi Sense was just a fluke temp fix.

    It has NOT resolved my issue, and my phone is also rebooting itself about every 10 - 15 minutes now.


    I complete a hard re-set this afternoon and am having the same problems as before.
    • Edited by Thajor Tuesday, April 15, 2014 1:32 AM
    Monday, April 14, 2014 6:08 PM

All replies

  • I've enabled WiFi Sense to no solution, but turning Wifi off allows it to function as normal. Anyone else still having problems after enabling wifi sense?
    Monday, April 14, 2014 7:54 PM
  • Same here, I've tried enabling Wifi-Sense but didnt work out for me (and unfortunately I don't have mobile data either T_T ) 
    Monday, April 14, 2014 8:05 PM
  • From my thread on the developer side, has anyone tried Cortana from the live tile? It still didn't work for me, but someone from Microsoft suggested it.

    http://social.msdn.microsoft.com/Forums/wpapps/en-US/223ad106-7d56-455c-97f0-65476ba98ce6/cortana-cant-connect-when-attempting-to-use-voice-commands?forum=wpdevelop

    Monday, April 14, 2014 8:09 PM
  • Updated original post- It seems like enabling Wi-Fi Sense was just a fluke temp fix. It has NOT resolved my issue, and my phone is also rebooting itself about every 10 - 15 minutes now.

    I have tried Cortana from the Live Tile as well and get the same results. Strangely, Cortana can connect intermittently via Wi-Fi, but it seems completely random and most of the time will only work if I disable Wi-Fi.


    I complete a hard re-set this afternoon and am having the same problems as before.
    • Edited by Thajor Tuesday, April 15, 2014 1:32 AM
    Tuesday, April 15, 2014 1:31 AM
  • Well..That sucks !  My 520's working fine so far ( No issues whatsoever except the cortana bug )

    Also..You might wanna keep a eye here xD :http://forums.wpcentral.com/cortana/274947-cortana-cannot-connect-while-wifi.html

    Tuesday, April 15, 2014 2:57 AM
  • Turning WiFi off has resolved my rebooting issue, and also allows me to use Cortana.

    Hopefully a fix can be rolled out soon so that myself and others with the issue can get back to using WiFi.

    Tuesday, April 15, 2014 2:18 PM
  • I found this but am not changing my modems DNS settings due to my home setup if you're not bothered though you could try this

    http://forums.wpcentral.com/cortana/277008-fix-cortana-wifi-issue.html

    Thursday, April 17, 2014 12:42 AM
  • I'm not up for changing my modem's DNS settings either, but I did try changing DNS on my phone and was unable to get internet access that way.

    Thanks for the link; I'll keep an eye on it in case someone there comes up with another solution.

    Thursday, April 17, 2014 2:18 AM
  • I bit the bullet and decided to try OpenDNS. WiFi worked flawlessly on my phone... for a little less than half an hour... and then it rebooted itself again.

    It did resolve Cortana's Wi-Fi connection issue, but now Wi-Fi is off again so that I can have a stable phone.

    Thursday, April 17, 2014 6:19 AM