none
fatal error LNK1104: cannot open file 'C:\Documents.obj'

    Question

  • I have came across this error and i have tried several ways to debug according to what i have found on the web, for eg installing SDK, linking them etc.

    By the way, i am using VS2003. 

    'C:\Documents.obj' -> i don have this file path at all.

    Hope to get it solve ASAP, rushing for proj!
    THANKS

    Debugging err as followed: 

    ------ Build started: Project: faces, Configuration: Debug Win32 ------

    faces - up-to-date.



    ------ Build started: Project: faceview, Configuration: Debug Win32 ------

    Linking...

    LINK : fatal error LNK1104: cannot open file 'C:\Documents.obj'

    Build log was saved at "file://c:\Documents and Settings\L340c02\Desktop\libface-0.0.1-prealpha1\vcprj\cli\faceview\Debug\BuildLog.htm"

    faceview - 1 error(s), 0 warning(s)



    ------ Build started: Project: facecmp, Configuration: Debug Win32 ------

    Linking...

    LINK : fatal error LNK1104: cannot open file 'C:\Documents.obj'

    Build log was saved at "file://c:\Documents and Settings\L340c02\Desktop\libface-0.0.1-prealpha1\vcprj\cli\facecmp\Debug\BuildLog.htm"

    facecmp - 1 error(s), 0 warning(s)



    ------ Build started: Project: faceinit, Configuration: Debug Win32 ------

    Linking...

    LINK : fatal error LNK1104: cannot open file 'C:\Documents.obj'

    Build log was saved at "file://c:\Documents and Settings\L340c02\Desktop\libface-0.0.1-prealpha1\vcprj\cli\faceinit\Debug\BuildLog.htm"

    faceinit - 1 error(s), 0 warning(s)



    ------ Build started: Project: faceextract, Configuration: Debug Win32 ------

    Linking...

    LINK : fatal error LNK1104: cannot open file 'C:\Documents.obj'

    Build log was saved at "file://c:\Documents and Settings\L340c02\Desktop\libface-0.0.1-prealpha1\vcprj\cli\faceextract\Debug\BuildLog.htm"

    faceextract - 1 error(s), 0 warning(s)



    ---------------------- Done ----------------------

    Build: 1 succeeded, 4 failed, 0 skipped


    Thursday, July 03, 2008 5:13 AM

Answers

  • It looks like you have a path pointing to C:\Documents and Settings\...\ that is unquoted, and the space is causing the linker to look at the wrong folder. Wherever you have this path, put "quotes" around it.
    • Marked as answer by PEYTENG Friday, July 11, 2008 5:29 AM
    Thursday, July 03, 2008 5:15 AM
  • Somewhere you are telling the linker to look in C:\Documents and Settings\...

    Because it contains a space, the linker gets confused.

    You need to put quotes around it, like "C:\Documents and Settings\..." so that it treats it as one path.
    • Marked as answer by PEYTENG Friday, July 11, 2008 5:29 AM
    Thursday, July 03, 2008 6:07 AM

All replies

  • It looks like you have a path pointing to C:\Documents and Settings\...\ that is unquoted, and the space is causing the linker to look at the wrong folder. Wherever you have this path, put "quotes" around it.
    • Marked as answer by PEYTENG Friday, July 11, 2008 5:29 AM
    Thursday, July 03, 2008 5:15 AM
  • sorry but what you mean by putting a "quote". put where? in my coding? if yes, my whole coding doesnt have that "path"
    Thursday, July 03, 2008 5:20 AM
  • Somewhere you are telling the linker to look in C:\Documents and Settings\...

    Because it contains a space, the linker gets confused.

    You need to put quotes around it, like "C:\Documents and Settings\..." so that it treats it as one path.
    • Marked as answer by PEYTENG Friday, July 11, 2008 5:29 AM
    Thursday, July 03, 2008 6:07 AM
  • But i couldn't find any path in my coding or any other file. Actually, this project is downloaded from a website, is it possible that there are some missing files... Is it possible if you help me check it out yo. If not is alright. I really appreciate your help. THANKS!

    http://sourceforge.net/projects/openbio/

    Thursday, July 03, 2008 6:34 AM