none
setup project with Sql Ce 4 admin user rights issue

    Question

  • Hi , I have created a setup project and installing sql Ce database with the application .

    Application crashes when it try to access to the database and prompt that you haven't sufficient rights to access the database. So i set the AdminUser condition in the Luanch Conditions. But when i run the exe . It prompts each time to apply changes to the user machine. I also try with Privileged condition but same tedious prompts on each time when i run the exe. please suggest any solution.

    When i installed it into the D drive then there isn't any rights issue.

    Note: I am installing the application in AppData folder not in Program files


    • Edited by Nofil Asad Tuesday, July 23, 2013 8:52 AM
    Tuesday, July 23, 2013 6:24 AM

Answers

All replies

  • Hi , I have created a setup project and installing sql Ce database with the application . Application crashes when it try to access to the database and prompt that you haven't sufficient rights to access the database. So i set the AdminUser condition in the Luanch Conditions. But when i run the exe . It prompts each time to apply changes to the user machine. I also try with Privileged condition but same tedious prompts on each time when i run the exe. please suggest any solution.

    I also test this exe to another machine. There it runs without setting admin rights.

    Note: I am installing the application in AppData folder not in Program files

    Thursday, July 18, 2013 8:35 AM
  • Hi Nofil,

    Thank you for visiting the MSDN forum.

    I’m afraid that it is not the correct forum about this issue. I am moving your question to the moderator forum ("Where is the forum for..?"). The owner of the forum will direct you to a right forum.

    Thanks for your understanding.

    Regards,


    Lisa Zhu [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, July 19, 2013 6:12 AM
  • I think you should ask in the SQL Server Compact forum, as it's not a setup issue, or apparently a code issue.

    Karl


    When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer



    My Blog: http://unlockpowershell.wordpress.com
    My Book: Windows PowerShell 2.0 Bible
    My E-mail: -join ("6B61726C6D69747363686B65406D742E6E6574"-split"(?<=\G.{2})",19|%{[char][int]"0x$_"})

    Monday, July 22, 2013 2:23 PM
  • Hi;

    I have resolved this by changing the Application default folder location from CommonAppData folder  to UserAppData Folder


    Tuesday, July 23, 2013 10:03 AM