locked
Setting Tab Order in Visual Basic 2010 Express

    Question

  • Is there an easy way to set the tab order for controls on a form in Visual Basic 2010 Express?  I saw some references to a "View / Tab Order" menu item, but I don't see anything like this in the View menu when I am designing a form.
    Thursday, April 15, 2010 3:29 AM

Answers

  • Hi! I was having a hard time finding the tab order option in the view menu too in the Visual Basic 2010 express edition. I reset the toolbar and it didn't help.

    So, I had to add it manually.

    Here is what I did:

    1. Right click on the menu bar and choose customize.

    2. Click the commands tab.

    3. You'll see a phrase saying: Choose a menu or toolbar to arrange. Then a radio button with Menu bar: beside it. From here, choose View.

    4.Click Add command, from categories choose view, from commands choose tab order then click OK. Well, they're arranged alphabetically.

    5. Now click close and check the tab order button in the view toolbar and you'll find it.

    I hope this helps

    If you need anything just ask. I'm a total beginner. I'm still watching the beginner's videos.

    • Proposed as answer by Amira.3ezz Sunday, April 25, 2010 3:37 PM
    • Marked as answer by MikeSchumann Sunday, April 25, 2010 5:05 PM
    Sunday, April 25, 2010 3:34 PM

All replies

  • I don't have the Express version installed, but I have it under View | Tab Order.

    The documentation on it is here:

    http://msdn.microsoft.com/en-us/library/bd16a8cw(VS.80).aspx

    It does not have any notes regarding it being missing in the Express version. Have you tried resetting the menu?

    Right-click on the menu bar. Select Customize, then the Commands tab. Pick View and Modify Selection, then Reset.

    Hope this helps.

     


    www.insteptech.com ; msmvps.com/blogs/deborahk
    We are volunteers and ask only that if we are able to help you, that you mark our reply as your answer. THANKS!
    Thursday, April 15, 2010 3:39 PM
  • Hi! I was having a hard time finding the tab order option in the view menu too in the Visual Basic 2010 express edition. I reset the toolbar and it didn't help.

    So, I had to add it manually.

    Here is what I did:

    1. Right click on the menu bar and choose customize.

    2. Click the commands tab.

    3. You'll see a phrase saying: Choose a menu or toolbar to arrange. Then a radio button with Menu bar: beside it. From here, choose View.

    4.Click Add command, from categories choose view, from commands choose tab order then click OK. Well, they're arranged alphabetically.

    5. Now click close and check the tab order button in the view toolbar and you'll find it.

    I hope this helps

    If you need anything just ask. I'm a total beginner. I'm still watching the beginner's videos.

    • Proposed as answer by Amira.3ezz Sunday, April 25, 2010 3:37 PM
    • Marked as answer by MikeSchumann Sunday, April 25, 2010 5:05 PM
    Sunday, April 25, 2010 3:34 PM
  • Instead of all that manual stuff they said.  Go to Tools>Settings>Expert Settings.  I had the same problem because my VB express was set to Basic Settings.  Just change it to Expert Settings, VB will take a couple of secs to reset itself and you should be able to keep working.  I hope that helps you out.
    • Proposed as answer by emtint Tuesday, July 19, 2011 1:28 PM
    Wednesday, January 19, 2011 11:31 PM
  • It is in a toolbar by default, its included in the Layout toolbar as the last item, dont know why they removed it from the main menu though, pretty silly IMO.
    Monday, July 25, 2011 2:36 AM
  • That was perfect! Thank you for the help.
    Instead of all that manual stuff they said.  Go to Tools>Settings>Expert Settings.  I had the same problem because my VB express was set to Basic Settings.  Just change it to Expert Settings, VB will take a couple of secs to reset itself and you should be able to keep working.  I hope that helps you out.
    Thursday, September 15, 2011 1:45 AM
  • That was SO helpful!! Thank you soo much! I had no idea how to fix this. Your post totally helped! Thanks.
    Wednesday, October 24, 2012 3:39 PM