locked
general error c101008d: Failed to write the updated manifest to the resource of file... Access is denied.

    Question

  • I recently upgraded to Vista and having been tinkering with Visual C++ 2008 EE.

     

    When I first compile code (in Release of Debug mode) it works fine. However, next time I compile I get the error message above.

     

    The reason appears to be due to a Release (or Debug) folder being created in my Solution folder that is created with Read-Only attributes. If I delete this folder I can compile/run again but end up having to do this every time.

     

    How do I stop this folder being created [as read-only]? (and why is it necessary?)

    Saturday, January 05, 2008 7:46 PM

Answers

  • Hi,

     

    As far as I know, unlike the Read-only attribute for a file, the Read-only attribute for a folder is typically ignored by Windows, Windows components and accessories, and other programs. Thus, the cause of your problem seems not to be read-only attribute of Debug folder. In addition, I think you can read information at following website.

    http://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=301614

     

    Is the symptom and running environment the same as that in above link? Besides, do you install other third-party software which has effect on the building process?

     

    Hope this helps!

     

    Tuesday, January 08, 2008 9:00 AM

All replies

  • Hi,

     

    As far as I know, unlike the Read-only attribute for a file, the Read-only attribute for a folder is typically ignored by Windows, Windows components and accessories, and other programs. Thus, the cause of your problem seems not to be read-only attribute of Debug folder. In addition, I think you can read information at following website.

    http://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=301614

     

    Is the symptom and running environment the same as that in above link? Besides, do you install other third-party software which has effect on the building process?

     

    Hope this helps!

     

    Tuesday, January 08, 2008 9:00 AM
  • I am having the same problem except that I can not recompile under any circumstance, even if I delete the Debug/exe file, F7, F5 repeatedly. I have to abandon the project.  An additional observation is that I start with a simple application (CLR/Windows) compile/run, then add a menu strip, a few buttons and then recompile.  For me, Vista, C++ Express this is a repeatable problem and a show stopper until this is resolved.  Good luck in the lab.

     

    Friday, January 11, 2008 8:49 PM
  • If I add a menu strip, I lose the entire project and can not proceed. 

     

    Look at this in the Forms Designer

     

    To prevent possible data loss before loading the designer, the following errors must be resolved:
    1 Error
    Ignore and Continue
    Why am I seeing this page?
    C++ CodeDOM parser error: Line: 85, Column: 37 --- Internal Error
     
    Instances of this error (1)
    1.
    at Microsoft.VisualC.CppCodeParser.OnMethodPopulateStatements(Object sender, EventArgs e)
    at System.CodeDom.CodeMemberMethod.get_Statements()
    at System.ComponentModel.Design.Serialization.TypeCodeDomSerializer.Deserialize(IDesignerSerializationManager manager, CodeTypeDeclaration declaration)
    at System.ComponentModel.Design.Serialization.CodeDomDesignerLoader.PerformLoad(IDesignerSerializationManager manager)
    at Microsoft.VisualStudio.Design.Serialization.CodeDom.VSCodeDomDesignerLoader.PerformLoad(IDesignerSerializationManager serializationManager)
    at Microsoft.VisualStudio.Design.Serialization.CodeDom.VSCodeDomDesignerLoader.DeferredLoadHandler.Microsoft.VisualStudio.TextManager.Interop.IVsTextBufferDataEvents.OnLoadCompleted(Int32 fReload)
     
    Help with this error
    Could not find an associated help topic for this error. Check Windows Forms Design-Time error list
     
    Forum posts about this error
     

    Wednesday, January 23, 2008 6:09 PM
  •  

    try removing blank lines at the top of the header files and tinkering with the virus program scan settings.
    Thursday, March 06, 2008 6:57 PM
  • Hey,

    I had the same problem. I closed the solution. I cut everything that was in the Debug folder and deleted the folder. I created another folder with the same exact name and pasted the old stuff in that folder. It fixed my problem. As to why that works I have no idea, it just did, and that's all I cared about.

    -Kevin.
    Tuesday, October 21, 2008 8:12 PM
  • I just had the same problem, I am runing Norton 360 securty software, all i did was right click on the little Norton icon in the task bar and disabled fire wall and auto protect, i then recompiled and then renabled the fire wall and auto protect and it is still leting me recompile with out haveing to disable the fire wall and stuff again. you may have to disable it again if you shut down visual C++

    hope this helps
    Sunday, November 22, 2009 7:32 PM
  • Kevin,

    You are right. The problem is that the debug folder is set to Read Only always. I tried and reset it and it didn't unlock Read Only. I realized that it may be caused by the Documents folder, so I just created the project in my own folder as d:\Cpp\TestProject\ Now the problem just went away.

    Conclusion, don't create your project in the default Documents\Visual Studio 2008\... folder. By the way, I am using Vista.

     

    Xin,

     

    Monday, March 22, 2010 7:51 PM
  • Press rebuild instead of build

    I think the shortcut is Shift f7 (IDK)

    Tuesday, July 06, 2010 2:38 AM
  • I had this problem too, but whenever I got it an AVG Anti-Virus popup came up, I had to add mt.exe to the exceptions - twice.

    From then onwards I was able to complete the build process successfully.

    Hope this helps,

    Dan.

    Sunday, May 01, 2011 12:06 AM
  • I made a workaround which I think is not too terrible.

    A potential solution is to postpone the embedding. This can be achieved by doing this as a post-build event.
    http://msdn.microsoft.com/en-us/library/ms235591(v=vs.80).aspx gives and explains the required command and explains embedding a manifest inside a C/C++ application.
    The normal option to embed the manifest is switched of, first.

    For an executable, the command line given is: mt.exe –manifest MyApp.exe.manifest -outputresource:MyApp.exe;1. For a dll, the ending number is 2.
    For complex makes, be sure to read the msdn link above for additional information.
    Alternatively, esp. in the case of an incremental link, convert the manifest to a resource first and use the linker (again, incrementally) to embed the resource.
    Clearly,
    MyApp.exe can be replaced by the macro $(OutDir)\$(TargetFileName).

    So, postbuild mt.exe –manifest $(OutDir)\$(TargetFileName).manifest -outputresource:$(OutDir)\$(TargetFileName);1 works for me.

    Hope this helps you guys too,

    Jan

     
    Saturday, May 12, 2012 7:34 PM