none
Windows 8 SyncToy 2.1 Task Scheduler error

    Question

  • When I run SyncToy from a scheduled task in windows 8 I get the following error:

     Failed to execute folder pair Pictures. Could not locate folder \\Computer\Pictures 

    This pops up in a command window very quickly, then goes away.  History says it completed successfully, but it didn't sync a file I just put up.

    I have tried running it in all of the 3 modes available (Windows 8, Windows 7..., and Vista)

    The task shows "Incorrect Function 0x80070001" next to it.

    If I run SyncToy from the GUI it works without errors.  If I cut and past the same command from Task Scheduler into a command window it works fine. Just getting this error when running from a sheduled task.  I have the -R switch in the command line and also the right permissions on both folders.  Any help would be greatly appreciated.

    Thank you,

    Jim



    -Jim

    Monday, November 19, 2012 3:57 PM

All replies

  • I have the same 0x8007001 issue but with server 2012.

    I am running with the -R switch but no joy. Running via the GUI is fine.

    I have also tried calling a batch file with the contents of "C:\Program Files\SyncToy 2.1\SyncToy.bat" -R. That too runs if i simply double click it but has the same 0x80070001 if called from task scheduler.

    Thanks

    Mark

     

    • Proposed as answer by Technogenii Thursday, January 03, 2013 6:32 PM
    Monday, November 19, 2012 8:15 PM
  • I have the same issue too. I have a scheduled task that runs every night to do a backup. It appears that although the task is set to run as my user it actually runs as the default user as I am seeing this in the SyncToy log file:-

    SYNC: 12/02/2012 02:00:06:618: -------------------------------------------------------------------------
    SYNC: 12/02/2012 02:00:06:821: Starting SyncToyCmd, version 2.1.0.0, built 19/10/2009 04:04:38.
    SYNC: 12/02/2012 02:00:06:977: *** SyncToy configuration file C:\Users\Default\AppData\Local\Microsoft\SyncToy\2.0\SyncToyDirPairs.bin not found.

    The log file is in the hidden Default user folder. If I look in my own user folder:-

    C:\Users\Mark\AppData\Local\Microsoft\SyncToy\2.0

    The required SyncToyDirPairs.bin file is there. I'm not sure whether the problem is with SyncToy or Windows 8. The fact that this used to work fine under Windows 7 is suspect it's probably a Windows 8 issue.

    Anyone got any ideas/workaround?

    Best Regards,

    Mark

     

    • Proposed as answer by Technogenii Thursday, January 03, 2013 6:32 PM
    Sunday, December 02, 2012 3:07 PM
  • I have the same issue, and discovered the same thing as Mark. I copied the SyncToyDirPairs.bin from my Admin account (under which the task is set to run) to the Default users folder. Now I get this:

    SYNC: 12/18/2012 06:05:49:677: *** SyncToyCmd has detected that the folder pair XXXXX
    Backup has not been synchronized yet. Please run SyncToy.exe to complete the initial
    synchronization.

    Fine; can I even do that? How do you logon as the Default user?!

    • Proposed as answer by Technogenii Thursday, January 03, 2013 6:32 PM
    Tuesday, December 18, 2012 2:10 PM
  • Good to know i'm not the only one having this issue. I had an online session with Microsoft the other day and the adviser wasn't particularly helpful. He said he will pass this onto the relevant department to investigate but i'm not going to hold my breath. Still not sure if this is a Synctoy issue or a Windows 8 issue or possibly a combination of both. Quite annoying really as my automated backups are now stuffed :-(
    • Proposed as answer by Technogenii Thursday, January 03, 2013 6:32 PM
    Friday, December 21, 2012 1:27 PM
  • ok just done a bit more investigation and here is what I have found. The scheduled task that I am using doesn't reference SyncToy directly, it is actually run from a batch file. I have just amended the batch file as follows:-

    @echo off
    echo SyncToy Log starting at %time:~0,8% on %date%
    echo Running as user: %username% <=== Added this line to see what user we are running as
    echo.

    when the scheduled task runs without me being logged in the log file generated shows this:-

    SyncToy Log starting at 13:50:00 on 21/12/2012

    Running as user: Mark

    So, it appears the scheduled task is running under my user, however, SyncToy seems to be ignoring this fact and is using the "default" user as the error is saying:-

    SYNC: 12/02/2012 02:00:06:618: -------------------------------------------------------------------------
    SYNC: 12/02/2012 02:00:06:821: Starting SyncToyCmd, version 2.1.0.0, built 19/10/2009 04:04:38.
    SYNC: 12/02/2012 02:00:06:977: *** SyncToy configuration file C:\Users\Default\AppData\Local\Microsoft\SyncToy\2.0\SyncToyDirPairs.bin not found.

    So could it be that something has changed with the way scheduled task are passing user info to the program. As I said before this works perfectly under Windows 7.

    Anyone from Microsoft care to comment? Anyone found a workaround?

    • Proposed as answer by Technogenii Thursday, January 03, 2013 6:32 PM
    Friday, December 21, 2012 2:08 PM
  • I have the same issue with a Server 2012 an SyncToy 2.1 (x64).

    I set up a synctoycmd.exe -R job, and it runs just fine in GUI or from Task Scheduler as my core admin user; when I set the task to run as my joe.backup user, it gives the "incorrect function" error.

    Using Task Scheduler as joe.backup when running wbadmin task runs just fine.


    John Weber [Lync MVP]


    • Edited by John WeberMVP Friday, December 28, 2012 5:41 PM typo
    • Proposed as answer by Technogenii Thursday, January 03, 2013 6:32 PM
    Friday, December 28, 2012 5:37 PM
  • I'm also having the exact same issue with Windows 8 and SyncToy. I get the "incorrect function" error.

    My solution was to stop using SyncToy and use the new "File History" feature in Windows 8.  File History saves copies of your files to an external hard drive or network location.

    http://www.hanselman.com/blog/Windows8Step0TurnOnContinuousBackupsViaFileHistory.aspx

    I hope this helps.

    • Proposed as answer by Technogenii Thursday, January 03, 2013 6:32 PM
    Saturday, December 29, 2012 3:59 AM
  • It's pretty simple actually - SyncToy does't work on Windows 8 :(

    From the Download page: (I can't post links yet because my account is new)

    Supported operating systems: Windows 7, Windows Vista, Windows XP

    Microsoft .NET Framework v2.0
    1GHz Intel P3 processor or equivalent
    256MB RAM, 512MB RAM recommended
    20MB free disk space

    Thursday, January 03, 2013 6:35 PM
  • I don't think so, I'm using x64 on Win8 and everything is working fine. I have never encountered said problems and the task scheduling works as intended, but I only use one user account.

    There must be an issue with different users and their respective paths for the config files as some people above have described...

    Tuesday, January 22, 2013 12:38 PM
  • Potential fix.... Here is how I got around this.  I am running Windows 8 64.

    I ran the task from command, and noticed that my foreign drive wasn't found, despite the fact explorer can see it fine.

    Firstly I set the SyncToy task to run as 'Configure for Windows 8' in the General tab in the task scheduler.  This won't fix it, but don't want it set to anything else.

    Then I changed my foreign mapped drive which was mapped as a network drive in explorer (Z: drive in my case), a network path //Unicorn using the browse to network option in the explorer window when choosing a pair.... if that all makes sense.

    In short that fixed it.

    Tell me how you get on.

    Dave.

    • Proposed as answer by DaveyB(UK) Friday, February 01, 2013 7:52 PM
    Friday, February 01, 2013 7:52 PM
  • ^^^

    this worked for me too. thanks.

    Tuesday, June 25, 2013 6:30 PM
  • Potential fix.... Here is how I got around this.  I am running Windows 8 64.

    I ran the task from command, and noticed that my foreign drive wasn't found, despite the fact explorer can see it fine.

    Firstly I set the SyncToy task to run as 'Configure for Windows 8' in the General tab in the task scheduler.  This won't fix it, but don't want it set to anything else.

    Then I changed my foreign mapped drive which was mapped as a network drive in explorer (Z: drive in my case), a network path //Unicorn using the browse to network option in the explorer window when choosing a pair.... if that all makes sense.

    In short that fixed it.

    Tell me how you get on.

    Dave.

    Changing from the Map Drive (S:\Folder\) to the network path (\\NAS\folder\) worked!
    Friday, August 30, 2013 8:53 PM
  • Hi to all, I tried to put bellow arguments in "Start in(optional)" this "C:\Program Files\SyncToy 2.1" and worked fine !

    Thanks to all 

    Sunday, September 15, 2013 6:13 PM