locked
HTTP Status 417: Expectation Failed

    Question

  • Hi,

    Hope someone knows the solution to this problem as it's driving me insane !

    I have Visual Studio Pro 2005 installed.  I do NOT have the local MSDN installed.   I want to use online version only.

    Whenver I go to the help I get "Information not found".   Document explorer is configured to use "Online first, then local".

    If I hit the search button and enter a search string I get the error message below:
    Search Failed.
    The request failed with HTTP Status 417: Expectation failed.

    If I try to 'download provider list' in the help options I get error message :
    Unable to retrieve resources from the MSDN service.

    The start page loads the MSDN without problem - as does my web browser.

    I have proxy configuration script - have tried some suggestions on here for that but they don't seem to be related to this error message.

    Any ideas anyone ??
    Monday, March 06, 2006 2:15 PM

Answers

  • Hi,

    It seems that this error can also occur on some proxies that don't support "100 continue" expectation. The workaround is to add the following to the dexplore.exe.config file.

    <configuration>

    <system.net>

    <settings>

                <servicePointManager expect100Continue="false" />

    </settings>

    </system.net>

    </configuration>

     

    --

    Regards,

    Saurabh

    Monday, March 20, 2006 9:12 PM

All replies

  • I am experiencing the same problem. If you find a solution, please let me know.
    Friday, March 10, 2006 9:43 AM
  • Can you describe your proxy environment, i.e. whether it is ISA or Squid or something else? Also, does it require authentication when browsing in IE?

    --
    Regards,
    Saurabh

    Wednesday, March 15, 2006 1:52 AM
  • Researching on the internet, it seems that some ad-blocking/SOAP blocking proxies result in the HTTP 417 errors. Following is an example of it.

    http://support.sourcegear.com/viewtopic.php?p=373#373

    Is it possible that proxies you are using are using one of blocking mechanisms? Help Search using Web Service calls and will fail if SOAP message is blocked.

    --
    Regards,
    Saurabh

     

    Thursday, March 16, 2006 8:56 PM
  • Hi,

    It seems that this error can also occur on some proxies that don't support "100 continue" expectation. The workaround is to add the following to the dexplore.exe.config file.

    <configuration>

    <system.net>

    <settings>

                <servicePointManager expect100Continue="false" />

    </settings>

    </system.net>

    </configuration>

     

    --

    Regards,

    Saurabh

    Monday, March 20, 2006 9:12 PM
  • That works perfectly!   Many thaks again Saurabh.
    Tuesday, March 21, 2006 8:22 AM
  • Now my MSDN C# 2005 Explorer is faster.

    But I cannot download the provider list. A messagebox displays : "Error getting Codezone Community sites. Configuration Sytsem Failed to inizialize."

     

    Help me  

    Tuesday, October 02, 2007 2:51 PM
  • its work for me
    great thank you
    Tuesday, April 06, 2010 9:14 AM
  • Thanks for this worked for me also. What I don't understand is why this is necessary when I've not changed my proxy settings in any way whatsoever...? Is it possibly due to a Windows patch, I'm still on good old WinXP SP3.

    Anyway thanks for the assistance. Rob

    Thursday, May 27, 2010 3:42 AM
  • Thanks for the answer. Its worked fine
    Thursday, May 27, 2010 6:26 AM
  • thanks a lot, this solved the error still confuse about working. well  at least working
    Sachin Kalra
    Friday, September 17, 2010 6:42 AM
  • Thanks for the answer. Its worked fine
    Tuesday, February 15, 2011 5:28 AM
  • Hi. I added these lines to the web.config of my WCF project but the services still give me the 417 protocol error.
    Friday, June 24, 2011 4:58 PM
  • Hi Saurabh,

    I have tried above solution and also tried to modify devenv.exe.config file with:

    <defaultProxy useDefaultCredentials="true" enabled="true">         
       <proxy usesystemdefault="True" />       
      </defaultProxy>

    For my problems I do not see either of them are working. I am using VS2010 SP1 REL on Windows7. I am facing similar two issues:

    1) Could not search in online Galary in Extension Manage, error says "Cannot search for online extensions becuase an error occured while trying to contact the server.", though I am on firewall with restrictions enforced by windows authentication.

    2) On the Start Page (VS2010) in Latest News section, I amnot able to browse on of the RSS feed. I have alos check with different RSS provided on asp.net website. also I have tried setting up diffrent options in Tools-Options-Environment-Startup etc. but no luck.

    I hope to hear from you soon. Thanks!

     

    Monday, June 27, 2011 3:20 PM
  • KB 910804 explains where to find the dexplore.exe.config file, although it doesn't seem to know about 64-bit versions, so the path may need appropriate changes to compensate for this.
    Answering policy: see profile.
    Wednesday, November 23, 2011 10:11 AM
  • For Visual Studio 2008, the file you must change is the devenv.exe.config - then insert the <servicePointManager expect100Continue="false" /> under the <system.net> and <settings> tags.
    Tuesday, August 07, 2012 2:28 PM