none
ReportViewer Display Problem in Web Page

    Question

  • Hello!
    I have a web page with just shows a report via a ReportViewer object. Whenever I view the web page from http://localhost:12345/mypage.aspx, the report shows up perfectly. However, after deploying the website and viewing it from http://computername/mypage.aspx, the toolbar shows up but the report is completely blank. What's more odd is that IE spams a bunch of errors (here's the first several):
    Error: 'RSClientController' is undefined
    Error: 'ReportViewerHoverButton' is undefined
    Error: 'document.getElementById(...).Controller' is null or not an object
    Error: 'ReportViewerHoverButton' is undefined
    I have no idea why the report is being displayed from one access point and not the other. Any ideas / help? Thanks in advance!
    -Scott
    Friday, July 31, 2009 11:31 PM

Answers

  • Well, I just got my problem solved! Here are the steps for fixing the problem (steps apply to IIS 7):

    Highlight your application/directory under [computer_name] --> Sites --> Default Web Page
    From the right-hand panel, click on Basic Settings.
         Switch to Class .NET AppPool
         Click on Connect As --> Specific User --> put in someone's credentials
    From the main panel (aka from Features View), double-click on Authentication
         Anonymous Authentication --> set to Enabled
         ASP.NET Impersonation --> set to Enabled

    Thanks Brad for your help though! I appreciate it!
    -Scott
    • Marked as answer by BustAmOVe274 Friday, August 07, 2009 9:03 PM
    Friday, August 07, 2009 9:03 PM

All replies

  • Not sure what is going on, but it sounds like the image objects are not downloading. Is there a setting in the web.config or asp.net that could be blocking images? (I do not know of one). Also make sure the Report Viewer is installed on the second computer.
    Brad Syputa, Microsoft Reporting Services This posting is provided "AS IS" with no warranties.
    Wednesday, August 05, 2009 4:43 PM
  • Hey Brad, thanks for the response!
    I'm not sure where I would look in the web.config file: I briefly went through the file and nothing about downloading images/objects was there. And I'm viewing the web page on the computer where it was built and the Report Service is running.
    Any other suggestions? Thanks again!
    -Scott
    Friday, August 07, 2009 7:03 PM
  • Well, I just got my problem solved! Here are the steps for fixing the problem (steps apply to IIS 7):

    Highlight your application/directory under [computer_name] --> Sites --> Default Web Page
    From the right-hand panel, click on Basic Settings.
         Switch to Class .NET AppPool
         Click on Connect As --> Specific User --> put in someone's credentials
    From the main panel (aka from Features View), double-click on Authentication
         Anonymous Authentication --> set to Enabled
         ASP.NET Impersonation --> set to Enabled

    Thanks Brad for your help though! I appreciate it!
    -Scott
    • Marked as answer by BustAmOVe274 Friday, August 07, 2009 9:03 PM
    Friday, August 07, 2009 9:03 PM
  • Well, I just got my problem solved! Here are the steps for fixing the problem (steps apply to IIS 7):

    Highlight your application/directory under [computer_name] --> Sites --> Default Web Page
    From the right-hand panel, click on Basic Settings.
         Switch to Class .NET AppPool
         Click on Connect As --> Specific User --> put in someone's credentials
    From the main panel (aka from Features View), double-click on Authentication
         Anonymous Authentication --> set to Enabled
         ASP.NET Impersonation --> set to Enabled

    Thanks Brad for your help though! I appreciate it!
    -Scott

    Thank you so so much!!! this helped me. I was going nuts with copying dlls, install/uninstall rv ctrl, modify web.config...so many things I tried...and after so many hours i found this...I just pick the othre from the two "seamless" option and it worked on my server, on clients as well.....

    thank you again
    Saturday, August 22, 2009 5:32 PM
  • Thank you so much! saved me hours of intense hair scratching and furniture destruction :D
    Thursday, December 01, 2011 12:30 AM